summaryrefslogtreecommitdiff
path: root/libre/libxfce4ui/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libxfce4ui/PKGBUILD')
-rw-r--r--libre/libxfce4ui/PKGBUILD81
1 files changed, 68 insertions, 13 deletions
diff --git a/libre/libxfce4ui/PKGBUILD b/libre/libxfce4ui/PKGBUILD
index 20f35ac54..63a1ccd7d 100644
--- a/libre/libxfce4ui/PKGBUILD
+++ b/libre/libxfce4ui/PKGBUILD
@@ -1,19 +1,23 @@
-# Maintainer (Arch): Evangelos Foutras <evangelos@foutrelis.com>
-# Contributor (Arch): Xavier Devlamynck <magicrhesus@ouranos.be>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Maintainer (arch): Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Xavier Devlamynck <magicrhesus@ouranos.be>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# parabola changes and rationale
# - rebranded "about" modal
+# - pin to strongly-coupled dependency versions
pkgname=libxfce4ui
-pkgver=4.16.0
+pkgver=4.18.4
pkgrel=1
+_pkgver_i686=4.18.3
+_pkgrel_i686=1.0
+eval "[[ -v _pkgver_${CARCH} ]] && pkgver=\$_pkgver_${CARCH}" # our different arches do not
+eval "[[ -v _pkgrel_${CARCH} ]] && pkgrel=\$_pkgrel_${CARCH}" # always roll at the same speed
pkgrel+=.parabola1
-pkgdesc="Commonly used Xfce widgets among Xfce applications"
-pkgdesc+=" (Parabola rebranded)"
+pkgdesc="Widgets library for the Xfce desktop environment"
arch=('x86_64')
arch+=('armv7h' 'i686')
url="https://www.xfce.org/"
@@ -22,26 +26,77 @@ depends=('libxfce4util' 'gtk3' 'xfconf' 'libsm' 'startup-notification'
'libgtop' 'libepoxy' 'hicolor-icon-theme')
makedepends=('intltool' 'gobject-introspection' 'vala')
source=(https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
-sha256sums=('8b06c9e94f4be88a9d87c47592411b6cbc32073e7af9cbd64c7b2924ec90ceaa')
+sha256sums=('87eefe797c6d26de3f754de48872faf131f1b5fc93fb88e22f5c7886a842cb4c')
+_sha256sum_i686='afa3a46eeed3ab612d2f7e1308edaf5819f6c33ccc16c13080efabd58f010abd'
+eval "[[ -v _sha256sum_${CARCH} ]] && sha256sums[0]=\$_sha256sum_${CARCH}" # upstream source-ball
+
+
+_version_constraint() # (dep_pkgname [precision])
+{
+ Log() { [[ "${FUNCNAME[2]}" == package ]] && echo "$@" >&2 || : ; }
+
+
+ local dep_pkgname=$1
+ declare -i req_precision=$2
+ local full_version=$(pacman -S --print-format='%v' ${dep_pkgname} 2> /dev/null | tail -n 1)
+ local n_dots=$(tmp=${full_version%-*} ; tmp=${tmp//[^\.]} ; echo "${#tmp}" ;)
+ local def_precision=$(( n_dots + 1 ))
+ local is_prec_valid=$(( req_precision > 0 && req_precision <= def_precision ))
+ local precision=$((( is_prec_valid )) && echo ${req_precision} || echo ${def_precision})
+ local pkgver_rx='[0-9A-Za-z_]+'
+ pkgver_rx=$(sed 's|\]|\+]|' <<<${pkgver_rx}) # according to the wiki, '+' is not allowed,
+ # but some pkgver have it (eg: 5.15.10+kde+r130)
+ local subver_rx='\.'${pkgver_rx}
+ local pkgrel_rx='[0-9]+'
+ local garbage_rx='[^0-9].*'
+ local capture_rx=${pkgver_rx}
+ for (( n_dots=1 ; n_dots < precision ; ++n_dots )) ; do capture_rx+=${subver_rx} ; done ;
+ local version pkgrel has_dot_char version_min version_max constraint_string
+ declare -i subver subver_inc pkgrel_inc
+
+ if [[ "${full_version}" =~ ^(${capture_rx})(${subver_rx})*-(${pkgrel_rx}).*$ ]]
+ then version=${BASH_REMATCH[1]} # pkgver cut to the requested precision
+ #unused=${BASH_REMATCH[2]} # discarded pkgver segments
+ pkgrel=${BASH_REMATCH[3]} # pkgrel with non-numerics right-trimmed
+ has_dot_char=$([[ "${version}" =~ \. ]] ; echo $(( ! $? )) ; )
+ subver=$(sed "s|${garbage_rx}||" <<<${version##*.}) # right-trim from any non-numeric
+ version=$( (( has_dot_char )) && echo ${version%.*}.${subver} || echo ${subver} )
+ subver_inc=$(( subver + 1 ))
+ pkgrel_inc=$(( pkgrel + 1 ))
+ version_min=$( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel} || \
+ echo ${version} )
+ version_max=$( ( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel_inc} ) || \
+ ( [[ "${version}" =~ \. ]] && echo ${version%.*}.${subver_inc} ) || \
+ echo ${subver_inc} )
+ constraint_string="${dep_pkgname}>=${version_min} ${dep_pkgname}<${version_max}"
+
+ Log "Applied version constraint: '${constraint_string}'"
+ else Log "ERROR: in _version_constraint() parsing: dep_pkgname='${dep_pkgname}' full_version='${full_version}'"
+ exit 1
+ fi
+
+ unset -f Log
+
+ echo -n "${constraint_string}"
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --libexecdir=/usr/lib \
--localstatedir=/var \
- --disable-static \
--disable-debug \
--with-vendor-info='Parabola GNU/Linux-libre'
make
}
package() {
- # pin to tightly-coupled dependency versions
- depends+=( "xfce4-session=${pkgver}" )
+ # pin to current 'xfce4-session' (versions do not always align)
+ depends+=($(_version_constraint 'xfce4-session' 3))
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}