summaryrefslogtreecommitdiff
path: root/libre/linux-libre-64/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-64/PKGBUILD')
-rw-r--r--libre/linux-libre-64/PKGBUILD166
1 files changed, 116 insertions, 50 deletions
diff --git a/libre/linux-libre-64/PKGBUILD b/libre/linux-libre-64/PKGBUILD
index b5fa0094d..f93d67f01 100644
--- a/libre/linux-libre-64/PKGBUILD
+++ b/libre/linux-libre-64/PKGBUILD
@@ -1,5 +1,54 @@
-# Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-# Feel free to push modifications or take over maintainership
+# Maintainers: Parabola hackers <dev@lists.parabola.nu>
+
+# Rationale: This package enables to run 64bit kernels with 32bit rootfs.
+#
+# For armv7k/aarch64, we have no aarch64 port yet, and the 32bit
+# kernels don't work for 64bit computers (for instance the dtb for
+# 64bit computers are not shipped).
+#
+# In turn if we can boot Parabola on these computers, it enables
+# people to work on an aarch64 port more easily as chrooting in 64bit
+# rootfs from 32bit rootfs work when we have a 64bit kernel (tested on
+# an x86_64 computer with a Parabola i686 rootfs and a Parabola x86_64
+# chroot).
+#
+# This enable to make rootfs that work on both 64bit and 32bit
+# computers. In that case the user will still need to select the right
+# kernel at boot.
+#
+# Generally speaking it also enable users to benefit from many of the
+# improvements of 64bit kernels (ability to chroot in 64bit rootfs,
+# better security, 4GiB address space per process instead of 3GiB for
+# 32bit rootfs, etc) without having to reinstall everything. In
+# addition, there was and is still no conversion guide to convert a
+# 32bit Parabola installation to 64bit), and in some cases (lot of
+# self-built software in /usr/local, PostgreSQL database, etc) the
+# migration to 64bit requires some work.
+#
+# As for using i686 for new installation on x86_64 computers, it can
+# enable people doing that to find and fix bugs on Parabola i686 to
+# enable people with 32bit-only computers (like Libreboot compatible
+# I945 Thinkpads) to still be able to use Parabola.
+#
+# Having both architectures (arm and x86) in the same PKGBUILD enables
+# to more widely test this package (if we find issues on x86, they'll
+# most likely apply to arm as well). Though it can become a problem if
+# we need different kernel versions for both architectures.
+#
+# Status:
+# - Tested on both arm and x86.
+# - The build is currently broken on ARM due to a missing cross
+# compiler for armv7h (it was accidentally removed and it doesn't
+# build anymore).
+# - External modules (like Wireguard or tp_smapi) also need to be
+# cross compiled. So modules for linux-libre-64 need to be added
+# (like tp_smapi-64) and dkms packages need to be adapted to also
+# work for this kernel.
+# - Some software (like building Guix) break with 32bit rootfs and
+# 64bit kernels due to wrong assumption about the number of bits,
+# through other software (like building rust with mrustc) work
+# better (here because we have 3GiB instead of 3GiB of memory per
+# process). Most software is not affected though.
# Based on the linux-libre package
@@ -8,27 +57,27 @@ _replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-64
-pkgver=5.7.2
-pkgrel=3
-pkgdesc='64bit Linux-libre for Parabola $CARCH'
-rcnver=5.7.2
-rcnrel=armv7-x9
+pkgver=5.15.12
+pkgrel=1
+pkgdesc="64bit Linux-libre for Parabola $CARCH"
+rcnver=5.11.11
+rcnrel=armv7-x14
url='https://linux-libre.fsfla.org/'
-arch=(armv7h i686 )
+arch=(armv7h i686)
license=(GPL2)
conflicts_armv7h=('linux-libre-aarch64')
replaces_armv7h=('linux-libre-aarch64')
conflicts_i686=('linux-libre-x86_64')
replaces_i686=('linux-libre-x86_64')
makedepends=(
- bc kmod libelf pahole
+ bc kmod libelf pahole cpio perl tar xz
xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
)
makedepends_i686+=('x86_64-pc-linux-gnu-gcc')
makedepends_armv7h=(uboot-tools vboot-utils dtc) # required by linux-libre-chromebook
makedepends_armv7h+=('aarch64-linux-gnu-gcc-initial')
options=('!strip')
-_srcname=linux-5.7
+_srcname=linux-5.15
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
"https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
@@ -44,9 +93,17 @@ source=(
# https://labs.parabola.nu/issues/877
# http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
0002-fix-Atmel-maXTouch-touchscreen-support.patch
- # extracted patches from Arch Linux kernel sources
+ # Arch Linux patches
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- sphinx-workaround.patch
+ 0002-PCI-Add-more-NVIDIA-controllers-to-the-MSI-masking-q.patch
+ 0003-iommu-intel-do-deep-dma-unmapping-to-avoid-kernel-fl.patch
+ 0004-cpufreq-intel_pstate-ITMT-support-for-overclocked-sy.patch
+ 0005-Bluetooth-btintel-Fix-bdaddress-comparison-with-garb.patch
+ 0006-lg-laptop-Recognize-more-models.patch
+)
+source_i686=(
+ # avoid using zstd compression in ultra mode (exhausts virtual memory)
+ no-ultra-zstd.patch
)
source_armv7h=(
# RCN patch (CM3 firmware deblobbed and bloatware removed)
@@ -69,9 +126,9 @@ validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('4805b2956f628c6581e86d67b1996b5b404e7f4b5d29ecfe708ddca45344571d75018364d8f0049835d4286ca1ba591307be263536d1bed0ea006696a8b8ac73'
+sha512sums=('3c586054285ea0cb4d1a1ff257757d092db80c2413dcec6e58c63b22490d42b8f2c441cee62839603599d5ad75fbd7560bf51ec6c2f3ab9354adae0c2c7234e5'
'SKIP'
- '73051904152f286189a29ee900d8717ae66f16b650a459647bcfb4290aee871e446684114703e59c7cf19fe443d57496af584e756a6efc3659be8f9b811b90fb'
+ '80a0d8903c6ee462f966e3360d22f4894dc69239c99ef28d62a1ea6643008580a368b61cee5e6691f2bbf0ff162fb10e13ca31904ab89a5e679f91ae9860999b'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -79,30 +136,35 @@ sha512sums=('4805b2956f628c6581e86d67b1996b5b404e7f4b5d29ecfe708ddca45344571d750
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
+ '4d20c1d0eed64bc64ac04e41e10288259212e00bc0967887e20e5ae277735d3a036c0a5ded08276455d2748af5787ebcf910329491eb43e84c204d6a9d76065f'
+ '51de84caf459ba526afaf11ce9e4b697bc828edaf841c512ee0438ed14b7c3beaa269f95446eeb6b6a87f91b20d075b43dfea901b6aed8ef45a476bc5ac6a3b2'
+ '51e8b4da770067e8257d292622d865cb16ac57fdfd8967bdfb74efec197dae9eab958e5637a728640ae60885bdde41c06c8076227a4f83db0b752215f91f3a87'
'53103bf55b957b657039510527df0df01279dec59cda115a4d6454e4135025d4546167fa30bdc99107f232561c1e096d8328609ab5a876cf7017176f92ad3e0b'
'167bc73c6c1c63931806238905dc44c7d87c5a5c0f6293159f2133dfe717fb44081018d810675716d1605ec7dff5e8333b87b19e09e2de21d0448e447437873b'
'bb6718984a7357c9b00c37e4788480e5b8b75018c172ecc1441bc3fc5d2d42444eb5d8c7f9d2e3a7d6fed6d03acb565e3c0559486e494c40a7fe6bd0570c9ede'
'143dea30c6da00e504c99984a98a0eb2411f558fcdd9dfa7f607d6c14e9e7dffff9cb00121d9317044b07e3e210808286598c785ee854084b993ec9cb14d8232'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- 'cbb533ae0bd68566e10fbf55fedd81374905ab301fc5d2a34a44a93a5346d9a70157a4a3323406c5baf7410841149dd6e0ef98559368623cc96fc2175b7ca5ed'
- '98e97155f86bbe837d43f27ec1018b5b6fdc6c372d6f7f2a0fe29da117d53979d9f9c262f886850d92002898682781029b80d4ee923633fc068f979e6c8254be')
-sha512sums_armv7h=('e0f456a12a9959ec1d2d670ef16dca7e1878f1d5291ac30c7fbcca8bc7f69e9820c9fe7589a70515a462376dcdb034176a2834bc7b12bc64398e1c66a6e217ae'
+ '5ad31d899fa56b49efb6eec6d721e85e1b723f65c83a9aaec52c3281f1862c7b0ccf5ddac077af669aa222b4818c4ddbc64f39739fc2946c5ddab49101ba0924'
+ 'c12a450a5026216676bd5728b43e04641d28a0eacd916e9304b6c38b03699005cf74ed8d3e4de67cab73f47cdaef728fdb1f75b3b1e5221cfc62c2a37e52ff67'
+ '65f4ecc64551d3e644fb6e95ed70dcb694aedd58fc6bed694a912c6d89bfdfd2382d1f20c3b79c0a9e6f5c479efe7e950e47f88b10925ac71276e4cad94ab07e'
+ '5b052dfc8f62ac2f86b1a08620109ec06154273a67ef011b18d38f7098b5b42026da2a8ba79a9234d10766bc00f740a2ce900552806a49937b7e33a35bca2809'
+ '6f139510d047cf0f915daded5221ea4cf2551ebb50c7350965ba417b9b2d0df8796e0508d772cdc6d50cdc5b8c1d8589ace86d6e7a779ea2abed0013696396a3'
+ 'e54423a3f0162f76cd211706c48f05f4fd96ea99453ca84821018947dd05b3d1bb943c8ba9e5ce190d237663136122601e7edfe50540fef24ab16c813c6a02e1')
+sha512sums_i686=('3a346ff5e0fdefafd28bc3dd0e4b6cd68e3f0014e59d1611d99f2edb8d074fd32649eeb0894a7e340e4f907b5cfc0e08e0753e0427a68dc113bb22835a892968')
+sha512sums_armv7h=('a4aa00ca3f03d524d3fb6379116c4e4e7908e7c30f6347f55be256c44d806d8db5f04c96369d5a725e45b7390e9fde842f388cdc5d5699d80ec5d1519f7367f4'
'SKIP'
- 'a3b23a92a6f9ee4c6200244e99b62e77af1f18cc9f9714f671c7e754502d0341a93b0461a4a5562329dc51822ae06ff713208ec7092d480492163862a455377c'
- '1919ef4738ce25f405e5c68b13233ce19d821ebb65fcd4f8f55a268a2f25029b8a8c0f7ac1cb2ecb9026fc43a4851eca182001baa2dc32653ec34dbb13106a72'
- 'd49d464bac530ff6e51ff117dcef046e45440aba6020f6c100958b664417f0a91cd045d3b132d86e8b74928c1a72fcec1ee41c6da8b432f6525a35a6a9c2cad9'
- '99c6694d78d3232df078fbe8ec8948c278aea94c1784e27d052d92a3bf23757c4341be3477ef42741bba0f25d11e520def01cdd0cdd24ef9e0005aefff6a90f6'
- 'd9a22997da50c735090c3b48828cae45ee7e4dac8f54acfa723c8200e94103440e1b30059126c95aea307aa0c344340cc0ce72bd7b0982016707676d2dc0bb63'
- 'cd35bafeb918a14ffdbf87bc0c056a9e0ec4887827c32dd9889dbdda5c366cbcf0e753f223098c0cc4f7f58234dd6311dd06dbbebca54e86af6d02f96a7bda98'
- '0e9200c19666cf9e8f13242ff1d76bc43953f98e3a2dd015c7242d780c856af39c0c24bfe8643ab0492ab4422cc72428c724b429899280ff348c8a5cdb918808'
- '22a02ac89eb579b7a1cc581944b16ce946d0a8969418f5162ef9b6bb32b20e545998c74a6f11757ad6514c77d6f825cf2116695bcb97a7f68331ddd8b1fe4080'
- '627ececc2ae6d3c50f29ab26e1e74a34c494f520341958d8c1196e52fdeb0cdcb606ebb1bc0be6324b2ca0f64c75fc9707c1825e50c24369c4241da5022e1675'
+ 'b832287560c841e292d71be01c65045ee2ee6ac41f05176ebe349d730b5b79887bb629d176d5fd16a3e7ebb5e51de30b6d6fad6fad53821063188248bd1415bb'
+ 'f997a0afaaffb66533168f5d9cc341871eb54feb88d6ce578e816add82596bedf4dc242510e171e1e5b56464cf701384a32ed916176ea0c2db24209d754d3c58'
+ '96b97f6e721d179d88e7b4084ebb62ce30ddd13cbbcb367147e6646c8487107af36b3610d10e53abffae3a83736cdd7734e5dbcadb1909ced278f40a20302861'
+ '14f3ef9f2211e98198e96bd4f91978720acd703ee778698b85916cef73c1aea648d1d08a075f2ed334f5c27b9933274fa0651401e0baa3570f389a20aaec54e8'
+ 'b464e9af459c37c929ba30cdb7eb575038e970c9d91ff98fa37c0bc6161538b42a802dde34882772cf665130038158cb985fe06d65313f7c584c6c63045199d8'
+ '9d8019b8f525d5614d476ac34a35a40e8e1994f444a686b561c57b8ae488fcc44ffca9d034cea7b2271a2b7a7fa3a2ba2fcaa452504c320eff0bc3fc4de64ed2'
+ 'b3cf13c44b8b35bb7610206161a251cbf90299b0533e8e23465b9ae566feed510c5722aceadb7e2097de439362d0689de5692a091cbe8bec2994ef5290622095'
+ '463d68de99f434fd3409ee620eaa7b648d6627c5a04cfeab65b91053129e71bf906db817fd9770297ae1e38f8a5a84be4d20a1d1717e6821478f2c1bbc416cb2'
+ '813fbfb17659e4e7512367f03b06f9bc54070886f5e7206548deced60032f92d3ca0beb78416706662bf713cb0f7a5d8d81f8f08b911ca8254b417e82306d829'
'7bda2ad7eb81af802873cb6764cb9c675ec50ceeb5adc487881ebc8c316cf55f836e56c2cc67494a2920e86494861db2eb924b7ff9b151ae3c5b0e493c373bf9')
-sha512sums_armv7h+=('9d342387b69316460e4a4922bceeb9d8bb134a4fb98fdcf9a4e0a65da0afc00e8f6304bbd7e6ab117ebc970fec52e1e5c6d45201c7212cbc96c84d4506ad47c1')
+sha512sums_armv7h+=('bc7b70863929737346fe6757373897391b43af36bb6884d5351a95aca0f9120f2d2cf9b9c2c6426a440c6b394e9fb334c280711d64081563322a834ecdfb2ba6')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -113,6 +175,7 @@ case "$CARCH" in
armv7h) KARCH=arm64;CROSS_COMPILE=aarch64-linux-gnu-;;
esac
+export STRIP=${CROSS_COMPILE}strip
export KBUILD_BUILD_HOST=parabola
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
@@ -145,6 +208,17 @@ prepare() {
done
fi
+ if [ "$CARCH" = "i686" ]; then
+ local src_i686
+ for src_i686 in "${source_i686[@]}"; do
+ src_i686="${src_i686%%::*}"
+ src_i686="${src_i686##*/}"
+ [[ $src_i686 = *.patch ]] || continue
+ echo "Applying patch $src_i686..."
+ patch -Np1 < "../$src_i686"
+ done
+ fi
+
local src
for src in "${source[@]}"; do
src="${src%%::*}"
@@ -182,7 +256,7 @@ _package() {
provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
replaces=(virtualbox-guest-modules-arch wireguard-arch)
provides+=("${_replacesarchkernel[@]/%/=$pkgver}" "LINUX-ABI_VERSION=$pkgver")
- conflicts=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
+ conflicts+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
replaces+=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
cd $_srcname
@@ -223,6 +297,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
provides=("${_replacesarchkernel[@]/%/-headers=$pkgver}")
conflicts=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
replaces=("${_replacesarchkernel[@]/%/-headers}" "${_replacesoldkernels[@]/%/-headers}")
@@ -256,25 +331,16 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- # from linux-armv7
- if [ "$KARCH" = "armv7h" ]; then
- for i in dove exynos omap2; do
- mkdir -p "$builddir/arch/$KARCH/mach-$i"
- cp -t "$builddir/arch/$KARCH/mach-$i/" -a arch/$KARCH/mach-$i/include
- done
- for i in omap orion samsung versatile; do
- mkdir -p "$builddir/arch/$KARCH/plat-$i"
- cp -t "$builddir/arch/$KARCH/plat-$i/" -a arch/$KARCH/plat-$i/include
- done
- fi
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
@@ -301,18 +367,18 @@ _package-headers() {
while read -rd '' file; do
case "$(file -bi "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
- strip -v $STRIP_SHARED "$file" ;;
+ ${STRIP} -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
- strip -v $STRIP_STATIC "$file" ;;
+ ${STRIP} -v $STRIP_STATIC "$file" ;;
application/x-executable\;*) # Binaries
- strip -v $STRIP_BINARIES "$file" ;;
+ ${STRIP} -v $STRIP_BINARIES "$file" ;;
application/x-pie-executable\;*) # Relocatable binaries
- strip -v $STRIP_SHARED "$file" ;;
+ ${STRIP} -v $STRIP_SHARED "$file" ;;
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
echo "Stripping vmlinux..."
- strip -v $STRIP_STATIC "$builddir/vmlinux"
+ ${STRIP} -v $STRIP_STATIC "$builddir/vmlinux"
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
@@ -342,7 +408,7 @@ _package-docs() {
}
_package-chromebook() {
- pkgdesc="Experimental $pkgdesc kernel sign for Chromebooks"
+ pkgdesc="Experimental $pkgdesc kernel sign for Veyron Chromebooks"
depends=(linux-libre-64=$pkgver)
provides+=("linux-libre-chromebook=$pkgver")
conflicts+=('linux-libre-chromebook')