summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pck/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-pck/PKGBUILD')
-rw-r--r--libre/linux-libre-pck/PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/libre/linux-libre-pck/PKGBUILD b/libre/linux-libre-pck/PKGBUILD
index a2dbca966..7f5a864f5 100644
--- a/libre/linux-libre-pck/PKGBUILD
+++ b/libre/linux-libre-pck/PKGBUILD
@@ -10,7 +10,7 @@
pkgbase=linux-libre-pck
_pkgbasever=4.7-gnu
-_pkgver=4.7.2-gnu
+_pkgver=4.7.3-gnu
_pckpatchver=pck1
_replacesarchkernel=('linux-zen')
@@ -20,7 +20,7 @@ _replacesoldmodules=()
_srcname=linux-${_pkgbasever%-*}
_archpkgver=${_pkgver%-*}
pkgver=${_pkgver//-/_}.${_pckpatchver}
-pkgrel=1
+pkgrel=2
rcnrel=armv7-x2
arch=('i686' 'x86_64' 'armv7h')
url="https://wiki.parabola.nu/PCK"
@@ -46,8 +46,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'linux.preset'
'change-default-console-loglevel.patch'
# armv7h patches
- "https://repo.parabola.nu/other/rcn-libre-pck/patches/${_pkgver%-*}/rcn-libre-pck-${_pkgver%-*}-${rcnrel}.patch"
- "https://repo.parabola.nu/other/rcn-libre-pck/patches/${_pkgver%-*}/rcn-libre-pck-${_pkgver%-*}-${rcnrel}.patch.sig"
+ "https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch"
+ "https://repo.parabola.nu/other/rcn-libre/patches/${_pkgver%-*}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch.sig"
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
'0003-SMILE-Plug-device-tree-file.patch'
@@ -60,9 +60,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'0010-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch')
sha256sums=('f483e595e0ad9a9d1b3afd20e4ecb0b798cf16eb31e79a7b99311eb9c061032a'
'SKIP'
- 'c8f7fb230f95d91b9923790c3e4aaa8d5c1eb1eaaca09c87ac0a1a0153af310b'
+ 'd0a3e799f1996ee3274409d83694176cf663ac0fce9bb038db48affa081fde35'
'SKIP'
- 'fbaa87174e05b721baebd65c2f7538856a9b3311c0177b81f4cc4e18f071f572'
+ '30cdf5dd6c3e1f125ed83bcd158521860af03984f9b2e983ceb085960d60ea02'
'SKIP'
'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'SKIP'
@@ -70,12 +70,12 @@ sha256sums=('f483e595e0ad9a9d1b3afd20e4ecb0b798cf16eb31e79a7b99311eb9c061032a'
'SKIP'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- 'a1374041d7d5949e7283bb672c076ede4a445208c66b592fd8d7ddf678f79163'
- '3fb3ade34c18402a77c3138df5f002e413cc02ab36122dee500516c3a86a3a47'
- '7c2ec514ff6136a5164fdc0eddd0c9de9b7d262c8b5e77fd65740b1360029634'
+ '295ff582f28fa5e00af9a2e9feb98f8aa39ca5fe57127858dc178c0a18b8d0c4'
+ '6c9b6d6b6065da5788cb461313fb2c1053c015acde20faf589e665cf68030484'
+ '79810caec9c4fbc877e9ed8c937b33105da4887d5dd964847f169f13519528a6'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '51b36bd40c0d62f9b108fb679e35872f73486828dd3caf85c1bd4daabe336c7f'
+ '8108d89ac5ade76738858c4bb8def776965c3718e21fe1bf4098076561680d5a'
'SKIP'
'1620f9ed6f52250c540a88d5182be0caf8b50b93f83c85fec02c225ae121c9c1'
'd61c4da6d06ad61b20058dd8684aba5dc581e75264834e3a03f958f941bfeea5'
@@ -116,7 +116,7 @@ prepare() {
# Note: For stability reasons, AUFS and RT have been removed in the RCN patch.
# We are supporting AUFS in linux-libre-pck through PCK patch and RT through its official
# patch in linux-libre-rt. See https://wiki.parabola.nu/PCK for further details about PCK.
- git apply -v "${srcdir}/rcn-libre-pck-${_pkgver%-*}-${rcnrel}.patch"
+ git apply -v "${srcdir}/rcn-libre-${_pkgver%-*}-${rcnrel}.patch"
# ALARM patches
patch -p1 -i "${srcdir}/0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch"