summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pck/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-pck/PKGBUILD')
-rw-r--r--libre/linux-libre-pck/PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/libre/linux-libre-pck/PKGBUILD b/libre/linux-libre-pck/PKGBUILD
index 0b3ee9828..627e6de99 100644
--- a/libre/linux-libre-pck/PKGBUILD
+++ b/libre/linux-libre-pck/PKGBUILD
@@ -179,7 +179,6 @@ _package() {
provides=("${_replacesarchkernel[@]/%/=${_archpkgver}}")
conflicts=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
replaces=("${_replacesarchkernel[@]}" "${_replacesoldkernels[@]}" "${_replacesoldmodules[@]}")
- [ "${CARCH}" = "armv7h" ] && conflicts+=("${_replacesarchkernel}-uimage") && replaces+=("${_replacesarchkernel}-uimage")
if [ "${CARCH}" = "x86_64" ] || [ "${CARCH}" = "i686" ]; then
depends+=('mkinitcpio>=0.7')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
@@ -194,13 +193,10 @@ _package() {
_basekernel=${_basekernel%.*}
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
- if [ "${CARCH}" = "armv7h" ]; then
- mkdir -p "${pkgdir}/boot/dtbs/${pkgbase}"
- fi
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
if [ "${CARCH}" = "armv7h" ]; then
+ make LOCALVERSION= INSTALL_DTBS_PATH="${pkgdir}/boot/dtbs/${pkgbase}" dtbs_install
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
- cp arch/$KARCH/boot/dts/*.dtb "${pkgdir}/boot/dtbs/${pkgbase}"
elif [ "${CARCH}" = "x86_64" ] || [ "${CARCH}" = "i686" ]; then
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
fi