summaryrefslogtreecommitdiff
path: root/libre/linux-libre-tools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre-tools/PKGBUILD')
-rw-r--r--libre/linux-libre-tools/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/libre/linux-libre-tools/PKGBUILD b/libre/linux-libre-tools/PKGBUILD
index 5c2ea3caa..6e9a080df 100644
--- a/libre/linux-libre-tools/PKGBUILD
+++ b/libre/linux-libre-tools/PKGBUILD
@@ -24,7 +24,7 @@ case "$CARCH" in
armv7h) pkgname+=('gpio-utils' 'iio-utils') ;;
esac
-pkgver=5.2.1
+pkgver=5.4.1
pkgver+=_gnu
pkgrel=1
license=('GPL2')
@@ -54,7 +54,7 @@ source=("https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver//_/-}/l
'cpupower.service'
'usbipd.service'
'perf-fix-types.patch')
-sha256sums=('a430f25ed746b70fab2dc82e38f494a1b94ee06acf6a634fba857ceba5fe43e2'
+sha256sums=('7d2ce65f26e9c9234091167b7558cc9a3de545236a1cec3a4e77d171d440f35c'
'SKIP'
# '2129f0a264ecb03a2a8ccd6a3e2270dec0b4c11c66d09262eb0f1bbf18fcaefc'
# 'SKIP'
@@ -62,7 +62,7 @@ sha256sums=('a430f25ed746b70fab2dc82e38f494a1b94ee06acf6a634fba857ceba5fe43e2'
'd2e8e5e8b22c6089a91f573aa1c59e442a1f3b67a2c9f047abe3b57d3d6558cc'
'fa2560630576464739ede14c9292249f4007f36a684bc378add174fc88394550'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
- '7a1d5e5a1adb05f7896b5e81ddd5c998ea67e172110675a706c1536c538ce1ce')
+ 'aa08545851784262d1049da4df6f63bdb366b0ac21e2dbecc7fd31382bb4f4dc')
validpgpkeys=('474402C8C582DAFBE389C427BCB7CF877E7D47A7') # Alexandre Oliva
prepare() {
@@ -98,8 +98,7 @@ build() {
PYTHON=python \
PYTHON_CONFIG=python-config \
PERF_VERSION=$pkgver-$pkgrel \
- DESTDIR="$pkgdir" \
- all man
+ DESTDIR="$pkgdir"
popd
msg2 'cpupower'
@@ -203,7 +202,7 @@ package_perf() {
PYTHON_CONFIG=python-config \
PERF_VERSION=$pkgver-$pkgrel \
DESTDIR="$pkgdir" \
- install install-man
+ install
cd "$pkgdir"
# add linker search path
mkdir "$pkgdir/etc/ld.so.conf.d"