summaryrefslogtreecommitdiff
path: root/libre/mc-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mc-libre/PKGBUILD')
-rw-r--r--libre/mc-libre/PKGBUILD73
1 files changed, 38 insertions, 35 deletions
diff --git a/libre/mc-libre/PKGBUILD b/libre/mc-libre/PKGBUILD
index 3528fba0e..d286f9cf3 100644
--- a/libre/mc-libre/PKGBUILD
+++ b/libre/mc-libre/PKGBUILD
@@ -1,36 +1,44 @@
-# $Id$
+# $Id: PKGBUILD 87679 2013-04-05 09:08:28Z schuay $
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
# Maintainer: schuay <jakob.gruber@gmail.com>
_pkgname=mc
pkgname=mc-libre
-pkgver=4.8.4
+pkgver=4.8.8
pkgrel=1
-pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander"
+pkgdesc="Midnight Commander is a text based filemanager/shell that emulates Norton Commander, with unar and arj recommendation included and nonfree unace recommendation removed"
arch=('i686' 'x86_64')
url="http://www.ibiblio.org/mc/"
license=('GPL')
-depends=('e2fsprogs' 'glib2' 'pcre' 'gpm' 'slang')
+depends=(
+ 'e2fsprogs'
+ 'glib2'
+ 'gpm'
+ 'libssh2'
+ 'pcre'
+ 'slang')
makedepends=('libxt' 'libx11')
-optdepends=('p7zip: support for 7zip archives'
- 'mtools: a+ extfs'
- 'cdparanoia: audio extfs'
- 'gawk: hp48+ extfs'
- 'cdrkit: iso9660 extfs'
- 'perl: needed by several extfs scripts'
- 'python-boto: s3+ extfs'
- 'python2-pytz: s3+ extfs'
- 'p7zip: u7z extfs'
- 'arj: uarj extfs'
- 'cabextract: ucab extfs'
- 'ununrar: urar extfs'
- 'zip: uzip extfs')
+optdepends=(
+ 'cabextract: ucab extfs'
+ 'cdparanoia: audio extfs'
+ 'cdrkit: iso9660 extfs'
+ 'gawk: hp48+ extfs'
+ 'aspell: spelling corrections'
+ 'cvs: CVS support'
+ 'mtools: a+ extfs'
+ 'perl: needed by several extfs scripts'
+ 'python2-boto: s3+ extfs'
+ 'python2-pytz: s3+ extfs'
+ 'smb: VFS support'
+ 'arj: uarj extfs'
+ 'unar: urar extfs'
+ 'zip: uzip extfs'
+ 'p7zip: support for 7zip archives')
conflicts=('mc')
replaces=('mc')
provides=("mc=${pkgver}")
options=('!emptydirs' '!makeflags')
backup=('etc/mc/edit.indent.rc'
- 'etc/mc/edit.spell.rc'
'etc/mc/filehighlight.ini'
'etc/mc/mcedit.menu'
'etc/mc/mc.ext'
@@ -40,30 +48,25 @@ backup=('etc/mc/edit.indent.rc'
source=("http://www.midnight-commander.org/downloads/${_pkgname}-${pkgver}.tar.bz2")
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure \
- --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man \
- --enable-background --enable-charset --enable-largefile \
- --with-edit --with-gpm-mouse --with-mmap --enable-vfs-smb \
- --with-screen=slang --with-subshell --with-vfs --with-x \
- --without-debug --without-gnome --without-included-gettext \
- --libexecdir=/usr/lib
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-vfs-smb \
+ --with-x --libexecdir=/usr/lib
- make
+ make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
- # Fix FS#15177
- sed 's|op_has_zipinfo = 0|op_has_zipinfo = 1|' \
- -i "${pkgdir}/usr/lib/mc/extfs.d/uzip"
+ # Fix FS#15177
+ sed 's|op_has_zipinfo = 0|op_has_zipinfo = 1|' \
+ -i "${pkgdir}/usr/lib/mc/extfs.d/uzip"
- sed 's#/usr/bin/env python#/usr/bin/python2#' \
- -i "${pkgdir}/usr/lib/mc/extfs.d/s3+"
+ sed 's#/usr/bin/env python#/usr/bin/python2#' \
+ -i "${pkgdir}/usr/lib/mc/extfs.d/s3+"
}
-md5sums=('a8edb8226cb25869f925ecce043faf1e')
+md5sums=('324ff5a192d30d3a3b234c130550eb0a')