summaryrefslogtreecommitdiff
path: root/libre/mc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mc/PKGBUILD')
-rw-r--r--libre/mc/PKGBUILD168
1 files changed, 109 insertions, 59 deletions
diff --git a/libre/mc/PKGBUILD b/libre/mc/PKGBUILD
index 856aca45f..e3dd049f0 100644
--- a/libre/mc/PKGBUILD
+++ b/libre/mc/PKGBUILD
@@ -1,79 +1,129 @@
-# Maintainer (Arch): Alad Wenter <alad@archlinux.org>
-# Maintainer (Arch): schuay <jakob.gruber@gmail.com>
-# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
-# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
+# Maintainer (arch): George Rawlinson <grawlinson@archlinux.org>
+# Contributor: Alad Wenter <alad@archlinux.org>
+# Contributor: schuay <jakob.gruber@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+
+# parabola changes and rationale:
+# - remove non-free archiver optdepends
+# - use versioned source-ball rather than VCS sources
+
+
pkgname=mc
-pkgver=4.8.24
-pkgrel=2
+pkgver=4.8.30
+pkgrel=1
pkgrel+=.parabola1
-pkgdesc="A file manager that emulates Norton Commander"
-pkgdesc+=", with arj recommendation included and nonfree unace and unrar support removed"
+pkgdesc='A file manager that emulates Norton Commander'
arch=('x86_64')
-arch+=('i686' 'armv7h')
-url="https://midnight-commander.org/"
+arch+=('armv7h' 'i686')
+url='https://midnight-commander.org/'
license=('GPL')
-depends=('e2fsprogs' 'glib2' 'gpm' 'libssh2' 'slang')
-makedepends=('libxt' 'libx11' 'unzip')
-optdepends=('aspell: spelling corrections'
- 'cabextract: ucab extfs'
- 'cdparanoia: audio extfs'
- 'cdrkit: iso9660 extfs'
- 'cvs: CVS support'
- 'gawk: hp48+ extfs'
- 'mtools: a+ extfs'
- 'p7zip: support for 7zip archives'
- 'perl: needed by several extfs scripts'
- 'python-boto: s3+ extfs'
- 'python-pytz: s3+ extfs'
- 'samba: VFS support'
- 'arj: uarj extfs'
- 'zip: uzip extfs')
-conflicts=('mc-libre')
-replaces=('mc-libre')
-backup=('etc/mc/edit.indent.rc'
- 'etc/mc/filehighlight.ini'
- 'etc/mc/mc.ext'
- 'etc/mc/mc.keymap'
- 'etc/mc/mc.menu'
- 'etc/mc/mcedit.menu'
- 'etc/mc/sfs.ini')
+depends=(
+ 'e2fsprogs'
+ 'glib2'
+ 'gpm'
+ 'libssh2'
+ 'slang'
+ 'which'
+)
+makedepends=(
+ 'aspell'
+ 'git'
+ 'libxt'
+ 'libx11'
+ 'unzip'
+)
+optdepends=(
+ 'aspell: spelling corrections'
+ 'cabextract: ucab extfs'
+ 'cdparanoia: audio extfs'
+ 'cdrkit: iso9660 extfs'
+ 'cvs: CVS support'
+ 'gawk: hp48+ extfs'
+ 'mtools: a+ extfs'
+ 'p7zip: support for 7zip archives'
+ 'perl: needed by several extfs scripts'
+ 'python: to access uc1541 or s3 storage'
+ 'python-boto: s3+ extfs'
+ 'python-pytz: s3+ extfs'
+ # non-free deleted
+ # non-free deleted
+ # non-free deleted
+ 'unzip: open zip archives'
+ 'zip: uzip extfs'
+
+)
+optdepends+=(
+ 'samba: VFS support'
+ 'arj: uarj extfs'
+)
+backup=(
+ 'etc/mc/edit.indent.rc'
+ 'etc/mc/filehighlight.ini'
+ 'etc/mc/mc.ext'
+ 'etc/mc/mc.keymap'
+ 'etc/mc/mc.menu'
+ 'etc/mc/mcedit.menu'
+ 'etc/mc/sfs.ini'
+)
options=('!emptydirs')
-source=("http://ftp.midnight-commander.org/${pkgname}-${pkgver}.tar.xz"
- "mc-mksh-subshell-v2.patch"
- "mc-python3.patch"
- 'libre.patch')
-sha256sums=('859f1cc070450bf6eb4d319ffcb6a5ac29deb0ac0d81559fb2e71242b1176d46'
- '5147afa3f9dfc00d8b7b36bbb144bcdb78d86301a0f8196686262a9eee41fb96'
- '10ab8b8c03770f8fe51f0bdbf0d66a44313bf2eed687cf769397909c07d8e8d5'
- '0129171a9af3d1a7e37be232809e3f42921ef8fa016974234ca61f3fa180232b')
+source=(
+ http://ftp.midnight-commander.org/${pkgname}-${pkgver}.tar.xz
+ 'mc-python3.patch'
+)
+source+=('libre.patch')
+sha256sums=('5ebc3cb2144b970c5149fda556c4ad50b78780494696cdf2d14a53204c95c7df'
+ '78df8592c86445fa6249433e8587889e3923c0bb8b604cae32d5e739d2cc025c')
+sha256sums+=('c5785a63c194363824e9218bfc1c068f4cc8fc41f7cbc934c0da9bdb495c5861')
+
prepare() {
- cd ${pkgname}-${pkgver}
- patch -p1 < "$srcdir"/mc-mksh-subshell-v2.patch
- patch -p1 < "$srcdir"/mc-python3.patch
+ ln -fs ${pkgname}{-${pkgver},} # link source-ball root dir as VCS root dirname
+ cd "$pkgname"
+
+ # port to Python 3
+ # ref: https://github.com/MidnightCommander/mc/pull/149
+ patch -p1 -i "$srcdir/mc-python3.patch"
+
+ #./autogen.sh # does not exist in the source-ball
+
+
+ ## parabola changes ##
+
+ rm -v src/vfs/extfs/helpers/{uace,urar}.in
+
+ echo "applying libre.patch"
patch -Np1 -i ../libre.patch
- rm -v src/vfs/extfs/helpers/u{ace,rar}.in
+
+ # libre.patch requires autotools reconfigure
+ rm -v configure Makefile.in
+ autoreconf -ifv
}
build() {
- cd ${pkgname}-${pkgver}
+ cd "$pkgname"
+
./configure \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --enable-vfs-smb \
- --with-screen=slang \
- --with-x
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --enable-aspell \
+ --enable-vfs-smb \
+ --with-screen=slang \
+ --with-x
+
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
- # Replace mc.keymap symlink with target file to fix backup mechanism (FS#50889).
- rm "${pkgdir}"/etc/mc/mc.keymap && cp "${pkgdir}"/etc/mc/mc{.default,}.keymap
+ # FS#50889: Replace mc.keymap symlink with target file to fix backup mechanism.
+ rm "$pkgdir/etc/mc/mc.keymap"
+ cp "$pkgdir"/etc/mc/mc{.default,}.keymap
}