summaryrefslogtreecommitdiff
path: root/libre/minitube/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/minitube/PKGBUILD')
-rw-r--r--libre/minitube/PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/libre/minitube/PKGBUILD b/libre/minitube/PKGBUILD
index 7b01452c1..f4505d60d 100644
--- a/libre/minitube/PKGBUILD
+++ b/libre/minitube/PKGBUILD
@@ -1,24 +1,29 @@
-# Maintainer (Arch): David Runge <dvzrv@archlinux.org>
-# Contributor (Arch): speps <speps at aur dot archlinux dot org>
+# Maintainer (arch): David Runge <dvzrv@archlinux.org>
+# Contributor: speps <speps at aur dot archlinux dot org>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: fauno <fauno@parabola.nu>
+
+# parabola changes and ratuonale:
+# - remove 'AppsWidget' with non-free recommendations
+
+
pkgname=minitube
-pkgver=3.3
+pkgver=3.9
pkgrel=1
pkgrel+=.parabola1
pkgdesc="A YouTube desktop application"
-pkgdesc+=", without nonfree recommendations"
+pkgdesc+=", without non-free recommendations"
arch=('x86_64')
arch+=('i686')
url="https://flavio.tordini.org/minitube"
license=('GPL3')
-depends=('mpv' 'qt5-declarative' 'qt5-x11extras')
-makedepends=('qt5-tools')
-source=("https://github.com/flaviotordini/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
- 'remove_unfree_recommendations.patch')
-sha512sums=('8496405de0fdfb58a109c95004437fafea92013860ab5acbdd0aba983da7b6114e3c4a216f6b910df88740e688f57c2dc9640fe02630b256a309bc3c6e03ba8d'
- '58955bc1c07fe95327b29523d71b378fcd679d82912986f2091f725a3c653e4ec6a624b6c201ff044e39b2445fb46dfa566670036759d8b246cbda24e3e23d46')
+depends=('gcc-libs' 'glibc' 'qt5-base' 'qt5-declarative' 'qt5-x11extras')
+makedepends=('mpv' 'qt5-tools')
+source=("https://github.com/flaviotordini/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+source+=('remove_unfree_recommendations.patch')
+sha512sums=('d68545ce81eae730213bc7abe8de52d28c0230f92cef727d9129b9b512c3b396afffb06839f491bc9edaf2174658b0457859ddaa4660ba005650e6a8c65772f4')
+sha512sums+=('eca111cbdcaa1608e37be4fc795d0db5c60caa3a17d76ebe9bccd809b57a6a6c6fae64e0c52e6565898c63aebe0ad6be67cf23d6a2e9b44c1139781f541e8d6c')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -31,6 +36,7 @@ build() {
}
package() {
+ depends+=('libmpv.so')
cd "${pkgname}-${pkgver}"
make install INSTALL_ROOT="${pkgdir}/"
install -vDm 644 {AUTHORS,CHANGES,README.md,TODO} \