summaryrefslogtreecommitdiff
path: root/libre/mozilla-searchplugins/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mozilla-searchplugins/PKGBUILD')
-rw-r--r--libre/mozilla-searchplugins/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/libre/mozilla-searchplugins/PKGBUILD b/libre/mozilla-searchplugins/PKGBUILD
new file mode 100644
index 000000000..c86c9514a
--- /dev/null
+++ b/libre/mozilla-searchplugins/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net
+# Contributor: Figue <ffigue at gmail>
+# Contributor: Figue <ffigue at gmail>
+# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
+# Contributor (Parabola): vando <facundo@esdebian.org>
+# Thank you very much to the older contributors:
+# Contributor: evr <evanroman at gmail>
+# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
+
+pkgname=mozilla-searchplugins
+pkgver=1.0
+pkgrel=1
+pkgdesc="System-wide OpenSearch plugins common for Mozilla based browsers."
+arch=('any')
+license=('MPL' 'GPL' 'LGPL')
+url="https://parabolagnulinux.org/"
+source=(
+ duck-duck-go-lite.xml
+ duck-duck-go-ssl.xml
+ internet-archive.xml
+ jamendo-en.xml
+ logless-search.xml
+ scroogle-ssl-english.xml
+ wikipedia.xml
+ yacy.xml
+)
+
+package() {
+ install -m755 -d "${pkgdir}/usr/lib/mozilla/searchplugins"
+ install -m644 "${srcdir}"/*.xml "${pkgdir}/usr/lib/mozilla/searchplugins"
+}
+
+md5sums=('e1bda0854de7d764f7401c81bb82b5ef'
+ 'c5f00b6b24222aacd5a749d1f59c4d24'
+ '462c68585461f8cdc23c93c46f6ee4cf'
+ '2d492295c4308f9bba9ece28d8b3af2d'
+ '937ac0e5392b060d93bd33e761fbfa51'
+ 'cf97082e77e3ef5f1bd74b1db9329965'
+ 'c35f4971feff8387e0570d7a165eb6fa'
+ '24528ca3f7f1e1a0ba735231aa3ac1de')