summaryrefslogtreecommitdiff
path: root/libre/netsurf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/netsurf/PKGBUILD')
-rw-r--r--libre/netsurf/PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/libre/netsurf/PKGBUILD b/libre/netsurf/PKGBUILD
index 50a3270e8..757084ec0 100644
--- a/libre/netsurf/PKGBUILD
+++ b/libre/netsurf/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=netsurf
pkgver=3.3
pkgrel=1.parabola2
pkgdesc='Lightweight and fast web browser, without non-privacy search engines'
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'armv7h')
url='http://www.netsurf-browser.org/'
license=('MIT' 'GPL2')
replaces=(${pkgname}-libre)
@@ -18,12 +18,15 @@ depends=('libmng' 'librsvg' 'libwebp' 'curl' 'lcms' 'desktop-file-utils' 'libnsb
makedepends=('re2c' 'netsurf-buildsystem' 'perl-html-parser' 'nsgenbind' 'inetutils' 'libwebp')
install="$pkgname.install"
source=("http://download.$pkgname-browser.org/$pkgname/releases/source/$pkgname-$pkgver-src.tar.gz"
+ 'netsurf-remove_webp.patch'
'netsurf.sh')
sha256sums=('23f92a0940f577b9605f2e54786fea3521680d32d6c00f2a3db1eae3f29e3686'
+ 'f3729afed925f2762b4800c40065d352f70ac5a77c17df031f1943e3ee68c080'
'70310682d1612457d7bb3096549110b6ec127f50e97853259fada6be0c52924b')
prepare() {
cd "$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/netsurf-remove_webp.patch"
# remove non-privacy search engines
sed -i '\|Google|d
@@ -100,7 +103,7 @@ build() {
make -C "$pkgname-$pkgver" \
PREFIX=/usr \
TARGET=gtk \
- NETSURF_USE_WEBP=YES \
+ NETSURF_USE_WEBP=NO \
NETSURF_USE_VIDEO=NO \
NETSURF_USE_JS=NO \
NETSURF_USE_MOZJS=NO # Javascript is disabled, for now. See FS#41582