summaryrefslogtreecommitdiff
path: root/libre/nextcloud-client/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/nextcloud-client/PKGBUILD')
-rw-r--r--libre/nextcloud-client/PKGBUILD108
1 files changed, 74 insertions, 34 deletions
diff --git a/libre/nextcloud-client/PKGBUILD b/libre/nextcloud-client/PKGBUILD
index c1ca0c67d..5d57543e3 100644
--- a/libre/nextcloud-client/PKGBUILD
+++ b/libre/nextcloud-client/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer (arch): Chih-Hsuan Yen <yan12125@archlinux.org>
-# Contributor: Tyler Dence <tyzoid@archlinux32.org>
-# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+# Maintainer (Arch): Caleb Maclennan <caleb@alerque.com>
+# Maintainer (Arch): Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor (Arch): Tyler Dence <tyzoid@archlinux32.org>
+# Contributor (Arch): Konstantin Shalygin <k0ste@k0ste.ru>
# Maintainer: David P. <megver83@parabola.nu>
-
+# Contributor: bill-auger <bill-auger@programmer.net>
# parabola changes and rationale:
# - build without qt5-webengine
-
+# - disable tests which require networking
pkgbase=nextcloud-client
# Put config files for libcloudproviders integration in a separate package as
@@ -16,42 +17,72 @@ pkgname=(nextcloud-client nextcloud-client-cloudproviders)
epoch=2
# Upstream does not provide signed tarballs (yet)
# https://github.com/nextcloud/desktop/issues/1510
-pkgver=3.4.1
-# `git rev-parse v$pkgver`
-_tag=c1e1f91309b46f46d432ea0722e301ecaa094fb5
-pkgrel=1
+pkgver=3.10.0
+_tag=19a02ad0b0146167949a9a06d4cb4a1137df8153
+pkgrel=2
pkgrel+=.parabola1
arch=(x86_64)
arch+=(i686 armv7h)
url='https://nextcloud.com/'
+_url=https://github.com/nextcloud/desktop
license=(GPL)
-makedepends=(libcloudproviders openssl sqlite
- qt5-quickcontrols2 qt5-svg qt5-tools qt5-websockets qtkeychain-qt5
- extra-cmake-modules kio
- cmocka doxygen git inkscape python-sphinx)
-source=("$pkgbase::git+https://github.com/nextcloud/desktop.git?signed#tag=$_tag"
- fix-translations.patch)
+makedepends=(cmocka
+ doxygen
+ extra-cmake-modules
+ git
+ inkscape
+ kio5
+ libcloudproviders
+ openssl
+ python-sphinx
+ qt5-quickcontrols2
+ qt5-svg
+ qt5-tools
+ qt5-websockets
+ qtkeychain-qt5
+ sqlite)
+source=("$pkgbase::git+$_url.git?signed#tag=$_tag")
+source+=(no-webengine.patch)
validpgpkeys=(
- A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
- 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
- 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
- 01D736173523DFC7A7B55258C2FBEF0E1C7E72D0 # https://github.com/allexzander
- 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
- 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
+ A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # https://github.com/camilasan
+ 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # https://github.com/misch7
+ 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
+ 0739B11EDA696A3616666F6AE04221E85C5BB816 # https://github.com/allexzander
+ 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
+ 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
)
sha256sums=('SKIP'
- 'd112358031ddf79c08acde1f1b5e39aad9e3ee84ba161817d4f6e0259f9a5832')
+ '1e6d35210a15b8dfa94582d7db875e6ede2cd6b4e70f12cda02ff0be5a6badfb')
pkgver() {
cd $pkgbase
git describe --tags | sed 's/^v//;s/-/+/g'
}
+_pkgver() {
+ curl -fs https://api.github.com/repos/nextcloud/desktop/git/ref/tags/v$pkgver |
+ jq -r .object.sha
+}
+
prepare() {
# tmpdir for check()
- mkdir tmpdir
-
- patch -d $pkgbase -p1 < fix-translations.patch # Fix loading translations
+ mkdir -p tmpdir
+ cd $pkgbase
+ # Monkey patch that disables bulk upload capability which causes infinite
+ # loops for many server/client combos. Feature is also disabled by default on
+ # server end in v23.0.3 because it was so problematic. This can abe re-enabled
+ # when underlying bug squashed:
+ # https://github.com/nextcloud/desktop/issues/5726
+ sed -i -e '/bulkupload/s/return _.*;$/return false;/' src/libsync/capabilities.cpp
+ # Disable tests that touch on disabled feature
+ sed -i -e '/SyncEngine/s/^/#/' -e '/Capabilities/s/^/#/' -e '/SecureFileDrop/s/^/#/' test/CMakeLists.txt
+
+ # disable tests which require networking
+ sed -i -e '/OAuth/s/^/#/' test/CMakeLists.txt
+ sed -i -e '/PushNotifications/s/^/#/' test/CMakeLists.txt
+
+ echo "applying no-webengine.patch"
+ patch -Np1 -i "${srcdir}"/no-webengine.patch
}
build() {
@@ -63,6 +94,7 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_CRASHREPORTER=OFF \
+ -DBUILD_UPDATER=OFF \
-DUNIT_TESTING=ON \
-DPLUGINDIR=lib/qt/plugins # Fix vfs plugin install dir https://github.com/nextcloud/desktop/issues/3781#issuecomment-918918320
@@ -83,15 +115,23 @@ check() {
package_nextcloud-client() {
pkgdesc='Nextcloud desktop client'
- depends=(openssl sqlite qtkeychain-qt5 qt5-svg qt5-websockets xdg-utils libcloudproviders
- qt5-graphicaleffects qt5-quickcontrols2)
- optdepends=(
- 'kio: integration with Dolphin'
- 'nemo-python: integration with Nemo'
- 'python-nautilus: integration with Nautilus'
- 'python-caja: integration with Caja'
- 'nextcloud-client-cloudproviders: cloudproviders support'
- )
+ depends=(hicolor-icon-theme
+ karchive5
+ libcloudproviders
+ openssl
+ qt5-graphicaleffects
+ qt5-quickcontrols
+ qt5-quickcontrols2
+ qt5-svg
+ qt5-websockets
+ qtkeychain-qt5
+ sqlite
+ xdg-utils)
+ optdepends=('kio5: integration with Dolphin'
+ 'nemo-python: integration with Nemo'
+ 'python-nautilus: integration with Nautilus'
+ 'python-caja: integration with Caja'
+ 'nextcloud-client-cloudproviders: cloudproviders support')
backup=('etc/Nextcloud/sync-exclude.lst')
cd $pkgbase/build