summaryrefslogtreecommitdiff
path: root/libre/opencv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/opencv/PKGBUILD')
-rw-r--r--libre/opencv/PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/libre/opencv/PKGBUILD b/libre/opencv/PKGBUILD
index de739fb97..77d8b570c 100644
--- a/libre/opencv/PKGBUILD
+++ b/libre/opencv/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 253171 2015-12-07 02:57:20Z arojas $
+# $Id: PKGBUILD 259894 2016-02-17 10:16:39Z arojas $
# Maintainer (Arch): Ray Rashif <schiv@archlinux.org>
# Contributor (Arch): Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
@@ -7,8 +7,8 @@
pkgbase=opencv
pkgname=opencv
-pkgver=2.4.12.2
-pkgrel=2.parabola1
+pkgver=2.4.12.3
+pkgrel=1.parabola1
pkgdesc="Free Computer Vision Library, without nonfree SIFT algorithm and nonfree Milky icons"
arch=('i686' 'x86_64')
license=('BSD')
@@ -20,9 +20,11 @@ optdepends=('opencv-samples'
'libcl: For coding with OpenCL'
'python2-numpy: Python 2.x interface')
mksource=("$pkgbase-$pkgver::https://github.com/Itseez/opencv/archive/$pkgver.zip")
-source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.zip")
-mkmd5sums=('5f7cde7f0bccd90542805ea20687fc8d')
-md5sums=('782558e2a82909771662228ff79001e4')
+source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.zip"
+ opencv-ffmpeg3.patch)
+mkmd5sums=('eaede6500e9c2d56683196b0576db1f7')
+md5sums=('7a5f152bdbd730928aaebf1dcb960747'
+ 'c752f3e83ebb021171fdd04aa7fb2e5a')
_cmakeopts=('-D WITH_OPENCL=ON'
'-D WITH_OPENGL=ON'
@@ -66,6 +68,9 @@ prepare() {
# remove nonfree SIFT references
rm -rv modules/nonfree
+
+ # fix build with ffmpeg 3.0 (Debian)
+ patch -p1 -i ../opencv-ffmpeg3.patch
}
build() {