summaryrefslogtreecommitdiff
path: root/libre/p7zip-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/p7zip-libre/PKGBUILD')
-rw-r--r--libre/p7zip-libre/PKGBUILD38
1 files changed, 13 insertions, 25 deletions
diff --git a/libre/p7zip-libre/PKGBUILD b/libre/p7zip-libre/PKGBUILD
index 2e6ab6e01..fbd189a81 100644
--- a/libre/p7zip-libre/PKGBUILD
+++ b/libre/p7zip-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: PKGBUILD 188504 2013-06-15 04:51:48Z bisson $
# Contributor: Thayer Williams <thayer@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
@@ -8,7 +8,7 @@
pkgname=p7zip-libre
_pkgname=${pkgname%-libre}
pkgver=9.20.1
-pkgrel=6
+pkgrel=7
pkgdesc='Command-line version of the 7zip compressed file archiver without Rar'
url='http://p7zip.sourceforge.net/'
license=('GPL')
@@ -20,21 +20,22 @@ depends=('gcc-libs' 'bash')
optdepends=('wxgtk: GUI'
'desktop-file-utils: desktop entries')
makedepends=('yasm' 'nasm' 'wxgtk')
-source=("http://repo.parabolagnulinux.org/other/${pkgname}_${pkgver}.tar.bz2"
+source=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${pkgver}_src_all.tar.bz2"
'p7zip-libre.patch'
'7zFM.desktop')
-sha1sums=('4cffac613e7f3d8fc3c60677491b83a2d5cf16c9'
+sha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
'8fc0e6e80aeec371a8c80e7a6082594ac6d08aed'
'f2c370d6f1b286b7ce9a2804e22541b755616a40')
+
+options=('!makeflags')
install=install
-mksource() {
- if [ ! -d "${_pkgname}_${pkgver}" ]; then
- wget -O - "http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${pkgver}_src_all.tar.bz2" | \
- tar xjf -
- fi
+build() {
+ cd "${srcdir}/${_pkgname}_${pkgver}"
- pushd "${_pkgname}_${pkgver}"
+ [[ $CARCH = x86_64 ]] \
+ && cp makefile.linux_amd64_asm makefile.machine \
+ || cp makefile.linux_x86_asm_gcc_4.X makefile.machine
msg "Removing unRar"
# Generate patch
@@ -43,20 +44,7 @@ mksource() {
# Remove Rar mentions in CPP/7zip/Bundles/Format7zFree/makefile
patch -Np1 -i ../p7zip-libre.patch
- popd
-
- tar czvf "${pkgname}_${pkgver}.tar.bz2" "${_pkgname}_${pkgver}"
-}
-
-build() {
- cd "${srcdir}/${_pkgname}_${pkgver}"
-
- case $CARCH in
- x86_64) cp makefile.linux_amd64_asm makefile.machine ;;
- i686) cp makefile.linux_x86_asm_gcc_4.X makefile.machine ;;
- esac
-
- make all4 OPTFLAGS="${CXXFLAGS}"
+ make all4 OPTFLAGS="${CXXFLAGS}"
}
package() {
@@ -68,7 +56,7 @@ package() {
DEST_MAN="/usr/share/man"
# Integration with stuff...
- install -D GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
+ install -Dm644 GUI/p7zip_32.png "${pkgdir}"/usr/share/icons/hicolor/32x32/apps/p7zip.png
install -d "${pkgdir}"/usr/share/{applications,kde4/services/ServiceMenus}
cp GUI/kde4/* "${pkgdir}"/usr/share/kde4/services/ServiceMenus/
cp ../7zFM.desktop "${pkgdir}"/usr/share/applications/