summaryrefslogtreecommitdiff
path: root/libre/p7zip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/p7zip/PKGBUILD')
-rw-r--r--libre/p7zip/PKGBUILD79
1 files changed, 32 insertions, 47 deletions
diff --git a/libre/p7zip/PKGBUILD b/libre/p7zip/PKGBUILD
index f7c09510a..b866ac127 100644
--- a/libre/p7zip/PKGBUILD
+++ b/libre/p7zip/PKGBUILD
@@ -1,40 +1,38 @@
-# $Id: PKGBUILD 288091 2017-02-05 19:09:19Z foutrelis $
-# Maintainer (Arch): Evangelos Foutras <evangelos@foutrelis.com>
-# Contributor (Arch): Gaetan Bisson <bisson@archlinux.org>
-# Contributor (Arch): Thayer Williams <thayer@archlinux.org>
-# Contributor (Arch): Hugo Doria <hugo@archlinux.org>
-# Contributor (Arch): TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
-# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
+# Maintainer (arch): Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Thayer Williams <thayer@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+# Contributor: TuxSpirit<tuxspirit@archlinux.fr>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
_pkgname=p7zip-libre
pkgname=p7zip
-pkgver=16.02
-pkgrel=5.parabola1
+pkgver=17.04
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc="Command-line file archiver with high compression ratio"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://p7zip.sourceforge.net/"
+arch=('x86_64')
+arch+=('i686' 'armv7h')
+url="https://github.com/jinfeihan57/p7zip"
license=('LGPL')
conflicts=('p7zip-libre')
replaces=('p7zip-libre')
depends=('gcc-libs' 'sh')
-makedepends_i686=('nasm')
-makedepends_x86_64=('yasm')
-install=$pkgname.install
-mksource=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2)
-source=(https://repo.parabola.nu/other/${_pkgname}/${_pkgname}_${pkgver}_src_all.tar.bz2
- CVE-2016-9296.patch
- CVE-2017-17969.patch
+source=(https://github.com/jinfeihan57/p7zip/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
+ oemcp-iconv.patch::https://github.com/jinfeihan57/p7zip/commit/c104127e6a93.patch
+ oemcp-cygwin.patch::https://github.com/jinfeihan57/p7zip/commit/0e0a1a8316b6.patch
+ oemcp-apple.patch::https://github.com/jinfeihan57/p7zip/commit/334a01e3f8bc.patch
libre.patch)
-mksha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f')
-sha256sums=('486e5784de9284c7123b401b3f27e684af772d03fc1fb8cdbbefb8123dc9f841'
- 'f9bcbf21d4aa8938861a6cba992df13dec19538286e9ed747ccec6d9a4e8f983'
- 'c6af5ba588b8932a5e99f3741fcf1011b7c94b533de903176c7d1d4c02a9ebef'
- 'feeeb3b1b7a827b7a675d6c8a363ea6c2499a4f04b3160c7e8d7bba42e0b3c15')
+sha256sums=('ea029a2e21d2d6ad0a156f6679bd66836204aa78148a4c5e498fe682e77127ef'
+ 'e32636aa03b9c75a2b9d9138e03a738ceed6ca5da4c3c67e7f5981e135fb9e24'
+ 'fa658d42cc1da2b567a210a819502bd8e3bb1e02d5d23e087e2278c4aaffe15e'
+ 'a1b21ceb5582633d85d41ec9e4995f758cba1731dd80fb6f45a7bc6b18bfe394'
+ '5dd8986cbc8541b9197235163d1bc63cc04956bf8256a5473f9682dfdf6843c1')
-mksource() {
- cd "${srcdir}/${pkgname}_${pkgver}"
+prepare() {
+ cd $pkgname-$pkgver
# Remove nonfree unRAR utility files from the source
rm -rv CPP/7zip/{Archive,Compress}/Rar
@@ -45,36 +43,23 @@ mksource() {
# Remove nonfree parent folder icon
rm CPP/7zip/UI/FileManager/res/ParentFolder.h
-}
-
-prepare() {
- cd "$srcdir/${pkgname}_$pkgver"
-
- # https://sourceforge.net/p/p7zip/bugs/185/
- patch -Np1 -i ../CVE-2016-9296.patch
-
- # https://sourceforge.net/p/p7zip/bugs/204/
- patch -Np1 -i ../CVE-2017-17969.patch
-
- if [[ $CARCH = x86_64 ]]; then
- cp makefile.linux_amd64_asm makefile.machine
- elif [[ $CARCH = i686 ]]; then
- cp makefile.linux_x86_asm_gcc_4.X makefile.machine
- else
- cp makefile.linux_any_cpu_gcc_4.X makefile.machine
- fi
# Remove RAR and parent folder icon references
patch -Np1 -i ../libre.patch
+
+ # https://github.com/jinfeihan57/p7zip/issues/112
+ patch -Rp1 -i ../oemcp-apple.patch
+ patch -Rp1 -i ../oemcp-cygwin.patch
+ patch -Rp1 -i ../oemcp-iconv.patch
}
build() {
- cd "$srcdir/${pkgname}_$pkgver"
- make all3 OPTFLAGS="$CFLAGS"
+ cd $pkgname-$pkgver
+ make OPTFLAGS="$CPPFLAGS $CFLAGS" 7z 7zr 7za
}
package() {
- cd "$srcdir/${pkgname}_$pkgver"
+ cd $pkgname-$pkgver
make install \
DEST_DIR="$pkgdir" \