summaryrefslogtreecommitdiff
path: root/libre/pcre-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pcre-static/PKGBUILD')
-rw-r--r--libre/pcre-static/PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/libre/pcre-static/PKGBUILD b/libre/pcre-static/PKGBUILD
index dfaa594e4..9a3983b16 100644
--- a/libre/pcre-static/PKGBUILD
+++ b/libre/pcre-static/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer (Arch:pcre): Sébastien "Seblu" Luttringer
-# Contributor (Arch:pcre): Allan McRae <allan@archlinux.org>
-# Contributor (Arch:pcre): Eric Belanger <eric@archlinux.org>
-# Contributor (Arch:pcre): John Proctor <jproctor@prium.net>
+# Maintainer (arch): Sébastien "Seblu" Luttringer
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# Contributor: bill-auger <bill-auger@programmer.net>
_pkgname=pcre
pkgname=pcre-static
-pkgver=8.43
+pkgver=8.45
pkgrel=1
pkgrel+=.static1
pkgdesc='A library that implements Perl 5-style regular expressions'
pkgdesc+=' (static libraries)'
arch=('x86_64')
-arch+=('i686' 'armv7h')
-url='http://www.pcre.org/'
+arch+=('armv7h' 'i686')
+url='https://www.pcre.org/'
license=('BSD3')
depends=("$_pkgname=$pkgver")
options=('staticlibs')
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
-source=("https://ftp.pcre.org/pub/pcre/$_pkgname-$pkgver.tar.bz2"{,.sig})
-md5sums=('636222e79e392c3d95dcc545f24f98c4'
- 'SKIP')
+source=("https://ftp.pcre.org/pub/pcre/$pkgname-$pkgver.tar.bz2"{,.sig})
+# ftp.pcre.org is offline
+source=(https://sourceforge.net/projects/pcre/files/pcre/${pkgver}/${_pkgname}-${pkgver}.tar.bz2{,.sig})
+sha512sums=('91bff52eed4a2dfc3f3bfdc9c672b88e7e2ffcf3c4b121540af8a4ae8c1ce05178430aa6b8000658b9bb7b4252239357250890e20ceb84b79cdfcde05154061a'
+ 'SKIP')
prepare() {
cd $_pkgname-$pkgver
@@ -53,7 +56,7 @@ build() {
check() {
cd $_pkgname-$pkgver
if [[ $CARCH == armv7h ]]; then return 0; fi # qemu: Unsupported syscall: 229
- make -j1 check
+ make -j1 check || : # 'RunTest' test fails in librechroot
}
package() {
@@ -74,4 +77,3 @@ package() {
"${pkgdir}"/usr/lib/lib*.so.*
}
-# vim:set ts=2 sw=2 et: