summaryrefslogtreecommitdiff
path: root/libre/phoronix-test-suite/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/phoronix-test-suite/PKGBUILD')
-rw-r--r--libre/phoronix-test-suite/PKGBUILD96
1 files changed, 40 insertions, 56 deletions
diff --git a/libre/phoronix-test-suite/PKGBUILD b/libre/phoronix-test-suite/PKGBUILD
index eed63d29c..ae8270497 100644
--- a/libre/phoronix-test-suite/PKGBUILD
+++ b/libre/phoronix-test-suite/PKGBUILD
@@ -2,16 +2,18 @@
# Maintainer: Fabio 'Lolix' Loli <lolix at disroot.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Andreas Schönfelder <passtschu at freenet dot de>
+# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
pkgname=phoronix-test-suite
-pkgver=9.2.1
+pkgver=10.8.3
pkgrel=1
pkgrel+=.par1
-pkgdesc="The most comprehensive testing and benchmarking platform available for Linux without the nonfree tests"
+pkgdesc="Testing and benchmarking tool with nonfree tests disabled (but still listed with 'phoronix-test-suite list-available-tests')"
arch=(any)
license=(GPL3)
url="http://www.phoronix-test-suite.com/"
-depends=(php)
+depends=('make' 'gzip' 'php' 'sed' 'tar' 'which')
+makedepends=('python')
optdepends=('php-gd'
'sqlite3: required when running a Phoromatic server.'
'gcc-fortran: required for universe-cli test suite'
@@ -22,66 +24,48 @@ optdepends=('php-gd'
'mesa-demos: required for universe-cli test suite'
'openmpi: required for universe-cli test suite')
source=("$pkgname-$pkgver.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/phoronix-test-suite-launcher.patch"
- "0001-Don-t-download-online-tests.patch")
-sha256sums=('28acbcb6c5b8eb27c20329cd1a5ea3f1a27abb69812c4b1eeade4b91c89fc7d8'
- '577326343d0303a59fd469c3f9c9740e756dd59c0660c54363b62d6fd1cee26d'
- 'SKIP')
-options=(!strip)
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/phoronix-test-suite-launcher.patch")
+sha256sums=('752012b6e94897f03a219157fe1ba6c4198eb16a5ddf026811b739f1f89cfd9e'
+ '577326343d0303a59fd469c3f9c9740e756dd59c0660c54363b62d6fd1cee26d')
-test_profiles=('build-apache-1.5.1'
- 'build-eigen-1.0.0'
- 'build-gcc-1.1.2'
- 'build-llvm-1.1.0'
- 'build-php-1.4.0')
+# This patch comes from Guix at the commit
+# 92121b8e9db9541b0fdf0e6e0b17e28e03a01277 ("gnu: Add
+# phoronix-test-suite."). It disables tests that include nonfree
+# software. I've already bugreported to Guix for tests like linux or
+# gnupg which download nonfree software so they should be fixed at
+# some point. If new problematic tests are found, since Guix is FSDG
+# compliant, it is possible to bugreport there to get them fixed, and
+# then to backport the fixed patch to Parabola. As I understand this
+# phoronix-test-suite-fsdg.patch is also being upstreamed, so once is
+# is upstream, it will be possible to directly send patches to fix
+# issues upstream.
+#
+# Note that with this patch, while the tests are disabled, they still
+# show up in phoronix-test-suite list-available-tests, but when trying
+# to run them they fail to run.
+source+=("phoronix-test-suite-fsdg.patch")
+sha256sums+=('SKIP')
-# Issues:
-# build-firefox: source code not FSDG compliant
-# build-imagemagick: TODO: rebuild the tarball from official source code
-# build-linux-kernel: source code not FSDG compliant
-# build-mplayer: TODO: make sure that it doesn't build with FAAC
-# build-webkitfltk: TODO: review the project source code
+options=(!strip)
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- patch phoronix-test-suite -i "${srcdir}/phoronix-test-suite-launcher.patch"
- patch -p1 -i "${srcdir}/0001-Don-t-download-online-tests.patch"
- # Only keep tests that meet the following requirements:
- # - No dependencies on nonfree software
- # - No binaries
- # - Source comming from official projects potentially with additional patches
- # to be able to understand what was changed.
- mkdir -p ob-cache_/test-profiles/pts/
- for p in ${test_profiles[@]} ; do
- # Local works with the current patch
- # TODO: make it appear under pts
- mv ob-cache/test-profiles/pts/${p} ob-cache_/test-profiles/local/
- done
- rm -rf ob-cache
- mv ob-cache_ ob-cache
+
+ # Without that fix, running makepkg twice results in the following
+ # error:
+ # ==> Starting prepare()...
+ # The next patch would create the file delete-nonfree-metadata,
+ # which already exists! Skipping patch.
+ # [...]
+ # ==> ERROR: A failure occurred in prepare().
+ # Aborting...
+ rm -f delete-nonfree-metadata
+
+ patch -Np1 -i "${srcdir}/phoronix-test-suite-fsdg.patch"
+ patch -Np1 phoronix-test-suite -i "${srcdir}/phoronix-test-suite-launcher.patch"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- ./install-sh $pkgdir/usr
-
- rm -r "${pkgdir}"/usr/share/phoronix-test-suite/deploy
- rm -rf "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/{dependency-handlers,scripts,xml}/{*.php,*.sh,*.xml}
-
- install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/dependency-handlers/arch_dependency_handler.php \
- "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/dependency-handlers/arch_dependency_handler.php
-
- install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/scripts/install-arch-packages.sh \
- "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/scripts/install-arch-packages.sh
-
- install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/arch-packages.xml \
- "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/arch-packages.xml
-
- install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/generic-packages.xml \
- "${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/generic-packages.xml
-
- install "${srcdir}/phoronix-test-suite-${pkgver}"/phoronix-test-suite \
- "${pkgdir}"/usr/bin/phoronix-test-suite
-
- ln -s /usr/bin/phoronix-test-suite "$pkgdir/usr/bin/pts"
+ ./install-sh $pkgdir/usr --free-software-only
}