summaryrefslogtreecommitdiff
path: root/libre/python-reportlab/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/python-reportlab/PKGBUILD')
-rw-r--r--libre/python-reportlab/PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/libre/python-reportlab/PKGBUILD b/libre/python-reportlab/PKGBUILD
index a92f90702..6599a7172 100644
--- a/libre/python-reportlab/PKGBUILD
+++ b/libre/python-reportlab/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer (Arch): Morten Linderud <foxboron@archlinux.org>
-# Contributor (Arch): Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
-# Contributor (Arch): William Rea <sillywilly@gmail.com>
+# Maintainer (arch): Morten Linderud <foxboron@archlinux.org>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: William Rea <sillywilly@gmail.com>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: borgo <nomail>
# Contributor: André Silva <emulatorman@hyperbola.info>
+
+# parabola changes and rationale:
+# - remove nonfree fonts support
+# - remove duplicate fonts found in ther packages
+
+
_origname=reportlab
pkgname=python-reportlab
-pkgver=3.6.6
-pkgrel=1
+pkgver=3.6.12
+pkgrel=3
pkgrel+=.parabola1
pkgdesc="A proven industry-strength PDF generating solution"
-pkgdesc+=", without nonfree Adobe T1 fonts support"
arch=('x86_64')
-arch+=('i686' 'armv7h')
+arch+=('armv7h' 'i686')
url="https://www.reportlab.com/"
depends=('freetype2')
depends=('python' 'python-pillow')
makedepends=('freetype2' 'python-pillow' 'mercurial')
license=('BSD')
-source=(https://files.pythonhosted.org/packages/source/${_origname::1}/${_origname}/${_origname}-${pkgver}.tar.gz
- 'free-fonts.patch')
-sha256sums=('dd1cdb62dc123f5859ca514eb639f70660bdc818c95fb0ee2370a175a0e20ce4'
- '7e31b2a2bde509d628cb7da9fec301d730d38ea8a8dc9956cdfc8da4ebeec370')
+source=(https://files.pythonhosted.org/packages/source/${_origname::1}/${_origname}/${_origname}-${pkgver}.tar.gz)
+source+=('free-fonts.patch')
+sha256sums=('b13cebf4e397bba14542bcd023338b6ff2c151a3a12aabca89eecbf972cb361a')
+sha256sums+=('7e31b2a2bde509d628cb7da9fec301d730d38ea8a8dc9956cdfc8da4ebeec370')
+
prepare() {
cd ${_origname}-${pkgver}
@@ -42,7 +48,7 @@ build() {
check() {
cd ${_origname}-${pkgver}
- python setup.py tests || true
+ python -m unittest discover -vs tests || true
rm tests/_i_am_actually_a_*
}