summaryrefslogtreecommitdiff
path: root/libre/retroarch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/retroarch/PKGBUILD')
-rw-r--r--libre/retroarch/PKGBUILD89
1 files changed, 38 insertions, 51 deletions
diff --git a/libre/retroarch/PKGBUILD b/libre/retroarch/PKGBUILD
index 954cc32a5..775fabe2e 100644
--- a/libre/retroarch/PKGBUILD
+++ b/libre/retroarch/PKGBUILD
@@ -9,107 +9,96 @@
# rationale for inclusion in [libre]:
# - disable auto-updater/downloader
+# - build from versioned source-ball rather than VCS
pkgname=retroarch
-pkgver=1.9.6
-pkgrel=2
-pkgrel+=.parabola2
+_upstream_name=RetroArch
+pkgver=1.16.0.3
+pkgrel=1
+pkgrel+=.parabola1
pkgdesc='Reference frontend for the libretro API'
arch=(x86_64)
-arch+=(i686 armv7h)
+arch+=(armv7h i686)
url=http://www.libretro.com/
license=(GPL)
groups=(libretro)
depends=(
alsa-lib
+ dbus
+ ffmpeg
flac
+ fontconfig
+ fribidi
+ gcc-libs
+ glibc
libass.so
- libavcodec.so
- libavformat.so
- libavutil.so
libdrm
libfreetype.so
libgl
libpulse
- libswresample.so
- libswscale.so
libudev.so
- libusb-1.0.so
- mbedtls
+ libusb
+ libx11
+ libxcb
+ libxext
+ libxinerama
+ libxkbcommon
+ libxrandr
+ libxxf86vm
+ libxv
+ mbedtls2
mesa
- miniupnpc
- openal
+ openssl
qt5-base
sdl2
v4l-utils
+ wayland
zlib
)
depends+=(libmbedcrypto.so)
makedepends=(
+ gamemode
git
- libx11
- libxcb
- libxext
- libxinerama
- libxkbcommon
- libxrandr
- libxv
- libxxf86vm
+ libdecor
vulkan-icd-loader
- wayland
wayland-protocols
)
optdepends=(
+ 'gamemode: GameMode support'
+ 'libdecor: Wayland decorations'
'libretro-overlays: Collection of overlays'
'libretro-shaders: Collection of shaders'
- 'libxinerama: X11 support'
- 'libxrandr: X11 support'
'python: retroarch-cg2glsl'
'retroarch-assets-ozone: Ozone menu assets'
'retroarch-assets-xmb: XMB menu assets'
- 'wayland: Wayland support'
)
backup=(etc/retroarch.cfg)
-_tag=4a6dc36b1cc026bf337537e2d7527a117727bb91
source=(
- git+https://github.com/libretro/RetroArch.git#tag=${_tag}
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/libretro/${_upstream_name}/archive/refs/tags/v${pkgver}.tar.gz
retroarch-config.patch
- disable-auto-update.patch
)
-sha256sums=(
- SKIP
- 7857cff30c45721b66666828ca9edbb2923817c6c64591be3f58fe019277103e
- cb3915a5ada76e29abd2a8b2c06c8dc50909473b5c53ec112dffab87fcc585e1
-)
-
-pkgver() {
- cd RetroArch
-
- git describe --tags | sed 's/^v//'
-}
+source+=(disable-auto-update.patch)
+b2sums=('e04b33585085679262da52ba37a960c1b5076628ffeaadd0beb7bceaf092f7a202677622fec5156ee61afdffbbaae050379d8038ef331475b17a7f0bbb8c50b3'
+ '5ecbe57126c7f9b66bdf189f0af2f1cec031cb68ea85bb9609847ba9beb0e720c902cd3330d7c286901a73e6c2e272c3f04166cf9a47bb6f80097f19dde8ce3a')
+b2sums+=('232dd01998f119ba00082212d4a44f3be3664b1027c937e54529c0186626b0445e34e551ee3fa9982fffbada7c57c6bbe11e6e6716eea4fc4ad5488e74cabf73')
prepare() {
- cd RetroArch
-
+ cd ${_upstream_name}-${pkgver}
patch -Np1 -i ../retroarch-config.patch
- git cherry-pick -n 685948368e6b28b97e1b91bdfe5921519359a033 # FS#66843
-
echo "applying disable-auto-update.patch"
- sed -i 's|\(#define DEFAULT_BUILDBOT_SERVER_URL\) ".*|\1 ""|' config.def.h
- sed -i 's|\(#define DEFAULT_BUILDBOT_ASSETS_SERVER_URL\) ".*|\1 ""|' config.def.h
patch -Np1 -i ${srcdir}/disable-auto-update.patch
}
build() {
- cd RetroArch
-
+ cd ${_upstream_name}-${pkgver}
+ export CFLAGS+=' -I/usr/include/mbedtls2'
+ export LDFLAGS+=' -L/usr/lib/mbedtls2'
./configure \
--prefix=/usr \
--disable-builtinflac \
--disable-builtinmbedtls \
- --disable-builtinminiupnpc \
--disable-builtinzlib \
--disable-cg \
--disable-jack \
@@ -122,10 +111,8 @@ build() {
}
package() {
- cd RetroArch
-
+ cd ${_upstream_name}-${pkgver}
make DESTDIR="${pkgdir}" install
-
install -Dm 644 libretro-common/audio/dsp_filters/*.{dsp,so} -t "${pkgdir}"/usr/lib/retroarch/filters/audio/
install -Dm 644 gfx/video_filters/*.{filt,so} -t "${pkgdir}"/usr/lib/retroarch/filters/video/
}