summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index f9907d3f4..ecee94e9b 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -1,14 +1,13 @@
-# $Id: PKGBUILD 187808 2013-06-06 07:51:31Z tpowa $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=syslinux
-pkgver=5.10
-pkgrel=3
+pkgver=4.06
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)"
-url="http://www.syslinux.org"
+url="http://syslinux.zytor.com/"
license=('GPL2')
depends=('perl' 'glibc')
optdepends=('perl-passwd-md5: For md5pass'
@@ -25,10 +24,10 @@ source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.t
syslinux.cfg
syslinux-install_update
splash.png)
-md5sums=('8f51d6a5d2730f534ba90e71f3347bff'
- '25af85a05e7b212b7fb8b7587175e492'
- 'e5a69630e3f7083aad2d14362b6117b3'
- '4450792e13a0270c1b89bb6a66ce2fbc'
+md5sums=('0384ef35b724615074e77b1fc89d5b47'
+ '1528c376e43f0eaccaa80d8ad1bc13b4'
+ '31fe4d80ad74b01e5bc8fccc1d32cccd'
+ '8559fb3daf3afa8688600d8a38118918'
'befd0e7c38a03442b791f2a530b4dd2d')
build() {
@@ -46,10 +45,8 @@ build() {
package() {
cd "$srcdir"/$pkgname-${pkgver}
- make INSTALLROOT="$pkgdir" AUXDIR=/usr/lib/syslinux install
+ make INSTALLROOT="$pkgdir" SBINDIR=/usr/bin AUXDIR=/usr/lib/syslinux install
- # install docs
- cp -ar "$srcdir"/$pkgname-${pkgver}/doc "$pkgdir"/usr/share/
# Install the default configuration
install -D -m644 "$srcdir"/syslinux.cfg "$pkgdir"/boot/syslinux/syslinux.cfg
# Install Parabola splash
@@ -57,7 +54,4 @@ package() {
# Install the installation and update script
# This script is maintained at git://gist.github.com/772138.git
install -D -m755 "$srcdir"/syslinux-install_update "$pkgdir"/usr/bin/syslinux-install_update
- # move extlinux binary to /usr/bin
- mv "$pkgdir"/sbin/extlinux "$pkgdir"/usr/bin/extlinux
- rmdir "$pkgdir"/sbin
}