summaryrefslogtreecommitdiff
path: root/libre/texlive-core/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/texlive-core/PKGBUILD')
-rw-r--r--libre/texlive-core/PKGBUILD70
1 files changed, 42 insertions, 28 deletions
diff --git a/libre/texlive-core/PKGBUILD b/libre/texlive-core/PKGBUILD
index 4d4d75ec2..1b8ce15e1 100644
--- a/libre/texlive-core/PKGBUILD
+++ b/libre/texlive-core/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer (Arch): Rémy Oudompheng <remy@archlinux.org>
-# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
+# Maintainer (arch): Rémy Oudompheng <remy@archlinux.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Michał Masłowski <mtjm@mtjm.eu>
# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
_pkgname=texlive-core-libre
pkgname=texlive-core
-pkgver=2020.55416
-_revnr=${pkgver#2020.}
-pkgrel=1
-pkgrel+=.par2
+pkgver=2023.66587
+_revnr=${pkgver#2023.}
+pkgrel=2
+pkgrel+=.par1
pkgdesc="TeX Live core distribution"
pkgdesc+=", without nonfree add-on packages (Parabola rebranded)"
license=('GPL')
arch=(any)
depends=('texlive-bin' 'perl')
+makedepends=('subversion')
optdepends=(
'dialog: for texconfig'
'ghostscript: for epstopdf, epspdf and other ConTeXt tools'
'java-runtime: for utilities like arara, texplate'
'perl-tk: for texdoctk'
'psutils: to manipulate the output of dvips'
- 'python: for pythontex'
- 'python2: for dviasm'
+ 'python: for de-macro, dviasm, pythontex'
'ruby: for old ConTeXT MkII and epspdf'
't1utils: can be useful when installing Type1 fonts'
+ 'wdiff: for texdiff'
)
groups=('texlive-most')
conflicts=('tetex' 'texlive-latex3' 'pdfjam'
@@ -38,11 +39,12 @@ replaces=('tetex' 'texlive-latex3' 'pdfjam'
'texlive-plainextra')
url='http://tug.org/texlive/'
mksource=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip")
-mksha256sums=('8e025c2dfa4e19dcb6aa5e661874d2c2a158aa2e1a078c11a4ddd6347bd9db45')
+mksha256sums=('2cdaf356d89351e61152243f1192a5e000a9586c67b873737f01878a3e5724ff')
noextract=("$pkgname-$pkgver-src.zip")
source=("https://repo.parabola.nu/other/$_pkgname/$_pkgname-$pkgver-src.tar.xz"{,.sig}
"$pkgname.maps"
"$pkgname.fmts"
+ "texlive-man::svn://tug.org/texlive/tags/texlive-2023.0/Master/texmf-dist/doc/man#revision=${_revnr}"
"mktexlsr.hook"
"mktexlsr.script"
"texlive-updmap.hook"
@@ -64,17 +66,18 @@ backup=(etc/texmf/web2c/texmf.cnf \
etc/texmf/web2c/fmtutil.cnf \
etc/texmf/web2c/mktex.cnf \
etc/texmf/xdvi/XDvi)
-sha256sums=('b9efbb80cb2044bf1c2bf8784fd2c94403d4cfa60d57022642c4b118f1836725'
+sha256sums=('ec1b572a3fd372410bf3465eb7687889072213976213c67a7f11f1ee5f22917c'
+ 'SKIP'
+ 'bbed1c20c91daca967e344505b9dd4e502569365709ce6b87be5510c2ebb98ef'
+ '7da46b34158b7fd997e494adaffdc5778617706680ba8124343d9973c2b1e965'
'SKIP'
- '275253728d884b2b75e01840b0824c1fe5afbdda91fafeacd33deb6cd92341a3'
- '09cbe0717c53078d30bdc378322f82e673dafbe7cf76a11e0a3c6dd54dcdfea3'
'c76f01fe2a42e5860f7d0b2f16a4fc09101e1a14ea7488985e914cda749f1a21'
'05afeae62a5d4c9de79c838c9636e2aefe9ad1d6b787fed4e5930c13baf60eba'
'2141c0842668fb937fd21ca2fae39b642c9665656e404a0d4ee7bdc477bf51fe'
'ee6e76192a5ad880a2152cd7900b86c8465239fb228045a2f8360b0d7a449f4a'
'b641550fe7727422b6964d505db7dbc35b3680a9d47b8d97ac550828bdb9bac7'
'f96e9f815fa0a4b85e677f2a9215d9106b8abe46eceb3f3e36a6c76eda3e4a85'
- 'df669d731c0cb14d7702c0bd9228d35a2da2c941a684313ec11c9ed00ae1fb25'
+ '387c123ab6efe9c51ab7eeb9c20a0cbe6c3b94887d717ca3da2e15b66dc963f8'
'0b6c3ee516608ce04d7133db52cadfa1be5d885b3f82bb39dc5897b213847e0d'
'5e79c40cf3ab93348fc89e97890198601767ea2c8fea89ea76088c17a2b35962')
validpgpkeys=('1B8C5E87702444D3D825CC8086ED62396D5DBA58' # Omar Vega Ramos
@@ -142,7 +145,7 @@ package() {
install -m644 "$srcdir"/$pkgname.maps "$pkgdir"/var/lib/texmf/arch/installedpkgs/
install -m644 "$srcdir"/$pkgname.fmts "$pkgdir"/var/lib/texmf/arch/installedpkgs/
install -m755 -d "$pkgdir"/usr/share
- wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
+ wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && [[ $d != texlive-man ]] && echo $d; done) || true
for dir in $wanteddirs; do
find $dir -type d -exec install -d -m755 "$pkgdir"/usr/share/texmf-dist/'{}' \;
find $dir -type f -exec install -m644 '{}' "$pkgdir"/usr/share/texmf-dist/'{}' \;
@@ -162,8 +165,10 @@ package() {
install -d -m755 "$pkgdir"/etc/texmf/tex/generic/tex-ini-files
install -d -m755 "$pkgdir"/etc/texmf/ttf2pk
install -d -m755 "$pkgdir"/etc/texmf/xdvi
- install -d -m755 "$pkgdir"/etc/fonts/conf.avail
- install -m644 "$srcdir"/09-texlive-fonts.conf "$pkgdir"/etc/fonts/conf.avail/
+
+ install -d -m755 "$pkgdir"/usr/share/fontconfig/conf.avail
+ install -m644 "$srcdir"/09-texlive-fonts.conf \
+ "$pkgdir"/usr/share/fontconfig/conf.avail/
# Remove manpages (already in texlive-bin).
rm -rf "$pkgdir"/usr/share/texmf-dist/doc/man
@@ -203,9 +208,6 @@ package() {
# replace upstream texmfcnf.lua with ours
install -m644 "$srcdir"/texmfcnf.lua "$pkgdir"/usr/share/texmf-dist/web2c/texmfcnf.lua
- # use python2 instead of python for scripts.
- sed -i '1s/python/python2/' "$pkgdir"/usr/share/texmf-dist/scripts/de-macro/de-macro
-
# install Perl libraries
mv "$pkgdir"/usr/share/texmf-dist/tlpkg "$pkgdir"/usr/share
rm -rf "$pkgdir"/usr/share/tlpkg/tlpobj
@@ -217,7 +219,7 @@ package() {
install -D -m755 ${srcdir}/mktexlsr.script "$pkgdir/usr/share/libalpm/scripts/mktexlsr"
install -D -m755 ${srcdir}/texlive-updmap.script "$pkgdir/usr/share/libalpm/scripts/texlive-updmap"
install -D -m755 ${srcdir}/texlive-fmtutil.script "$pkgdir/usr/share/libalpm/scripts/texlive-fmtutil"
-
+
# remove upstream updmap.cfg: it contains too many maps.
rm "${pkgdir}/usr/share/texmf-dist/web2c/updmap.cfg"
# remove upstream fmtutil.cnf: it will be autogenerated
@@ -227,12 +229,14 @@ package() {
rm -rf "$pkgdir/usr/share/texmf-dist/scripts/context/stubs/mswin/"
# link programs from /usr/share/texmf-dist/scripts
+ # texaccents is a SNOBOL program and will not be linked
_linked_scripts="
a2ping/a2ping.pl
accfonts/mkt1font
accfonts/vpl2ovp
accfonts/vpl2vpl
adhocfilelist/adhocfilelist.sh
+albatross/albatross.sh
arara/arara.sh
attachfile2/pdfatfi.pl
bundledoc/arlatex
@@ -246,19 +250,13 @@ cjk-gs-integrate/cjk-gs-integrate.pl
clojure-pamphlet/pamphletangler
cluttex/cluttex.lua
context/perl/mptopdf.pl
-context/stubs/unix/context
-context/stubs/unix/contextjit
-context/stubs/unix/luatools
-context/stubs/unix/mtxrun
-context/stubs/unix/mtxrunjit
-context/stubs/unix/texexec
-context/stubs/unix/texmfstart
ctan-o-mat/ctan-o-mat.pl
ctanbib/ctanbib
ctanify/ctanify
ctanupload/ctanupload.pl
de-macro/de-macro
dosepsbin/dosepsbin.pl
+digestif/digestif.texlua
dtxgen/dtxgen
dviasm/dviasm.py
dviinfox/dviinfox.pl
@@ -268,6 +266,7 @@ fontools/afm2afm
fontools/autoinst
fontools/ot2kpx
fragmaster/fragmaster.pl
+git-latexdiff/git-latexdiff
installfont/installfont-tl
jfmutil/jfmutil.pl
ketcindy/ketcindy.sh
@@ -282,14 +281,17 @@ latexfileversion/latexfileversion
latexindent/latexindent.pl
latexmk/latexmk.pl
latexpand/latexpand
+light-latex-make/llmk.lua
ltxfileinfo/ltxfileinfo
ltximg/ltximg.pl
+luafindfont/luafindfont.lua
luaotfload/luaotfload-tool.lua
lwarp/lwarpmk.lua
make4ht/make4ht
match_parens/match_parens
mf2pt1/mf2pt1.pl
mkjobtexmf/mkjobtexmf.pl
+optexcount/optexcount
pdfbook2/pdfbook2
pdfcrop/pdfcrop.pl
pdfjam/pdfjam
@@ -305,6 +307,7 @@ purifyeps/purifyeps
pythontex/depythontex.py
pythontex/pythontex.py
simpdftex/simpdftex
+spix/spix.py
srcredact/srcredact.pl
sty2dtx/sty2dtx.pl
tex4ebook/tex4ebook
@@ -339,6 +342,8 @@ texlive-extra/texconfig-dialog.sh
texlive-extra/texconfig-sys.sh
texlive-extra/texconfig.sh
texlive-extra/texlinks.sh
+texlive-extra/xelatex-unsafe.sh
+texlive-extra/xetex-unsafe.sh
texlive/fmtutil-sys.sh
texlive/fmtutil-user.sh
texlive/fmtutil.pl
@@ -346,12 +351,14 @@ texlive/mktexlsr
texlive/mktexmf
texlive/mktexpk
texlive/mktextfm
-texlive/rungs.tlu
+texlive/rungs.lua
texlive/updmap-sys.sh
texlive/updmap-user.sh
texlive/updmap.pl
texliveonfly/texliveonfly.py
texloganalyser/texloganalyser
+texlogfilter/texlogfilter
+texlogsieve/texlogsieve
texplate/texplate.sh
thumbpdf/thumbpdf.pl
typeoutfileinfo/typeoutfileinfo.sh
@@ -360,10 +367,14 @@ xindy/texindy.pl
xindy/xindy.pl
"
install -m755 -d "$pkgdir/usr/bin"
+ install -m755 -d "$pkgdir/usr/share/man/man1"
for _script in ${_linked_scripts}; do
_scriptbase=$(basename $_script)
_scriptbase=${_scriptbase%.*}
ln -s /usr/share/texmf-dist/scripts/${_script} "${pkgdir}/usr/bin/${_scriptbase}"
+ if [[ -f "$srcdir/texlive-man/man1/${_scriptbase}.1" ]]; then
+ install -m644 "$srcdir/texlive-man/man1/${_scriptbase}.1" "${pkgdir}/usr/share/man/man1/"
+ fi
done
ln -s /usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh "${pkgdir}/usr/bin/listings-ext.sh"
@@ -379,4 +390,7 @@ xindy/xindy.pl
ln -s mktexlsr "${pkgdir}"/usr/bin/texhash
ln -s pdfcrop "${pkgdir}"/usr/bin/rpdfcrop
ln -s texdef "${pkgdir}"/usr/bin/latexdef
+ for _scriptbase in allec kpsepath kpsexpand mktexfmt texhash; do
+ install -m644 "$srcdir/texlive-man/man1/${_scriptbase}.1" "${pkgdir}/usr/share/man/man1/"
+ done
}