summaryrefslogtreecommitdiff
path: root/libre/unzip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/unzip/PKGBUILD')
-rw-r--r--libre/unzip/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/libre/unzip/PKGBUILD b/libre/unzip/PKGBUILD
index 79c081b2e..596b033aa 100644
--- a/libre/unzip/PKGBUILD
+++ b/libre/unzip/PKGBUILD
@@ -1,16 +1,17 @@
-# $Id: PKGBUILD 233850 2015-03-15 04:53:48Z bisson $
+# $Id: PKGBUILD 250045 2015-11-03 07:35:37Z bisson $
# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
# Contributor (Arch): Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor (Arch): Robson Peixoto
+# Maintainer: André Silva <emulatorman@parabola.nu>
_pkgname=unzip-libre
pkgname=unzip
pkgver=6.0
_pkgver=${pkgver/./}
-pkgrel=10.parabola1
+pkgrel=11.parabola1
pkgdesc='For extracting and viewing files in .zip archives'
url='http://www.info-zip.org/UnZip.html'
-arch=('i686' 'x86_64' 'mips64el')
+arch=('i686' 'x86_64' 'armv7h')
license=('custom')
depends=('bzip2' 'bash')
conflicts=("${_pkgname}")
@@ -47,6 +48,9 @@ prepare() {
patch -i ../test_compr_eb.patch # FS#43391
patch -i ../getZip64Data.patch # FS#43300
patch -i ../crc32.patch # FS#43300
+ patch -p1 -i ../empty-input.patch # FS#46955
+ patch -p1 -i ../csiz-underflow.patch # FS#46955
+ patch -p1 -i ../nextbyte-overflow.patch # FS#46955
}
build() {