summaryrefslogtreecommitdiff
path: root/nonprism/banshee/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/banshee/PKGBUILD')
-rw-r--r--nonprism/banshee/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/nonprism/banshee/PKGBUILD b/nonprism/banshee/PKGBUILD
index f8487407b..386ca0052 100644
--- a/nonprism/banshee/PKGBUILD
+++ b/nonprism/banshee/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=banshee
pkgver=2.6.2
-pkgrel=4.nonprism1
+pkgrel=5.nonprism1
pkgdesc="Music management and playback for GNOME, without gdata-sharp support"
arch=('i686' 'x86_64' 'mips64el')
url="http://banshee.fm/"
license=('MIT')
-depends=(libxxf86vm gst-plugins-base-libs mono-addins dbus-sharp-glib webkitgtk2 libsoup-gnome taglib-sharp gudev-sharp gkeyfile-sharp gconf-sharp libmtp libgpod mono-zeroconf desktop-file-utils hicolor-icon-theme media-player-info gst-plugins-bad mono-upnp gst-plugins-good)
+depends=(libxxf86vm gst-plugins-base-libs mono-addins dbus-sharp-glib webkitgtk2 libsoup-gnome taglib-sharp gudev-sharp gkeyfile-sharp gconf-sharp libmtp libgpod mono-zeroconf desktop-file-utils hicolor-icon-theme media-player-info gst-plugins-bad mono-upnp gst-plugins-good gvfs)
makedepends=('intltool' 'gnome-doc-utils' 'gtk-sharp-beans' 'gnome-common')
optdepends=('gst-plugins-ugly: Extra media codecs'
'gst-libav: Extra media codecs'
@@ -20,15 +20,16 @@ conflicts=(${pkgname}-nonprism)
install=$pkgname.install
source=(http://download.gnome.org/sources/$pkgname/2.6/$pkgname-$pkgver.tar.xz
Initial-port-to-GStreamer-1.0.patch
- Remove-build-time-enable-gapless-playback-option.patch)
-md5sums=('12dbb8a996783f7081d538062a8589b7'
- '16cbe2ef60e6f9b22015585bb3209648'
- '0bf7ee4241b12538779c9ecc401d142a')
+ Remove-build-time-enable-gapless-playback-option.patch
+ Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
+ Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch)
prepare() {
cd $pkgname-$pkgver
patch -p1 -i ../Initial-port-to-GStreamer-1.0.patch
patch -p1 -i ../Remove-build-time-enable-gapless-playback-option.patch
+ patch -p1 -i ../Don-t-use-the-new-decoded-pad-signal-of-decodebin.patch
+ patch -p1 -i ../Use-new-style-GStreamer-1.0-raw-audio-caps-in-the-WA.patch
}
build() {
@@ -58,3 +59,8 @@ package() {
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
+md5sums=('12dbb8a996783f7081d538062a8589b7'
+ '16cbe2ef60e6f9b22015585bb3209648'
+ '0bf7ee4241b12538779c9ecc401d142a'
+ 'f87534f54029794bd7be2a123ab01300'
+ 'd092827720e4a11549587eb3131123ae')