summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD66
1 files changed, 38 insertions, 28 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index f4932ddfe..5ac31f985 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -1,21 +1,24 @@
-# $Id: PKGBUILD 288058 2017-02-05 09:28:56Z andyrtr $
+# Maintainer: Andreas Grapentin <andreas@grapentin.org>
# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
-# Maintainer: Márcio Silva <coadde@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
pkgname=claws-mail
-pkgver=3.14.1
+
+pkgver=3.15.1
pkgrel=3.nonprism1
+arch=(i686 x86_64 armv7h)
+
pkgdesc="A GTK+ based e-mail client, without libgdata support"
-arch=('i686' 'x86_64' 'armv7h')
-license=('GPL3')
url="http://www.claws-mail.org"
-depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
- 'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('spamassassin' 'bogofilter' 'valgrind'
+license=(GPL3)
+
+depends=(gtk2 gnutls startup-notification enchant gpgme libetpan compface
+ libsm dbus-glib hicolor-icon-theme desktop-file-utils)
+makedepends=(spamassassin bogofilter valgrind
# dependencies for plugins
- 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'dillo'
+ libnotify libcanberra poppler-glib pygtk libytnef libical dillo
# deps to build the docs
- 'docbook-utils')
+ docbook-utils)
#'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
optdepends=('python2: needed for some tools and python plugin'
'perl: needed for some tools and perl plugin'
@@ -30,31 +33,39 @@ optdepends=('python2: needed for some tools and python plugin'
'libytnef: for tnef_parse plugin'
'poppler-glib: for pdf viewer plugin'
'ghostscript: for pdf viewer plugin'
+ 'libical: for vcalendar plugin'
'dillo: for html viewer plugin')
-replaces=('sylpheed-claws' 'claws-mail-extra-plugins' 'claws-mail-libre' 'claws-mail-libre-nonprism' 'claws-mail-nonprism')
-conflicts=('claws-mail-extra-plugins' 'claws-mail-libre' 'claws-mail-libre-nonprism' 'claws-mail-nonprism')
-provides=('claws')
+replaces=(sylpheed-claws claws-mail-extra-plugins claws-mail-libre claws-mail-libre-nonprism claws-mail-nonprism)
+conflicts=(claws-mail-extra-plugins claws-mail-libre claws-mail-libre-nonprism claws-mail-nonprism)
+provides=(claws)
+
source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
- dillo-plugin.diff)
-sha256sums=('b79a1dc04f0b3d1f693e84d7fa7282f140fb5280179281445a8b954ce423c335'
+ dillo-plugin.diff
+ enchant-2.patch
+ claws-mail-3.15.1-libical3.patch)
+sha256sums=('8d093c2f32db863c1141d56e35424c04ee48fe5d6adf4c7f349f647fa3149542'
'SKIP'
- 'e58fde187b53ce12d4cb711a11ad2c6f5c3d152253e07999710decfd414b14ce')
+ '4913d101aa32a69afda7ffb17eb23dce8580bfb619e28cc271f4ea10ce39cc5d'
+ 'fafd9713b265b55a84b01e5071d930965b98d34cde57be4aaa46c5eb6c2635ce'
+ '160cb7a3ac057c5a8f65427adc152f53abd372eeaf1b371e9a99bfcb741a793f')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
prepare() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
# upstream reintroduction of dillo plugin - after fancy plugin dropped
patch -Np1 -i ../dillo-plugin.diff
+ patch -Np1 -i ../enchant-2.patch
+ patch -Np1 -i ../claws-mail-3.15.1-libical3.patch
autoreconf -vfi
+ sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
+ sed -i 's:python -c:python2 -c:g' configure
}
build() {
- cd ${pkgname}-${pkgver}
+ cd $pkgname-$pkgver
# fixes for python2
export PYTHON="/usr/bin/python2"
- sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
- sed -i 's:python -c:python2 -c:g' configure
./configure --prefix=/usr --disable-static \
--enable-enchant \
@@ -65,19 +76,18 @@ build() {
--enable-spamassassin-plugin \
--enable-bogofilter-plugin \
--disable-gdata-plugin #--help
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
- # build and install extra tools
+ # install extra tools
cd tools
- make
- # all executables and .conf files ; only top directory
- find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i ; do
- install -D -m755 ${i} \
- ${pkgdir}/usr/lib/claws-mail/tools/${i}
+ install -m755 -d $pkgdir/usr/lib/claws-mail/tools
+ for files in *.pl *.py *.sh kdeservicemenu multiwebsearch.conf tb2claws-mail update-po uudec uuooffice README; do
+ cp -arv $files $pkgdir/usr/lib/claws-mail/tools/$i
done
}