summaryrefslogtreecommitdiff
path: root/nonprism/duplicity/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/duplicity/PKGBUILD')
-rw-r--r--nonprism/duplicity/PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/nonprism/duplicity/PKGBUILD b/nonprism/duplicity/PKGBUILD
new file mode 100644
index 000000000..f1fb1feef
--- /dev/null
+++ b/nonprism/duplicity/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD 110919 2014-05-09 15:34:16Z lfleischer $
+# Maintainer (Arch): Lukas Fleischer <archlinux at cryptocrack dot de>
+# Contributor (Arch): Kaiting Chen <kaitocracy@gmail.com>
+# Contributor (Arch): Aaron Schaefer <aaron@elasticdog.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=duplicity
+pkgver=0.6.24
+pkgrel=1.nonprism1
+pkgdesc='A utility for encrypted, bandwidth-efficient backups using the rsync algorithm, without python2-gdata recommendation'
+arch=('i686' 'x86_64' 'mips64el')
+url='http://www.nongnu.org/duplicity/'
+license=('GPL')
+replaces=(${pkgname}-nonprism)
+conflicts=(${pkgname}-nonprism)
+depends=('gnupg' 'librsync' 'ncftp' 'python2-paramiko' 'python2-lockfile')
+makedepends=('python2-setuptools')
+optdepends=('lftp: FTPS backend'
+ 'python2-boto: Amazon S3 backend'
+ 'python2-gobject: GIO backend'
+ 'gvfs: GIO backend'
+ 'python2-httplib2: Ubuntu One backend'
+ 'python2-oauthlib: Ubuntu One backend'
+ 'rsync: rsync backend')
+source=("https://launchpad.net/$pkgname/0.6-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"{,.sig})
+md5sums=('5d4e9329a6d793880909d18b0736ff06'
+ 'SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python$_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python$_#!/usr/bin/env python2_' $file
+ done
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # fix broken documentation permissions until upstream does (FS#27301)
+ chmod 644 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ chmod 644 "$pkgdir/usr/share/man/man1/rdiffdir.1"
+ chmod 644 "$pkgdir/usr/share/doc/$pkgname-$pkgver"/*
+}