summaryrefslogtreecommitdiff
path: root/nonprism/gnome-settings-daemon/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/gnome-settings-daemon/PKGBUILD')
-rw-r--r--nonprism/gnome-settings-daemon/PKGBUILD90
1 files changed, 65 insertions, 25 deletions
diff --git a/nonprism/gnome-settings-daemon/PKGBUILD b/nonprism/gnome-settings-daemon/PKGBUILD
index 2921ffe88..e76c88b40 100644
--- a/nonprism/gnome-settings-daemon/PKGBUILD
+++ b/nonprism/gnome-settings-daemon/PKGBUILD
@@ -1,60 +1,100 @@
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor (Hyperbola): André Silva <emulatorman@hyperbola.info>
+# Maintainer (arch): Fabian Bornschein <fabiscafe-at-mailbox-dot-org>
+# Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: Andreas Grapentin <andreas@grapentin.org>
# Contributor: Isaac David <isacdaavid@at@isacdaavid.info>
# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
# parabola changes and rationale:
-# - removed geoclue2 support
-# - add libmm-glib as dependency (implicit in upstream)
+# - removed geoclue support
+
pkgname=gnome-settings-daemon
-pkgver=3.34.1+1+ge1fc4599
+pkgver=45.0
pkgrel=1
pkgrel+=.nonprism1
-pkgdesc="GNOME Settings Daemon, without geoclue2 support"
+pkgdesc="GNOME Settings Daemon"
+pkgdesc+=", without geoclue support"
url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
arch=(x86_64)
-arch+=(i686 armv7h)
+arch+=(armv7h i686)
license=(GPL)
-depends=(dconf gnome-desktop gsettings-desktop-schemas libcanberra-pulse libnotify systemd-libs
- libwacom pulseaudio pulseaudio-alsa upower librsvg libgweather geocode-glib nss
- libgudev gtk3-print-backends libnm gcr libmm-glib)
-makedepends=(xf86-input-wacom libxslt docbook-xsl python git meson)
-checkdepends=(python-gobject python-dbusmock)
+depends=(
+ dconf
+ gcr-4
+ geoclue
+ geocode-glib-2
+ gnome-desktop
+ gsettings-desktop-schemas
+ gtk3
+ libcanberra-pulse
+ libgudev
+ libgweather-4
+ libnm
+ libnotify
+ librsvg
+ libwacom
+ nss
+ pulseaudio
+ pulseaudio-alsa
+ systemd
+ upower
+)
+depends=( ${depends[*]/geoclue/} ) # privacy
+makedepends=(
+ docbook-xsl
+ git
+ libxslt
+ meson
+ python
+ usbguard
+)
+makedepends+=(libmm-glib) # gnome-settings-daemon/meson.build:220:16: ERROR: Dependency "mm-glib" not found, tried pkgconfig
+checkdepends=(
+ python-dbusmock
+ python-gobject
+)
+optdepends=('usbguard: USB protection support')
groups=(gnome)
-_commit=e1fc4599764c9b10e086317164267c78f9338883 # gnome-3-34
-source=("git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- nonprism.patch)
-sha256sums=('SKIP'
- 'SKIP'
- '6619205eb1e4d87caeb8e1673d6c80acf4d30f15ae91c5f6cb728a2e5674bf65')
+backup=(etc/xdg/Xwayland-session.d/00-xrdb)
+_commit=ed2173a812a820d3e7aaa8107e554f9e6068684f # tags/45.0^0
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+)
+source+=(nonprism.patch)
+b2sums=('SKIP'
+ 'SKIP')
+b2sums+=('5bccb162d6fa29940b77ca50fe64190522029424ded00af7e121748726a9b5a730bc637730f0322af45da0ce883af97bc31cd760e88602a0f1ed582889fa59c2')
+
pkgver() {
cd $pkgname
- git describe --tags | sed 's/^GNOME_SETTINGS_DAEMON_//;s/_/./g;s/-/+/g'
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
cd $pkgname
git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
- git submodule update
+ git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
+ git -c protocol.file.allow=always submodule update
+ echo "applying nonprism.patch"
patch -p1 -i $srcdir/nonprism.patch
}
build() {
arch-meson $pkgname build
- ninja -C build
+ meson compile -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}