summaryrefslogtreecommitdiff
path: root/nonprism/gnome-weather/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/gnome-weather/PKGBUILD')
-rw-r--r--nonprism/gnome-weather/PKGBUILD75
1 files changed, 45 insertions, 30 deletions
diff --git a/nonprism/gnome-weather/PKGBUILD b/nonprism/gnome-weather/PKGBUILD
index 92ce19f92..2acf0f263 100644
--- a/nonprism/gnome-weather/PKGBUILD
+++ b/nonprism/gnome-weather/PKGBUILD
@@ -1,49 +1,64 @@
+# Maintainer (arch): Fabian Bornschein <fabiscafe-at-mailbox-dot-org>
+# Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Maintainer: Andreas Grapentin <andreas@grapentin.org>
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: André Silva <emulatorman@hyperbola.info>
-pkgname=gnome-weather
-pkgver=3.26.0
-pkgrel=1.nonprism1
-arch=(any)
+# parabola changes and rationale:
+# privacy:
+# - removed geoclue support
+# technical:
+# - build from versioned source-ball, rather than VCS sources
+
-pkgdesc="Access current weather conditions and forecasts, without geoclue2 support"
+pkgname=gnome-weather
+pkgver=45.0
+pkgrel=1
+pkgrel+=.nonprism1
+pkgdesc="Access current weather conditions and forecasts"
+pkgdesc+=", without geoclue support"
url="https://wiki.gnome.org/Apps/Weather"
+arch=(any)
license=(GPL)
+depends=(
+ geoclue
+ gjs
+ gtk4
+ libadwaita
+ libgweather-4
+)
+depends=( ${depends[*]/geoclue/} ) # privacy
+makedepends=(
+ appstream-glib
+ git
+ gobject-introspection
+ meson
+)
+makedepends=( ${makedepends[*]/git/} )
+groups=(gnome)
+source=(https://download.gnome.org/sources/gnome-weather/45/gnome-weather-45.0.tar.xz)
+source+=(nonprism.patch)
+sha256sums=('30c0029702883dc8d8160e6de1d6116877cd6c25bc950d4e4902a6ab467b2fa4')
+sha256sums+=('226c05dfc345ab4d8ed6b21686d10799a98e65a7050602d944d70208d718d19a')
-makedepends=(intltool gobject-introspection autoconf-archive appstream-glib git)
-depends=(gtk3 gjs libgweather gnome-desktop)
-groups=(gnome-extra)
-
-_commit=608877f993ab001666d9ca843c23c98c16459abe # tags/3.26.0^0
-source=("git+https://git.gnome.org/browse/gnome-weather#commit=$_commit"
- "nonprism.patch")
-sha256sums=('SKIP'
- '982ac0d22e5e46adc97d5b9b964a13c3c036f9525b42b05fc56946a1d114f0de')
-
-pkgver() {
- cd $pkgname
-
- git describe --tags | sed 's/-/+/g'
-}
prepare() {
- cd $pkgname
+ cd ${pkgname}-${pkgver}
- patch -p1 -i $srcdir/nonprism.patch
- NOCONFIGURE=1 ./autogen.sh
+ echo "applying nonprism.patch"
+ patch -p1 -i ${srcdir}/nonprism.patch
}
build() {
- cd $pkgname
+ arch-meson ${pkgname}-${pkgver} build
+ meson compile -C build
+}
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
- make
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- cd $pkgname
-
- make DESTDIR="$pkgdir" install
+ meson install -C build --destdir "$pkgdir"
}
+