summaryrefslogtreecommitdiff
path: root/nonprism/icedove/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/icedove/PKGBUILD')
-rw-r--r--nonprism/icedove/PKGBUILD39
1 files changed, 30 insertions, 9 deletions
diff --git a/nonprism/icedove/PKGBUILD b/nonprism/icedove/PKGBUILD
index 4088cf78c..260b17209 100644
--- a/nonprism/icedove/PKGBUILD
+++ b/nonprism/icedove/PKGBUILD
@@ -1,10 +1,12 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
# Contributor: Márcio Silva <coadde@parabola.nu>
+# Contributor: Luke R. <g4jc@openmailbox.org>
+# Contributor: Isaac David <isacdaavid@isacdaavid.info>
# We're getting this from Debian Sid
_debname=icedove
-_debver=45.2.0
-_debrel=deb2
+_debver=45.3.0
+_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -12,10 +14,10 @@ _pkgname=thunderbird
pkgname=icedove
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=2.nonprism1
+pkgrel=1.nonprism1
pkgdesc="A libre version of Debian Icedove, the standalone mail and news reader based on Mozilla Thunderbird, without support for unsafe and dangerous for privacy protocols"
-arch=(i686 x86_64)
+arch=(i686 x86_64 armv7h)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib gtk2 hunspell icu=57.1 libevent libvpx=1.6.0 libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
makedepends=(autoconf2.13 diffutils gconf imake inetutils libpulse mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
@@ -33,17 +35,21 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
changing-the-default-search-engine.patch
firefox-gcc-6.0.patch mozilla-1228540.patch mozilla-1228540-1.patch
vendor.js
- fix-missing-files.patch)
-sha256sums=('923e7e7a2b9c2e3bdb4424ab0517b93123ee16a1ad9bd55c3ccaa0f0f7796ad0'
- 'e70bb2274c3a93549eca726c65ffd8b6c0a87a986214efd7c66dec3a4c5ac421'
+ fix-missing-files.patch
+ no-neon.patch
+ mozilla-1253216.patch)
+sha256sums=('3e8a34c0e7e41daa400f020c565219fcc4f8d3abe7c14acd909706103fee25f3'
+ '72a23ab7975769e05c25ec838ed2a2e22107093c74788bd320f315451fdda621'
'aaca37bcca176d1b8ebe7c18d3fb0c61e3d21769fbf8e994a189eb3263257d3d'
'0b0d25067c64c6b829c84e5259ffca978e3971f85acc8483f47bdbed5b0b5b6a'
'e1f72c44e31f191271207fc874dcfbf3d504b6b42dc1bb063ba8c7c9ee032130'
'4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
'3a3e84c702ee31450a3e84698441aceb11cf44e64c9fedcaddb8cb50db759417'
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19'
- '058b58074368b57acf8a6df9a9ffac848b7d7b39f5abd84cb2039bcee42b73e2'
- '294a2cc7b0477ad285af10ac2a04b767cabec07f03b23da23014bda71caea510')
+ '173c929176262c0ad27984d68d61918d51d27bbc538ccbe9e6d19727d1f9de4d'
+ '294a2cc7b0477ad285af10ac2a04b767cabec07f03b23da23014bda71caea510'
+ '59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e'
+ '1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
prepare() {
cd "$srcdir/$_pkgname-$_debver"
@@ -130,6 +136,21 @@ prepare() {
# Load our searchplugins
rm -rv mail/locales/en-US/searchplugins
cp -av /usr/lib/mozilla/searchplugins mail/locales/en-US
+
+ # ARM-specific changes:
+ if [[ "$CARCH" == arm* ]]; then
+ patch -Np0 -i ../no-neon.patch
+ patch -p2 -d mozilla < ../mozilla-1253216.patch
+ sed -i '/ac_add_options --enable-gold/d' .mozconfig
+ cat >> .mozconfig <<- EOF
+ ac_add_options --disable-elf-hack
+ ac_add_options --disable-neon
+ ac_add_options --disable-ion
+ ac_add_options --disable-webrtc
+ ac_add_options --disable-debug
+ ac_add_options --disable-debug-symbols
+ EOF
+ fi
}
build() {