summaryrefslogtreecommitdiff
path: root/nonprism/openshot/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/openshot/PKGBUILD')
-rw-r--r--nonprism/openshot/PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/nonprism/openshot/PKGBUILD b/nonprism/openshot/PKGBUILD
index 2fbda5801..e10e2bada 100644
--- a/nonprism/openshot/PKGBUILD
+++ b/nonprism/openshot/PKGBUILD
@@ -11,11 +11,12 @@
# - neuter google analytics and exception tracking as it all happens over http
pkgname=openshot
-pkgver=2.4.1
-pkgrel=1.nonprism3
+pkgver=2.4.3
+pkgrel=1
+pkgrel+=.nonprism1
pkgdesc="a free, non-linear video editor for GNU/Linux based on MLT framework, without nonfree faac recommendation and Youtube uploader support"
arch=('any')
-url="http://www.openshotvideo.com/"
+url="http://www.openshot.org/"
license=('GPL')
depends=('mlt-python-bindings' 'sdl' 'librsvg' 'mplayer'
'pyxdg' 'python-pyqt5' 'python-httplib2' 'python-pillow' 'dvgrab'
@@ -23,14 +24,17 @@ depends=('mlt-python-bindings' 'sdl' 'librsvg' 'mplayer'
'libopenshot' 'python-pyzmq' 'qt5-webkit' 'python-setuptools'
'python-requests')
optdepends=('frei0r-plugins: effects'
- 'libquicktime' 'libavc1394' 'jack' 'jack-rack')
+ 'libquicktime' 'libavc1394' 'jack')
makedepends=('python-setuptools')
+
+
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenShot/openshot-qt/archive/v$pkgver.tar.gz"
'nonprism.patch'
'neuter_tracking.patch')
-sha256sums=('da388c08cd94ec503a57756871244d9bb8746973807e2f95618a0d9d5e11fae9'
- '434b1b52dd873efc0bb2c15b231035e7928decdcd7b2256638fbc0d5ab6c7375'
- 'dc457fac8fdef5a120fe83661ff72bc8bf31ae92ffc503e0439a0d2d10171486')
+
+sha256sums=('901b485c28cfcbb4d1baf3cd6a30b165090c49c96f252236f1bbd8c8ab709721'
+ '31b78e88c83bba0ff469afdbbdc36577ca64a55640e4220e9a88ccf0c7f105dc'
+ '3990bdf10f46cd5255d01b0b113fe10e3ffed16da0577dfcaad470edd016aef9')
prepare() {
cd "$srcdir"/openshot-qt-$pkgver