summaryrefslogtreecommitdiff
path: root/nonprism/tor-hardened-preferences/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/tor-hardened-preferences/PKGBUILD')
-rw-r--r--nonprism/tor-hardened-preferences/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/nonprism/tor-hardened-preferences/PKGBUILD b/nonprism/tor-hardened-preferences/PKGBUILD
new file mode 100644
index 000000000..752bc9494
--- /dev/null
+++ b/nonprism/tor-hardened-preferences/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luke R. <g4jc@openmailbox.org> GPG: rsa4096/3EAE8697
+# Contributor: André Silva <emulatorman@parabola.nu>
+
+pkgname=tor-hardened-preferences
+pkgver=0.1
+pkgrel=1
+pkgdesc="Creates clean chroot for TOR to run in, and cleans left over files when done running."
+arch=(any)
+license=(GPL3)
+depends=('tor')
+url="https://wiki.parabola.nu/Nonprism"
+install=tor-hardened-preferences.install
+source=('tor-hardened.service'
+'tor-hardened.sh'
+'torrc'
+'torchroot.sh'
+'tor-hardened-preferences.install')
+sha512sums=('2bd9ecdc089b49358e4fd1d4cddbc7e6260ab56c0c870f287bb8e4a8553111902df8222d3836046bdf011d2c02123e24cebfe1d9ca88259c7bd61e308bf68c77'
+ '26ca71558e0651858226fe475cd96456e4c9039f1954832e7a7b7011b31b67e82dadd6d033059f88dd8ed355ac9dd4568058f04482c7011d6f0ae47726c9c557'
+ '5d732ddbd96c0467434a03c1ba3aa14f5536affb1fa713a78b0d95eccefbfe4c9b6d68fefcbbf7fc9f23e5e80e4ddfb67f2047ad3bdd14a0b5bb72a9e947404e'
+ 'd767d55763ad2952e1620260fe92d3cd15383454ec7cae17432c8294bbc056ac5a91d9bf958b4a6bef4000d9bc78ca2411c6e6e48b352ec64fb33a8c0f2da98f'
+ '025b2b8ec7c74908af43b13d6dbb7fc85901b7f6e9899ab8e0cfc5f6d806d37d137378d4ef44f04e39250f874cdbe4152357e9e778a007833b779217978d49bb')
+
+package() {
+ mkdir -p ${pkgdir}/opt/tor-hardened-scripts
+ install -Dm755 tor-hardened.sh ${pkgdir}/opt/tor-hardened-scripts/tor-hardened.sh
+ install -Dm644 torrc ${pkgdir}/opt/tor-hardened-scripts/torrc
+ install -Dm755 torchroot.sh ${pkgdir}/opt/tor-hardened-scripts/torchroot.sh
+ install -Dm0644 "${srcdir}/tor-hardened.service" "${pkgdir}/usr/lib/systemd/system/tor-hardened.service"
+}