summaryrefslogtreecommitdiff
path: root/nonprism/your-privacy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/your-privacy/PKGBUILD')
-rw-r--r--nonprism/your-privacy/PKGBUILD68
1 files changed, 48 insertions, 20 deletions
diff --git a/nonprism/your-privacy/PKGBUILD b/nonprism/your-privacy/PKGBUILD
index c1394d87a..5b28775c4 100644
--- a/nonprism/your-privacy/PKGBUILD
+++ b/nonprism/your-privacy/PKGBUILD
@@ -1,30 +1,58 @@
-# Maintainer: Parabola Project <dev@lists.parabola.nu>
+# SPDX-License-Identifier: CC0-1.0
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+
+# NOTE: This PKGBUILD does not need to be edited manually.
+# The package is normally built automatically by the auto-builder.
+# To generate a new package, simply push changes to blacklist.git.
+# If ${pkgname}-blacklist.txt is modified, the auto-builder will
+# replace $pkgver, $_srcver, and the checksum (updpkgsums),
+# build and publish the package, and commit the changes to abslibre.
+
pkgname=your-privacy
-pkgdesc="This package will remove support for protocols and services known to endanger privacy."
-license=('GPL3')
-url="https://git.parabola.nu/blacklist.git"
-pkgver=20200511
-_gitver=e1631bc6d63bbfaa7a37e30f40dbb569249f62c9
+pkgver=20240212
+_srcver=6837f3645efbe7b2b22d27938accba27dad7da46
pkgrel=1
+pkgdesc="This package will remove support for protocols and services known to endanger privacy."
+arch=(any)
+url=https://wiki.parabola.nu/Blacklist
+license=(custom:CCPL:zero)
+# license=('CCPL:zero') # TODO: NYI
-arch=('any')
+makedepends=(librelib)
+backup=(etc/NetworkManager/conf.d/20-connectivity.conf)
install=${pkgname}.install
+_srcname=${pkgname}-blacklist-${_srcver}.txt
+source=(${_srcname}::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_srcver})
+source+=(archlinux-keyring.hook)
-makedepends=(librelib)
-source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
-sha512sums=('39bc1cd312c155a1c799c889dc837d3c35b23bc309af5a3bbc82599e7dd9406fac6781a72d71e13907a06e5b47eccbe652522a4509878315ac161c5ec8b4d221')
+sha256sums=('51bc5ed40f5ac65b5cd0bf2846675f94a4bc6c0487f7a981707ee101ef0e966e'
+ '908ee242989fbf932ff013238ad9c56f9b318c21988199a7dcf404df058d4879')
+
+
+package()
+{
+ # collect blacklisted package names as pacman conflicts
+ conflicts=( $( libreblacklist normalize < ${_srcname} | \
+ cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
-package() {
- cd "$srcdir"
+ install -Dm644 ${_srcname} "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
- conflicts=($( \
- < blacklist-${_gitver}.txt \
- libreblacklist normalize | \
- cut -d: -f1,2 | \
- sed -n 's/:$//p' | \
- sort -u \
- ))
+ # disable automatic archlinux-keyring refresh
+ install -Dm644 archlinux-keyring.hook "${pkgdir}"/usr/share/libalpm/hooks/archlinux-keyring.hook
- install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
+ # disable NetworkManager connectviity check
+ # TODO: This may disable some user-friendliness features.
+ # Something a bit more sophisticated may be needed,
+ # such as a source-level replacement check:
+ # $ dns_ip=$(sed 's|^nameserver ||p;d' /etc/resolv.conf) ; [[ -n "${dns_ip}" ]] && ping -c 1 ${dns_ip} &> /dev/null ;
+ # As of now, we are over-riding 'networkmanager' only for [nonsystemd],
+ # which already changes the target URI to parabola.nu.
+ # This simple solution is an attempt to avoid also packaging it for [nonprism].
+ install -Dm644 /dev/stdin "${pkgdir}"/etc/NetworkManager/conf.d/20-connectivity.conf <<EOF
+[connectivity]
+uri=https://www.parabola.nu/static/nm-check.txt
+enabled=false
+EOF
}