summaryrefslogtreecommitdiff
path: root/nonprism/your-privacy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/your-privacy/PKGBUILD')
-rw-r--r--nonprism/your-privacy/PKGBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/nonprism/your-privacy/PKGBUILD b/nonprism/your-privacy/PKGBUILD
index 1a00cf537..8d6213f64 100644
--- a/nonprism/your-privacy/PKGBUILD
+++ b/nonprism/your-privacy/PKGBUILD
@@ -1,31 +1,39 @@
# SPDX-License-Identifier: CC0-1.0
-# Maintainer: Parabola Project <dev@lists.parabola.nu>
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+
+# NOTE: This PKGBUILD does not need to be edited manually.
+# The package is normally built automatically by autobuilder.
+# To generate a new package, simply push changes to blacklist.git.
+# The autobuilder will modify this PKGBUILD,
+# replacing $pkgver, $_gitver, and the checksum (updpkgsums),
+# build and publish the package,
+# and commit the modified PKGBUILD to abslibre.
pkgname=your-privacy
-pkgdesc="This package will remove support for protocols and services known to endanger privacy."
-license=('GPL3')
-url="https://git.parabola.nu/blacklist.git"
pkgver=20211130
-_gitver=ab32447a5a47a2a5ec5a3fa6043dc6b9024e3674
pkgrel=1
+_gitver=ab32447a5a47a2a5ec5a3fa6043dc6b9024e3674
+pkgdesc="This package will remove support for protocols and services known to endanger privacy."
+arch=(any)
+url=https://wiki.parabola.nu/Blacklist
+license=(GPL3)
-arch=('any')
+makedepends=(librelib)
install=${pkgname}.install
+source=(${pkgname}-blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
-makedepends=(librelib)
-source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
sha512sums=('9ab837a9ca351bb844ecdfc147d69ec1f0d1971fbe12ceeed3b837fc59c54b10d2476901e60f677b0f53166a805b493b0a8bcd638e9e6638012dd454c7930cf8')
package()
{
- cd "${srcdir}"
-
+ # collect blacklisted package names as pacman conflicts
conflicts=( $( libreblacklist normalize < blacklist-${_gitver}.txt | \
cut -d: -f1,2 | \
sed -n 's/:$//p' | \
sort -u ) )
- install -Dm644 blacklist-${_gitver}.txt "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
+ install -Dm644 ${pkgname}-blacklist-${_gitver}.txt "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
}