summaryrefslogtreecommitdiff
path: root/nonsystemd/dbus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/dbus/PKGBUILD')
-rw-r--r--nonsystemd/dbus/PKGBUILD183
1 files changed, 119 insertions, 64 deletions
diff --git a/nonsystemd/dbus/PKGBUILD b/nonsystemd/dbus/PKGBUILD
index 5c9778c0d..c8949fcb7 100644
--- a/nonsystemd/dbus/PKGBUILD
+++ b/nonsystemd/dbus/PKGBUILD
@@ -1,77 +1,127 @@
-# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Jan de Groot <jgc@archlinux.org>
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor (Arch): Tom Gundersen <teg@jklm.no>
-# Contributor (Arch): Link Dupont <link@subpop.net>
-
-pkgname=dbus
-pkgver=1.12.16
-pkgrel=5
+# Maintainer (arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Link Dupont <link@subpop.net>
+# Contributor: bill-auger <bill-auger@programmer.net>
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+
+# parabola changes and rationale:
+# - support non-systemd
+# - disable tests by default (some require networking)
+
+
+pkgbase=dbus
+pkgname=(
+ dbus
+ dbus-docs
+)
+pkgver=1.14.6
+pkgrel=2
pkgrel+=.nonsystemd1
pkgdesc="Freedesktop.org message bus system"
url="https://wiki.freedesktop.org/www/Software/dbus/"
-arch=(x86_64 i686 armv7h)
-license=(GPL custom)
-depends=(libx11 libelogind expat audit)
-depends+=(libelogind.so libaudit.so)
-makedepends=(elogind xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive)
-provides=(libdbus libdbus-1.so)
-provides+=($pkgname-{elogind,openrc})
-conflicts=(${provides[@]})
-replaces=(${provides[@]})
-_commit=23cc709db8fab94f11fa48772bff396b20aea8b0 # tags/dbus-1.12.16^0
-source=("git+https://gitlab.freedesktop.org/dbus/dbus.git#commit=$_commit"
- dbus-reload.hook
- dbus-enable-elogind.patch
- dbus.initd)
-sha256sums=('SKIP'
- '1335a86bb5eb68614bf13af314f1a7f5f6f68253584986e9c5b492a4585ab722'
- 'faffcaa5b295f49fcedeed2c9ece5298949096be3062fd99a4bf1a6ac3ad1ea0'
- '9964aa935b4a7d64f5970bcfcd561b06013a85ae2712444bc4c5f644364dab3b')
-validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90' # Simon McVittie <simon.mcvittie@collabora.co.uk>
- '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>
-
-pkgver() {
- cd dbus
- git describe --tags | sed 's/^dbus-//;s/-/+/g'
-}
+arch=(x86_64)
+arch+=(i686 armv7h)
+license=(
+ GPL
+ custom
+)
+depends=(
+ audit
+ expat
+ systemd-libs
+)
+depends=( ${depends[*]/systemd-libs/libelogind} )
+depends+=(libx11)
+makedepends=(
+ autoconf-archive
+ docbook-xsl
+ doxygen
+ git
+ python
+ systemd
+ xmlto
+ yelp-tools
+)
+makedepends=( ${makedepends[*]/systemd/elogind} )
+source=(
+ "git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
+ dbus-enable-elogind.patch
+ no-fatal-warnings.diff
+)
+b2sums=('SKIP'
+ 'c9ef41ff7b31af6cbaf28ca16974fb62aa0f2492f1c6970b41216758768d1139d2ce9aabbb3aff952d625b0decd1e8c2b25f79bb0a13c146aa9453dd4f7b5c5a'
+ '1f14c134f0511b7bd8e2dc71f665a6e6e23f0addd944888c6f956d4f29c7caa962aa05fdbe9a10d500a28751ba635168248ae7609c269e03e00366b85d5d488f')
+validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
+
+
+_DISABLE_TESTS=1
+
prepare() {
cd dbus
- patch -Np 1 -i ${srcdir}/dbus-enable-elogind.patch
+ patch -Np 1 -i ../dbus-enable-elogind.patch
+
+ # Allow us to enable checks without them being fatal
+ patch -Np1 -i ../no-fatal-warnings.diff
+
NOCONFIGURE=1 ./autogen.sh
}
build() {
+ local configure_options=(
+ --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --libexecdir=/usr/lib/dbus-1.0
+ --runstatedir=/run
+ --with-console-auth-dir=/run/console/
+ --with-dbus-user=dbus
+ --with-system-pid-file=/run/dbus/pid
+ --with-system-socket=/run/dbus/system_bus_socket
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+ --enable-inotify
+ --enable-libaudit
+ --enable-systemd
+ --enable-user-session
+ --enable-xml-docs
+ --enable-doxygen-docs
+ --enable-ducktype-docs
+ --disable-static
+ --without-x
+ )
+ configure_options=( ${configure_options[*]/--with-systemdsystemunitdir=\/usr\/lib\/systemd\/system/--without-systemdsystemunitdir} )
+ configure_options=( ${configure_options[*]/--enable-systemd/--disable-systemd} )
+ configure_options=( ${configure_options[*]/--enable-user-session/--disable-user-session} )
+ configure_options=( ${configure_options[*]/--without-x/--enable-x11-autolaunch} )
+ configure_options+=( --enable-elogind )
+
cd dbus
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 \
- --with-console-auth-dir=/run/console/ \
- --with-dbus-user=dbus \
- --with-system-pid-file=/run/dbus/pid \
- --with-system-socket=/run/dbus/system_bus_socket \
- --without-systemdsystemunitdir \
- --enable-inotify \
- --disable-systemd \
- --disable-user-session \
- --disable-static \
- --disable-verbose-mode \
- --disable-asserts \
- --disable-checks \
- --enable-elogind \
- --enable-x11-autolaunch
+ ./configure "${configure_options[@]}"
make
}
check() {
- make -C dbus check
+ (( ! _DISABLE_TESTS )) || ! echo "skipping check()" || return 0
+
+ make -C dbus -j1 check
}
-package() {
+package_dbus() {
+ depends+=(
+ libaudit.so
+ libsystemd.so
+ )
+ depends=( ${depends[*]/libsystemd.so/libelogind.so} )
+ provides=(
+ libdbus
+ libdbus-1.so
+ )
+ conflicts=(libdbus)
+ replaces=(libdbus)
+
DESTDIR="$pkgdir" make -C dbus install
rm -r "$pkgdir"/{etc,var}
@@ -80,16 +130,21 @@ package() {
echo 'u dbus 81 "System Message Bus"' |
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
- install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+ # TODO: missing hook?
# Split docs
- mv "$pkgdir/usr/share/doc" "$srcdir"
+ mkdir -p doc/usr/share
+ mv {"$pkgdir",doc}/usr/share/doc
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+}
+
+package_dbus-docs() {
+ pkgdesc+=" - Documentation"
+ depends=()
- # Init script
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
- install -Dm755 "$srcdir/dbus.initd" "$pkgdir/etc/init.d/dbus"
- install -d "${pkgdir}/etc/runlevels/default"
- ln -sf "/etc/init.d/dbus" "${pkgdir}/etc/runlevels/default/dbus"
+ mv doc/* "$pkgdir"
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
}
-# vim:set sw=2 et: