summaryrefslogtreecommitdiff
path: root/nonsystemd/hdparm-openrc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/hdparm-openrc/PKGBUILD')
-rw-r--r--nonsystemd/hdparm-openrc/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/nonsystemd/hdparm-openrc/PKGBUILD b/nonsystemd/hdparm-openrc/PKGBUILD
new file mode 100644
index 000000000..a146fccf4
--- /dev/null
+++ b/nonsystemd/hdparm-openrc/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: David P. <megver83@parabola.nu>
+# Maintainer (Artix): artoo <artoo@artixlinux.org>
+
+pkgname=hdparm-openrc
+pkgver=20210505
+pkgrel=3
+pkgdesc="OpenRC hdparm init script"
+arch=('any')
+url="https://gitea.artixlinux.org/artixlinux/packages-openrc"
+license=('GPL2')
+groups=('openrc-system')
+provides=('init-hdparm')
+conflicts=('init-hdparm')
+backup=('etc/conf.d/hdparm')
+source=("hdparm.confd"
+ "hdparm.initd")
+sha256sums=('37c95ff723fa578e9039613d09dbf790d99113a318c065422986c744519214e9'
+ '05b264cadc84984f773cd555af322b41fdb13da7cb2ca60d8a7d590ddf4d5e5f')
+
+package() {
+ depends=('openrc' 'hdparm')
+ install -Dm644 "${srcdir}"/hdparm.confd "${pkgdir}"/etc/conf.d/hdparm
+ install -Dm755 "${srcdir}"/hdparm.initd "${pkgdir}"/etc/init.d/hdparm
+}
+