summaryrefslogtreecommitdiff
path: root/nonsystemd/libretools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/libretools/PKGBUILD')
-rw-r--r--nonsystemd/libretools/PKGBUILD90
1 files changed, 55 insertions, 35 deletions
diff --git a/nonsystemd/libretools/PKGBUILD b/nonsystemd/libretools/PKGBUILD
index 9d21ad451..a8132f9d6 100644
--- a/nonsystemd/libretools/PKGBUILD
+++ b/nonsystemd/libretools/PKGBUILD
@@ -3,49 +3,66 @@
# Contributor: Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
pkgbase=libretools
pkgname=(libretools librelib gitget)
-pkgdesc="Programs for Parabola development"
-url="https://git.parabola.nu/packages/libretools.git/"
-license=('GPL3' 'GPL2')
-
pkgver=20190907
-source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver-nonsystemd.tar.gz{,.sig}
- "revert.patch::https://git.parabola.nu/packages/libretools.git/patch/?id=42cca853176c9ff23a5d2896f9b132630f034fb7"
- 0002-libremakepkg-pacman_5_2.patch)
-sha256sums=('c9bdc6f422234b6b260349e488266500756857bbb65079783aa5e997b6a2d410'
- 'SKIP'
- '108aa8bbfb1ffe96427540cd8f7788338883b08ad038b2ed426e93ac6c57e91b'
- '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
-validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
- '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78') # David P.
-
+_pacman_constraints=( 'pacman<6.2' )
pkgrel=1
-pkgrel+=.nonsystemd2
-
+pkgrel+=.nonsystemd3
+pkgdesc="Programs for Parabola development"
arch=('any')
-makedepends=(ruby-ronn)
+url="https://git.parabola.nu/packages/libretools.git/"
+# license=(GPL-2.0-only GPL-3.0-or-later) # TODO:
+license=('GPL2' 'GPL3')
+
+makedepends=(ruby-ronn-ng)
checkdepends=(
- bash-bats git
- 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
+ bats
+ git
+ "${_pacman_constraints[@]}"
expac
openssh
rsync
tokyocabinet
)
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver-nonsystemd.tar.gz{,.sig})
+source+=(0001-revert.patch
+ 0002-libremakepkg-pacman_5_2.patch)
+sha256sums=('c9bdc6f422234b6b260349e488266500756857bbb65079783aa5e997b6a2d410'
+ 'SKIP')
+sha256sums+=('108aa8bbfb1ffe96427540cd8f7788338883b08ad038b2ed426e93ac6c57e91b'
+ '8986adf14a81b979b2ff4c4e3e76483115c146782e4ba30640649299f98355df')
+validpgpkeys=('99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
+ '6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
+ 'BFA8008A8265677063B11BF47171986E4B745536' # Andreas Grapentin
+ '3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
+
+
prepare() {
- cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
patch -N -p1 -i $srcdir/revert.patch
patch -N -p1 -i $srcdir/0002-libremakepkg-pacman_5_2.patch
}
build() {
- cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
+
make
}
+check() {
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
+
+ # <= 20240327
+ # SUDO_USER= make check TESTENVFLAGS='--no-network --no-sudo'
+ # >= 20240403
+ # SUDO_USER= make check BATS_FLAGS='--filter-tags !network,!sudo'
+}
+
package_librelib() {
pkgdesc="The shell library portion of libretools"
license=(GPL2)
@@ -55,7 +72,8 @@ package_librelib() {
'wget: for libreblacklist/blacklist.sh'
)
- cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
+
make install-librelib DESTDIR="$pkgdir"
}
@@ -64,11 +82,8 @@ package_gitget() {
license=(GPL2)
depends=("librelib=$pkgver" git)
- provides=("libregit=$pkgver")
- conflicts=("libregit")
- replaces=("libregit")
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
- cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
make install-gitget DESTDIR="$pkgdir"
}
@@ -78,29 +93,34 @@ package_libretools() {
etc/libretools.d/libredbdiff.conf
etc/libretools.d/librefetch.conf)
install=libretools.install
- conflicts=(devtools libretools-mips64el)
- replaces=(libretools-mips64el)
+ conflicts=(devtools)
depends=(
- "librelib=$pkgver"
- "gitget=$pkgver" # `createworkdir`
- 'pacman>=5.1.1-1.parabola5' 'pacman<6.1'
arch-install-scripts # `mkarchroot` uses `pacstrap`
- binutils # `libremakepkg` uses `makepkg` uses `strip`
+ binutils # `libremakepkg`->`makepkg` uses `strip`
expac # `libredbdiff`
- fakeroot # `libremakepkg` uses `makepkg` uses `fakeroot`
+ fakeroot # `libremakepkg`->`makepkg` uses `fakeroot`
make # `librefetch`
openssh # `librerelease`
+ pacutils # `librechroot` uses `pacsift`
rsync # `librerelease` and `makechrootpkg.sh`
tokyocabinet # `toru`
- #namcap # Namcap is currently dissabled in libremakepkg :-(
+ namcap # `libremakepkg`
subversion # `diff-unfree`
wget # `aur`, optdepend for librelib:`blacklist`
)
+ depends+=( # pinned dependencies
+ "librelib=$pkgver"
+ "gitget=$pkgver" # `createworkdir`
+ "${_pacman_constraints[@]}"
+ )
+ depends=( ${depends[*]/pacutils/} ) # WIP
+ depends=( ${depends[*]/namcap/} ) # FIXME: Namcap is currently disabled in libremakepkg :-(
optdepends=(
'qemu-user-static-binfmt: To build ARM packages from x86'
)
- cd "$srcdir/$pkgbase-$pkgver-nonsystemd"
+ cd "$srcdir"/$pkgbase-$pkgver-nonsystemd
+
make install-libretools DESTDIR="$pkgdir"
}