summaryrefslogtreecommitdiff
path: root/nonsystemd/opentmpfiles/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/opentmpfiles/PKGBUILD')
-rw-r--r--nonsystemd/opentmpfiles/PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/nonsystemd/opentmpfiles/PKGBUILD b/nonsystemd/opentmpfiles/PKGBUILD
deleted file mode 100644
index c6dc9824f..000000000
--- a/nonsystemd/opentmpfiles/PKGBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# Maintainer: David P. <megver83@parabola.nu>
-# Contributor: Luke Shumaker <lukeshu@parabola.nu>
-# Maintainer (Artix): artoo <artoo@artixlinux.org>
-
-pkgname=opentmpfiles
-pkgver=0.2
-pkgrel=2
-pkgdesc="A standalone utility for handling systemd-style tmpfiles.d settings"
-arch=('any')
-url="https://github.com/OpenRC/opentmpfiles"
-license=('BSD2')
-depends=('pacman')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- '30-opentmpfiles.hook'
- 'tmpfiles-hook')
-sha256sums=('4fa6a78600b1d67d34c441919e5e62ad181af358d9353ce380f515d623177ecb'
- '23c73b3cc20ec38e0a5166f254293c911d20ae3efec8e133f424c1a1d0703fb8'
- 'adbee03530006e8284ea44c5dd7eb99f6cc6c4e383c09fec36d7a22f7d486fc5')
-
-package_opentmpfiles() {
- replaces=('opentmpfiles-systemdcompat')
- conflicts=('opentmpfiles-systemdcompat' 'systemd-tools')
-
- cd "${pkgbase}-${pkgver}"
-
- make bindir="/usr/bin" DESTDIR="${pkgdir}" install
-
- # pacman hooks
- install -Dm755 ${srcdir}/tmpfiles-hook "$pkgdir"/usr/share/libalpm/scripts/tmpfiles-hook
- install -Dm644 -t "$pkgdir"/usr/share/libalpm/hooks ${srcdir}/*.hook
-
- ln -snf "/usr/bin/tmpfiles" "${pkgdir}/usr/bin/systemd-tmpfiles"
-
- install -d "${pkgdir}"/etc/{conf,init}.d "${pkgdir}"/etc/runlevels/{boot,sysinit}
-
- install -m755 openrc/opentmpfiles-dev.confd "${pkgdir}"/etc/conf.d/opentmpfiles-dev
- install -m755 openrc/opentmpfiles-dev.initd "${pkgdir}"/etc/init.d/opentmpfiles-dev
-
- install -m755 openrc/opentmpfiles-setup.confd "${pkgdir}"/etc/conf.d/opentmpfiles-setup
- install -m755 openrc/opentmpfiles-setup.initd "${pkgdir}"/etc/init.d/opentmpfiles-setup
-
- ln -snf /etc/init.d/opentmpfiles-dev "${pkgdir}"/etc/runlevels/sysinit/opentmpfiles-dev
- ln -snf /etc/init.d/opentmpfiles-setup "${pkgdir}"/etc/runlevels/boot/opentmpfiles-setup
-
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 "license" "${pkgdir}/usr/share/licenses/${pkgname}/"
-}