summaryrefslogtreecommitdiff
path: root/nonsystemd/sddm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/sddm/PKGBUILD')
-rw-r--r--nonsystemd/sddm/PKGBUILD83
1 files changed, 51 insertions, 32 deletions
diff --git a/nonsystemd/sddm/PKGBUILD b/nonsystemd/sddm/PKGBUILD
index 47e1389aa..0d1ee6023 100644
--- a/nonsystemd/sddm/PKGBUILD
+++ b/nonsystemd/sddm/PKGBUILD
@@ -4,59 +4,78 @@
# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
pkgname=sddm
-pkgver=0.18.1
-pkgrel=1
+pkgver=0.21.0
+pkgrel=4
pkgrel+=.nonsystemd1
pkgdesc='QML based X11 and Wayland display manager'
-arch=('x86_64')
-arch+=('i686' 'armv7h')
-url='http://github.com/sddm/sddm'
-license=('GPL')
-depends=('qt5-declarative' 'xorg-xauth' 'xorg-server' 'elogind')
-makedepends=('extra-cmake-modules' 'python-docutils' 'qt5-tools')
-makedepends+=('pcre2')
+arch=(x86_64)
+arch+=(i686 armv7h)
+url='https://github.com/sddm/sddm'
+license=(GPL-2.0-only)
+depends=(bash
+ gcc-libs
+ glibc
+ libelogind
+ libxau
+ libxcb
+ pam
+ qt6-base
+ qt6-declarative
+ ttf-font
+ xorg-server
+ xorg-xauth)
+makedepends=(extra-cmake-modules
+ python-docutils
+ qt5-base
+ qt5-declarative
+ qt5-tools
+ qt6-tools)
+optdepends=('qt5-declarative: for using Qt5 themes')
backup=('usr/share/sddm/scripts/Xsetup'
'usr/share/sddm/scripts/Xstop'
'etc/pam.d/sddm'
'etc/pam.d/sddm-autologin'
'etc/pam.d/sddm-greeter')
-provides=('display-manager' 'sddm-elogind')
-replaces=('sddm-elogind')
-conflicts=(${replaces[@]})
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz"
- sddm.sysusers sddm.tmpfiles)
-sha256sums=('07296fc747010a5dd58a45f16c3224b439997afad42566e4b043c841b1b71700'
- '9fce66f325d170c61caed57816f4bc72e9591df083e89da114a3bb16b0a0e60f'
- 'db625f2a3649d6d203e1e1b187a054d5c6263cadf7edd824774d8ace52219677')
-
-prepare() {
- mkdir -p build
-}
+provides=(display-manager)
+source=(https://github.com/$pkgname/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz
+ sddm.{tmpfiles,sysusers})
+sha256sums=('f895de2683627e969e4849dbfbbb2b500787481ca5ba0de6d6dfdae5f1549abf'
+ 'db625f2a3649d6d203e1e1b187a054d5c6263cadf7edd824774d8ace52219677'
+ '9fce66f325d170c61caed57816f4bc72e9591df083e89da114a3bb16b0a0e60f')
build() {
- cd build
- cmake ../${pkgname}-${pkgver} \
+ cmake -B build -S $pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBEXECDIR=/usr/lib/sddm \
+ -DBUILD_WITH_QT6=ON \
-DDBUS_CONFIG_DIR=/usr/share/dbus-1/system.d \
-DDBUS_CONFIG_FILENAME=sddm_org.freedesktop.DisplayManager.conf \
+ -DBUILD_MAN_PAGES=ON \
-DUSE_ELOGIND=yes \
-DNO_SYSTEMD=yes \
- -DBUILD_MAN_PAGES=ON
- make
+ -DUID_MAX=60513
+ cmake --build build
+
+ cmake -B build5 -S $pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build5/src/greeter
+ cmake --build build5/components
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
-
- install -Dm644 "$srcdir"/sddm.sysusers "$pkgdir"/usr/lib/sysusers.d/sddm.conf
- install -Dm644 "$srcdir"/sddm.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/sddm.conf
+ DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build5/src/greeter
+ DESTDIR="$pkgdir" cmake --install build5/components
install -d "$pkgdir"/usr/lib/sddm/sddm.conf.d
"$pkgdir"/usr/bin/sddm --example-config > "$pkgdir"/usr/lib/sddm/sddm.conf.d/default.conf
-# Don't set PATH in sddm.conf
+
+ # Don't set PATH in sddm.conf
sed -r 's|DefaultPath=.*|DefaultPath=/usr/local/sbin:/usr/local/bin:/usr/bin|g' -i "$pkgdir"/usr/lib/sddm/sddm.conf.d/default.conf
-# Unset InputMethod https://github.com/sddm/sddm/issues/952
+
+ # Unset InputMethod https://github.com/sddm/sddm/issues/952
sed -e "/^InputMethod/s/qtvirtualkeyboard//" -i "$pkgdir"/usr/lib/sddm/sddm.conf.d/default.conf
+
+ install -Dm644 sddm.sysusers "$pkgdir"/usr/lib/sysusers.d/sddm.conf
+ install -Dm644 sddm.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/sddm.conf
}