summaryrefslogtreecommitdiff
path: root/nonsystemd/thermald-openrc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/thermald-openrc/PKGBUILD')
-rw-r--r--nonsystemd/thermald-openrc/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/nonsystemd/thermald-openrc/PKGBUILD b/nonsystemd/thermald-openrc/PKGBUILD
new file mode 100644
index 000000000..1c450af44
--- /dev/null
+++ b/nonsystemd/thermald-openrc/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: David P. <megver83@parabola.nu>
+# Maintainer (Artix): Rafli Akmal <rafliakmaltejakusuma@gmail.com>
+# Contributor (Artix): artoo <artoo@artixlinux.org>
+# Contributor (Artix): Oscar Campos <damnwidget@artixlinux.org>
+
+pkgname=thermald-openrc
+pkgver=20210505
+pkgrel=1
+pkgdesc="OpenRC thermald init script"
+arch=('any')
+url="https://gitea.artixlinux.org/artixlinux/packages-openrc"
+license=('GPL2')
+groups=('openrc-galaxy')
+provides=('init-thermald')
+conflicts=('init-thermald')
+source=("thermald.initd")
+sha256sums=('c53e318a6da1e3abd758f864e870f3186ebfe49c729fe65b0f2dd94168e65892')
+
+package() {
+ depends=('dbus-openrc' 'thermald')
+ install -Dm 755 "$srcdir/thermald.initd" "$pkgdir/etc/init.d/thermald"
+}