summaryrefslogtreecommitdiff
path: root/nonsystemd/unbound-openrc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/unbound-openrc/PKGBUILD')
-rw-r--r--nonsystemd/unbound-openrc/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/nonsystemd/unbound-openrc/PKGBUILD b/nonsystemd/unbound-openrc/PKGBUILD
new file mode 100644
index 000000000..19a7a9d87
--- /dev/null
+++ b/nonsystemd/unbound-openrc/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: David P. <megver83@parabola.nu>
+# Maintainer (Artix): Rafli Akmal <rafliakmaltejakusuma@gmail.com>
+# Contributor (Artix): artoo <artoo@artixlinux.org>
+# Contributor (Artix): Oscar Campos <damnwidget@artixlinux.org>
+
+pkgname=unbound-openrc
+pkgver=20210505
+pkgrel=1
+pkgdesc="OpenRC unbound init script"
+arch=('any')
+url="https://gitea.artixlinux.org/artixlinux/packages-openrc"
+license=('GPL2')
+groups=('openrc-galaxy')
+provides=('init-unbound')
+conflicts=('init-unbound')
+backup=('etc/conf.d/unbound')
+source=("unbound.confd"
+ "unbound.initd")
+sha256sums=('7be43d80f0caf6448048a0278615617e0eaffd2e8e23468576149af8cece465f'
+ 'cb40465590249b9fe14e435944ce308ba1adf5853dfd8f90080232155a82144c')
+
+package() {
+ depends=('openrc' 'unbound')
+ install -Dm755 "$srcdir/unbound.initd" "$pkgdir/etc/init.d/unbound"
+ install -Dm644 "$srcdir/unbound.confd" "$pkgdir/etc/conf.d/unbound"
+}