summaryrefslogtreecommitdiff
path: root/nonsystemd/util-linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/util-linux/PKGBUILD')
-rw-r--r--nonsystemd/util-linux/PKGBUILD267
1 files changed, 181 insertions, 86 deletions
diff --git a/nonsystemd/util-linux/PKGBUILD b/nonsystemd/util-linux/PKGBUILD
index 1f31c0352..0d5ea698e 100644
--- a/nonsystemd/util-linux/PKGBUILD
+++ b/nonsystemd/util-linux/PKGBUILD
@@ -1,116 +1,211 @@
# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Tom Gundersen <teg@jklm.no>
-# Maintainer (Arch): Dave Reisner <dreisner@archlinux.org>
-# Contributor (Arch): judd <jvinet@zeroflux.org>
+# Maintainer (artix): Artoo <artoo@artixlinux.org>
+# Maintainer (arch): Tom Gundersen <teg@jklm.no>
+# Maintainer (arch): Dave Reisner <dreisner@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
pkgbase=util-linux
-pkgname=(util-linux libutil-linux)
-_pkgmajor=2.35
-pkgver=${_pkgmajor}.1
-pkgrel=1
+pkgname=(util-linux util-linux-libs)
+_tag='2.40-rc2'
+pkgver="${_tag/-/}"
+pkgrel=2
pkgrel+=.nonsystemd1
-pkgdesc="Miscellaneous system utilities for GNU/Linux"
-url="https://github.com/karelzak/util-linux"
-arch=('x86_64' 'i686' 'armv7h')
-makedepends=('udev' 'python' 'libcap-ng')
+pkgdesc='Miscellaneous system utilities for Linux'
+url='https://github.com/util-linux/util-linux'
+arch=('x86_64')
+arch+=('armv7h' 'i686')
+makedepends=('asciidoctor'
+ 'bash-completion'
+ 'git'
+ 'libcap-ng'
+ 'libutempter'
+ 'libxcrypt'
+ 'meson'
+ 'python'
+ 'sqlite'
+ 'systemd')
+makedepends=( ${makedepends[*]/systemd/udev} ) # DIFF: non-systemd
+license=(
+ 'BSD-2-Clause'
+ 'BSD-3-Clause'
+ 'BSD-4-Clause-UC'
+ 'GPL-2.0-only'
+ 'GPL-2.0-or-later'
+ 'GPL-3.0-or-later'
+ 'ISC'
+ 'LGPL-2.1-or-later'
+ 'LicenseRef-PublicDomain'
+) # TODO: SPDX
license=('GPL2')
options=('strip')
validpgpkeys=('B0C64D14301CC6EFAEDF60E4E4B71D5EEC39C284') # Karel Zak
-source=("https://www.kernel.org/pub/linux/utils/util-linux/v$_pkgmajor/$pkgbase-$pkgver.tar."{xz,sign}
- pam-{login,common,runuser,su}
+source=("git+https://github.com/util-linux/util-linux#tag=v${_tag}?signed"
+ $pkgbase-BSD-2-Clause.txt::https://raw.githubusercontent.com/Cyan4973/xxHash/f035303b8a86c1db9be70cbb638678ef6ef4cb2d/LICENSE
+ pam-{login,common,remote,runuser,su}
'util-linux.sysusers'
- '60-rfkill.rules')
-sha256sums=('d9de3edd287366cd908e77677514b9387b22bc7b88f45b83e1922c3597f1d7f9'
- 'SKIP'
- '993a3096c2b113e6800f2abbd5d4233ebf1a97eef423990d3187d665d3490b92'
- 'fc6807842f92e9d3f792d6b64a0d5aad87995a279153ab228b1b2a64d9f32f20'
- '95b7cdc4cba17494d7b87f37f8d0937ec54c55de0e3ce9d9ab05ad5cc76bf935'
- '51eac9c2a2f51ad3982bba35de9aac5510f1eeff432d2d63c6362e45d620afc0'
+ '60-rfkill.rules'
+ 'rfkill-unblock_.service'
+ 'rfkill-block_.service')
+source=( ${source[*]/rfkill-unblock_.service/} ) # DIFF: non-systemd
+source=( ${source[*]/rfkill-block_.service/} ) # DIFF: non-systemd
+# source+=('0001-uuid-tmpfiles.patch' ) # DIFF: non-systemd
+sha256sums=('SKIP'
+ '6ffedbc0f7878612d2b23589f1ff2ab15633e1df7963a5d9fc750ec5500c7e7a'
+ 'ee917d55042f78b8bb03f5467e5233e3e2ddc2fe01e302bc53b218003fe22275'
+ '57e057758944f4557762c6def939410c04ca5803cbdd2bfa2153ce47ffe7a4af'
+ '8bfbee453618ba44d60ba7fb00eced6c62edebfc592f2e75dede08e769ed8931'
+ '48d6fba767631e3dd3620cf02a71a74c5d65a525d4c4ce4b5a0b7d9f41ebfea1'
+ 'b28f31fcafa401b0eb26bc0c710002acc4f7718f97af45b0d444e4af6dfb15a8'
'10b0505351263a099163c0d928132706e501dd0a008dac2835b052167b14abe3'
- '7423aaaa09fee7f47baa83df9ea6fef525ff9aec395c8cbd9fe848ceb2643f37')
+ '7423aaaa09fee7f47baa83df9ea6fef525ff9aec395c8cbd9fe848ceb2643f37'
+ # DIFF: non-systemd
+ # DIFF: non-systemd
+)
+# sha256sums+=('7fccfdbc22c215104aa0b79afa7491c100623ecbc581ff12b7a44b7ca870096f')
+_backports=(
+ # current stable/v2.40
+ "v${_tag}..175af5cb8e0434bbc6660f7ccbea3a188d8f2d72"
+)
+
+_reverts=(
+)
+
+prepare() {
+ cd "${pkgbase}"
+
+ local _c _l
+ for _c in "${_backports[@]}"; do
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git cherry-pick --mainline 1 --no-commit "${_c}"
+ done
+ for _c in "${_reverts[@]}"; do
+ if [[ "${_c}" == *..* ]]; then _l='--reverse'; else _l='--max-count=1'; fi
+ git log --oneline "${_l}" "${_c}"
+ git revert --mainline 1 --no-commit "${_c}"
+ done
+
+ # fast-forward to current master
+ #git merge master
+
+# patch -Np 1 -i ../0001-uuid-tmpfiles.patch
+ # do not mark dirty
+ sed -i '/dirty=/c dirty=' tools/git-version-gen
+}
build() {
- cd "$pkgbase-$pkgver"
-
- # We ship Debian's hardlink in package 'hardlink', Fedora's hardlink was
- # merged in util-linux. For now we disable the latter, but let's dicuss
- # the details:
- # https://bugs.archlinux.org/task/62896
- # https://github.com/karelzak/util-linux/issues/808
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --localstatedir=/var \
- --enable-usrdir-path \
- --enable-fs-paths-default=/usr/bin:/usr/local/bin \
- --enable-raw \
- --enable-vipw \
- --enable-newgrp \
- --enable-chfn-chsh \
- --enable-write \
- --enable-mesg \
- --disable-hardlink \
- --with-python=3 \
- --with-systemd=no \
- --with-systemdsystemunitdir=no
-
- make
+ local _meson_options=(
+ -Dfs-search-path=/usr/bin:/usr/local/bin
+
+ -Dlibuser=disabled
+ -Dncurses=disabled
+ -Dncursesw=enabled
+ -Deconf=disabled
+
+ -Dbuild-chfn-chsh=enabled
+ -Dbuild-line=disabled
+ -Dbuild-mesg=enabled
+ -Dbuild-newgrp=enabled
+ -Dbuild-vipw=enabled
+ -Dbuild-write=enabled
+ )
+ _meson_options+=( -Dsystemd=disabled ) # DIFF: non-systemd
+
+ arch-meson "${pkgbase}" build "${_meson_options[@]}"
+
+ meson compile -C build
}
package_util-linux() {
- conflicts=('rfkill')
- provides=('rfkill')
- replaces=('rfkill')
- depends=('pam' 'shadow' 'coreutils' 'libudev' 'libcap-ng' 'libutil-linux')
- optdepends=('python: python bindings to libmount'
- 'words: default dictionary for look')
+ conflicts=('rfkill' 'hardlink')
+ provides=('rfkill' 'hardlink')
+ replaces=('rfkill' 'hardlink')
+ depends=('coreutils'
+ 'file' 'libmagic.so'
+ 'glibc'
+ 'libcap-ng'
+ 'libutempter'
+ 'libxcrypt' 'libcrypt.so'
+ 'ncurses' 'libncursesw.so'
+ 'pam'
+ 'readline'
+ 'shadow'
+ 'systemd-libs' 'libsystemd.so' 'libudev.so'
+ 'util-linux-libs'
+ 'zlib')
+ depends=( ${depends[*]/systemd-libs/libudev} ) # DIFF: non-systemd
+ depends=( ${depends[*]/libsystemd.so/} ) # DIFF: non-systemd
+ optdepends=('words: default dictionary for look')
backup=(etc/pam.d/chfn
etc/pam.d/chsh
etc/pam.d/login
+ etc/pam.d/remote
etc/pam.d/runuser
etc/pam.d/runuser-l
etc/pam.d/su
etc/pam.d/su-l)
- cd "$pkgbase-$pkgver"
+ _python_stdlib="$(python -c 'import sysconfig; print(sysconfig.get_paths()["stdlib"])')"
+
+ DESTDIR="${pkgdir}" meson install -C build
- make DESTDIR="$pkgdir" install
+ # remove static libraries
+ rm "${pkgdir}"/usr/lib/lib*.a*
# setuid chfn and chsh
- chmod 4755 "$pkgdir"/usr/bin/{newgrp,ch{sh,fn}}
+ chmod 4755 "${pkgdir}"/usr/bin/{newgrp,ch{sh,fn}}
# install PAM files for login-utils
- install -Dm644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chfn"
- install -m644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chsh"
- install -m644 "$srcdir/pam-login" "$pkgdir/etc/pam.d/login"
- install -m644 "$srcdir/pam-runuser" "$pkgdir/etc/pam.d/runuser"
- install -m644 "$srcdir/pam-runuser" "$pkgdir/etc/pam.d/runuser-l"
- install -m644 "$srcdir/pam-su" "$pkgdir/etc/pam.d/su"
- install -m644 "$srcdir/pam-su" "$pkgdir/etc/pam.d/su-l"
-
- # adjust for usrmove
- # TODO(dreisner): fix configure.ac upstream so that this isn't needed
- cd "$pkgdir"
- mv usr/sbin/* usr/bin
- rmdir usr/sbin
-
- ### runtime libs are shipped as part of libutil-linux
- rm "$pkgdir"/usr/lib/lib*.{a,so}*
-
- ### install opensysusers
- install -Dm644 "$srcdir/util-linux.sysusers" \
- "$pkgdir/usr/lib/sysusers.d/util-linux.conf"
-
- install -Dm644 "$srcdir/60-rfkill.rules" \
- "$pkgdir/usr/lib/udev/rules.d/60-rfkill.rules"
+ install -Dm0644 pam-common "${pkgdir}/etc/pam.d/chfn"
+ install -m0644 pam-common "${pkgdir}/etc/pam.d/chsh"
+ install -m0644 pam-login "${pkgdir}/etc/pam.d/login"
+ install -m0644 pam-remote "${pkgdir}/etc/pam.d/remote"
+ install -m0644 pam-runuser "${pkgdir}/etc/pam.d/runuser"
+ install -m0644 pam-runuser "${pkgdir}/etc/pam.d/runuser-l"
+ install -m0644 pam-su "${pkgdir}/etc/pam.d/su"
+ install -m0644 pam-su "${pkgdir}/etc/pam.d/su-l"
+
+ # TODO(dreisner): offer this upstream?
+ #sed -i '/ListenStream/ aRuntimeDirectory=uuidd' "${pkgdir}/usr/lib/systemd/system/uuidd.socket"
+
+ # runtime libs are shipped as part of util-linux-libs
+ install -d -m0755 util-linux-libs/lib/
+ mv "$pkgdir"/usr/lib/lib*.so* util-linux-libs/lib/
+ mv "$pkgdir"/usr/lib/pkgconfig util-linux-libs/lib/pkgconfig
+ mv "$pkgdir"/usr/include util-linux-libs/include
+ mv "$pkgdir"/"${_python_stdlib}"/site-packages util-linux-libs/site-packages
+ rmdir "$pkgdir"/"${_python_stdlib}"
+ mv "$pkgdir"/usr/share/man/man3 util-linux-libs/man3
+
+ ### install sysusers
+ install -Dm0644 util-linux.sysusers \
+ "${pkgdir}/usr/lib/sysusers.d/util-linux.conf"
+
+ install -Dm0644 60-rfkill.rules \
+ "${pkgdir}/usr/lib/udev/rules.d/60-rfkill.rules"
+
+ # DIFF: system only
+
+ install -vDm 644 $pkgbase/Documentation/licenses/COPYING.{BSD*,ISC} -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -vDm 644 $pkgbase-BSD-2-Clause.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-package_libutil-linux() {
- pkgdesc="util-linux runtime libraries"
- provides=('libblkid.so' 'libfdisk.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so')
-
- make -C "$pkgbase-$pkgver" DESTDIR="$pkgdir" install-usrlib_execLTLIBRARIES
+package_util-linux-libs() {
+ pkgdesc='util-linux runtime libraries'
+ depends=('glibc'
+ 'sqlite')
+ provides=('libutil-linux' 'libblkid.so' 'libfdisk.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so')
+ conflicts=('libutil-linux')
+ conflicts=('glib2>=2.81.0' 'at-spi2-core>=2.53.0') # the sodep 'libmount.so' is too stable - many GUI things break without this (eg: LXDE)
+ replaces=('libutil-linux')
+ optdepends=('python: python bindings to libmount')
+
+ install -d -m0755 "$pkgdir"/{"${_python_stdlib}",usr/share/man/}
+ mv util-linux-libs/lib/* "$pkgdir"/usr/lib/
+ mv util-linux-libs/include "$pkgdir"/usr/include
+ mv util-linux-libs/site-packages "$pkgdir"/"${_python_stdlib}"/site-packages
+ mv util-linux-libs/man3 "$pkgdir"/usr/share/man/man3
+
+ install -vDm 644 $pkgbase/Documentation/licenses/COPYING.{BSD*,ISC} -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -vDm 644 $pkgbase-BSD-2-Clause.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
}