summaryrefslogtreecommitdiff
path: root/nonsystemd/util-linux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/util-linux/PKGBUILD')
-rw-r--r--nonsystemd/util-linux/PKGBUILD69
1 files changed, 33 insertions, 36 deletions
diff --git a/nonsystemd/util-linux/PKGBUILD b/nonsystemd/util-linux/PKGBUILD
index e6e2d1bd1..7cc5344ec 100644
--- a/nonsystemd/util-linux/PKGBUILD
+++ b/nonsystemd/util-linux/PKGBUILD
@@ -1,72 +1,71 @@
-# $Id$
+# Maintainer: David P. <megver83@parabola.nu>
# Maintainer (Arch): Tom Gundersen <teg@jklm.no>
# Maintainer (Arch): Dave Reisner <dreisner@archlinux.org>
# Contributor (Arch): judd <jvinet@zeroflux.org>
-# Maintainer: David P. <megver83@parabola.nu>
pkgbase=util-linux
pkgname=(util-linux libutil-linux)
-_pkgmajor=2.32
+_pkgmajor=2.33
pkgver=${_pkgmajor}
-pkgrel=3
+pkgrel=2
pkgrel+=.nonsystemd1
pkgdesc="Miscellaneous system utilities for Linux"
url="https://www.kernel.org/pub/linux/utils/util-linux/"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('x86_64' 'i686' 'armv7h')
makedepends=('eudev' 'python' 'libcap-ng')
license=('GPL2')
options=('strip' 'debug')
validpgpkeys=('B0C64D14301CC6EFAEDF60E4E4B71D5EEC39C284') # Karel Zak
source=("https://www.kernel.org/pub/linux/utils/util-linux/v$_pkgmajor/$pkgbase-$pkgver.tar."{xz,sign}
- '0001-fstrim-cleanup-uncludes.patch'
- '0002-libmount_include_sys_mount_h_only_if_necessary.patch'
+ '0001-agetty-fix-output-of-escaped-characters.patch'
pam-{login,common,su}
'util-linux.sysusers'
'60-rfkill.rules')
-sha256sums=('6c7397abc764e32e8159c2e96042874a190303e77adceb4ac5bd502a272a4734'
+sha256sums=('f261b9d73c35bfeeea04d26941ac47ee1df937bd3b0583e748217c1ea423658a'
'SKIP'
- 'b1c0db069f60c086351f7a6fb7ff1add1c41e9ed7c1b65bd67e6604943fc4c75'
- 'c65d8354fc2773035be8ac071541f4709763366d22a8a8f1bc2cb3401dcfdf69'
+ 'a20ab3b78eed0e143300476d059e55ab87720bc9fc66a4dcbbd5ae8c48f39bf4'
'993a3096c2b113e6800f2abbd5d4233ebf1a97eef423990d3187d665d3490b92'
'fc6807842f92e9d3f792d6b64a0d5aad87995a279153ab228b1b2a64d9f32f20'
'51eac9c2a2f51ad3982bba35de9aac5510f1eeff432d2d63c6362e45d620afc0'
- 'a3980e33ef3a8d356379b4964c9730fd525d46e5b28cded5d0b50d6dc8a5563c'
+ '10b0505351263a099163c0d928132706e501dd0a008dac2835b052167b14abe3'
'7423aaaa09fee7f47baa83df9ea6fef525ff9aec395c8cbd9fe848ceb2643f37')
prepare() {
cd "$pkgbase-$pkgver"
- patch -Np1 -i ../0001-fstrim-cleanup-uncludes.patch
- patch -Np1 -i ../0002-libmount_include_sys_mount_h_only_if_necessary.patch
+ # agetty: fix output of escaped characters
+ patch -Np1 < ../0001-agetty-fix-output-of-escaped-characters.patch
}
build() {
cd "$pkgbase-$pkgver"
- ./configure --prefix=/usr \
- --libdir=/usr/lib \
- --bindir=/usr/bin \
- --localstatedir=/run \
- --enable-fs-paths-extra=/usr/bin \
- --enable-raw \
- --enable-vipw \
- --enable-newgrp \
- --enable-chfn-chsh \
- --enable-write \
- --enable-mesg \
- --with-python=3 \
- --with-systemd=no \
- --with-systemdsystemunitdir=no \
- --with-python=3
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --localstatedir=/var \
+ --enable-fs-paths-extra=/usr/bin \
+ --enable-raw \
+ --enable-vipw \
+ --enable-newgrp \
+ --enable-chfn-chsh \
+ --enable-write \
+ --enable-mesg \
+ --with-python=3 \
+ --with-systemd=no \
+ --with-systemdsystemunitdir=no
+
make
}
package_util-linux() {
- conflicts=('util-linux-nosystemd' 'eject' 'zramctl' 'rfkill')
- provides=("util-linux-nosystemd=$pkgver" 'eject' 'zramctl' 'rfkill')
- replaces=('util-linux-nosystemd' 'zramctl' 'rfkill')
+ conflicts=('eject' 'zramctl' 'rfkill')
+ provides=('eject' 'zramctl' 'rfkill')
+ replaces=('zramctl' 'rfkill')
depends=('pam' 'shadow' 'coreutils' 'libeudev' 'libcap-ng' 'libutil-linux')
- optdepends=('python: python bindings to libmount')
+ optdepends=('python: python bindings to libmount'
+ 'words: default dictionary for look')
groups=('base' 'base-devel')
backup=(etc/pam.d/chfn
etc/pam.d/chsh
@@ -97,7 +96,7 @@ package_util-linux() {
### runtime libs are shipped as part of libutil-linux
rm "$pkgdir"/usr/lib/lib*.{a,so}*
- ### install sysusers
+ ### install opensysusers
install -Dm644 "$srcdir/util-linux.sysusers" \
"$pkgdir/usr/lib/sysusers.d/util-linux.conf"
@@ -107,9 +106,7 @@ package_util-linux() {
package_libutil-linux() {
pkgdesc="util-linux runtime libraries"
- provides=("libutil-linux-nosystemd=$pkgver" 'libblkid.so' 'libfdisk.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so')
- replaces=('libutil-linux-nosystemd')
- conflicts=('libutil-linux-nosystemd')
+ provides=('libblkid.so' 'libfdisk.so' 'libmount.so' 'libsmartcols.so' 'libuuid.so')
make -C "$pkgbase-$pkgver" DESTDIR="$pkgdir" install-usrlib_execLTLIBRARIES
}