summaryrefslogtreecommitdiff
path: root/nonsystemd/your-initfreedom/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/your-initfreedom/PKGBUILD')
-rw-r--r--nonsystemd/your-initfreedom/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/nonsystemd/your-initfreedom/PKGBUILD b/nonsystemd/your-initfreedom/PKGBUILD
new file mode 100644
index 000000000..94545fe80
--- /dev/null
+++ b/nonsystemd/your-initfreedom/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Parabola Project <dev@lists.parabola.nu>
+
+pkgname=your-initfreedom
+pkgdesc="This package will remove systemd and support for it."
+license=('GPL3')
+url="https://git.parabola.nu/blacklist.git"
+pkgver=20180509
+_gitver=ce104115ea671c4dd4bf7dc0b70ba9cf40948ee3
+pkgrel=1
+
+arch=('any')
+groups=('base-openrc')
+install=${pkgname}.install
+
+makedepends=(librelib)
+# source=(blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
+source=(${pkgname}-blacklist.txt)
+sha512sums=('fba5eaef2137d090a4f6d8692930ba5bfba3300a0176741cba67112698b00480700c5724e4869fcc6bd19925d38972cc019653200f2acf084eb0bec739bb0c1b')
+
+pkgver() {
+ date +%Y%m%d
+}
+
+package() {
+ cd "$srcdir"
+
+ conflicts=($(
+ < ${pkgname}-blacklist.txt \
+ libreblacklist normalize |
+ cut -d: -f1,2 |
+ sed -n 's/:$//p' |
+ sort -u
+ ))
+
+# install -Dm644 blacklist-${_gitver}.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
+ install -Dm644 ${pkgname}-blacklist.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
+}