summaryrefslogtreecommitdiff
path: root/pcr-testing/python-flufl-i18n/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr-testing/python-flufl-i18n/PKGBUILD')
-rw-r--r--pcr-testing/python-flufl-i18n/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr-testing/python-flufl-i18n/PKGBUILD b/pcr-testing/python-flufl-i18n/PKGBUILD
new file mode 100644
index 000000000..932c13cd6
--- /dev/null
+++ b/pcr-testing/python-flufl-i18n/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+
+pkgname=('python-flufl-i18n' 'python2-flufl-i18n')
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="A high level API for Python internationalization"
+arch=(any)
+url=https://launchpad.net/flufl.i18n
+license=('LGPL')
+options=(!emptydirs)
+
+makedepends=('python-setuptools' 'python2-setuptools')
+
+_upstream_name='flufl.i18n'
+_release=${_upstream_name}-${pkgver}
+source=(https://pypi.python.org/packages/source/${_upstream_name:0:1}/${_upstream_name}/${_release}.tar.gz)
+sha256sums=('bb743c1101936138edf6f6b0dd9f77f157ca6b5f38c608f440fd16b59c4c5130')
+
+
+package_python-flufl-i18n()
+{
+ depends=('python2')
+
+ cd "${srcdir}/${_release}"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-flufl-i18n()
+{
+ depends=('python2')
+
+ cd "${srcdir}/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}