summaryrefslogtreecommitdiff
path: root/pcr-testing/python2-django-mailman3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr-testing/python2-django-mailman3/PKGBUILD')
-rw-r--r--pcr-testing/python2-django-mailman3/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/pcr-testing/python2-django-mailman3/PKGBUILD b/pcr-testing/python2-django-mailman3/PKGBUILD
new file mode 100644
index 000000000..e4a6896b8
--- /dev/null
+++ b/pcr-testing/python2-django-mailman3/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python2-django-mailman3')
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Django library to help interaction with Mailman"
+arch=(any)
+url=https://gitlab.com/mailman/django-mailman3
+license=('GPL3')
+options=(!emptydirs)
+
+depends=('python2' 'python2-django' 'python2-django-allauth' 'python2-future'
+ 'python2-mailmanclient' 'python2-pytz' 'python2-django-gravatar')
+
+_upstream_name='django-mailman3'
+_release="${_upstream_name}-${pkgver}"
+source=(https://gitlab.com/mailman/${_upstream_name}/-/archive/${pkgver}/${_release}.tar.gz)
+sha256sums=('fee336f22cef644cb9e1d9d1081ca58f96f6c9334d33df9b4df7e68d04754536')
+
+
+package()
+{
+ cd "$srcdir/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}