summaryrefslogtreecommitdiff
path: root/pcr/antimicro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/antimicro/PKGBUILD')
-rw-r--r--pcr/antimicro/PKGBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/pcr/antimicro/PKGBUILD b/pcr/antimicro/PKGBUILD
deleted file mode 100644
index 5a63c555c..000000000
--- a/pcr/antimicro/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer (Arch): grimi <grimi at poczta dot fm>
-# Maintainer (Arch): Thomas Nordenmark <t.nordenmark@gmail.com>
-# Developer (Arch): Travis Nickles <nickles.travis@gmail.com>
-
-pkgname=antimicro
-pkgver=2.23
-pkgrel=1
-pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
-arch=('i686' 'x86_64')
-url="https://github.com/AntiMicro/antimicro"
-license=('GPL3')
-depends=('libxkbcommon-x11' 'libxtst' 'qt5-base' 'sdl2' 'shared-mime-info' 'desktop-file-utils')
-makedepends=('cmake' 'gettext' 'itstool' 'qt5-tools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AntiMicro/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('cd58b5a9771d35fc937306a3452e8776ef754bb5a4fa44aeedb735d8366a38b318c1bf14f105bf8003e4264c35f129224becdade32d2a7b61067ec5a705a1e7e')
-
-
-
-build() {
- cd ${pkgname}-${pkgver}
-
- mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SDL_2=ON -DWITH_XTEST=ON \
- -DWITH_UINPUT=ON -DAPPDATA=ON ..
- make
-}
-
-package() {
- cd ${pkgname}-${pkgver}/build
-
- make DESTDIR="${pkgdir}" install
-}
-