summaryrefslogtreecommitdiff
path: root/pcr/antimicro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/antimicro/PKGBUILD')
-rw-r--r--pcr/antimicro/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/pcr/antimicro/PKGBUILD b/pcr/antimicro/PKGBUILD
new file mode 100644
index 000000000..8380aace1
--- /dev/null
+++ b/pcr/antimicro/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer (Arch): Travis Nickles <nickles.travis@gmail.com>
+
+pkgname=antimicro
+pkgver=2.14
+pkgrel=1
+pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
+arch=('i686' 'x86_64')
+url="https://github.com/Ryochan7/antimicro"
+license=('GPL3')
+depends=('libxkbcommon-x11' 'libxtst' 'qt5-base' 'sdl2')
+makedepends=('cmake' 'gettext' 'itstool' 'qt5-tools')
+install="${pkgname}.install"
+source=("https://github.com/Ryochan7/antimicro/archive/${pkgver}.tar.gz")
+md5sums=("66aecb2cb11070fb53e23d50196b7e97")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SDL_2=ON -DWITH_XTEST=ON \
+ -DWITH_UINPUT=ON -DAPPDATA=ON ..
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
+ make DESTDIR="${pkgdir}" install
+}