summaryrefslogtreecommitdiff
path: root/pcr/cluster-glue/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/cluster-glue/PKGBUILD')
-rw-r--r--pcr/cluster-glue/PKGBUILD191
1 files changed, 59 insertions, 132 deletions
diff --git a/pcr/cluster-glue/PKGBUILD b/pcr/cluster-glue/PKGBUILD
index 1a81e15d4..2c45a3b0c 100644
--- a/pcr/cluster-glue/PKGBUILD
+++ b/pcr/cluster-glue/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname1=${pkgname::7}
_pkgname2=${pkgname:8}
_pkgname=${_pkgname1^}_${_pkgname2^}
pkgver=1.0.11
-pkgrel=12
+pkgrel=14
pkgdesc='Set of libraries, tools and utilities suitable for the Heartbeat/Pacemaker cluster stack (Linux-HA)'
arch=(
i686
@@ -31,14 +31,13 @@ depends=(
openhpi
openipmi
openssh
- python
+ python2
util-linux
- #vacm !!Is VA-Cluster Manager abandonware? - http://vacm.sourceforge.net/ - ver 2.0.5a - 2001/10/03!!
)
optdepends=net-tools
makedepends=(
help2man
- #libxslt
+ libxslt
lynx
net-tools
openssh
@@ -50,8 +49,20 @@ provides=(ha-$_pkgname2)
conflicts=ha-$_pkgname2
replaces=ha-$_pkgname2
install=$pkgname.install
-source=http://hg.$group.org/$_pkgname2/archive/$_pkgname2-$pkgver.tar.bz2
-sha512sums=35ac8ac555c39f24c11e3a768cc50eba051fe617edf4cdc0429dac73f45a472f144cfe6ec5faff575606f2b04ff76a2f732556d848b61410c2683d93ba928413
+source=(
+ http://hg.$group.org/$_pkgname2/archive/$_pkgname2-$pkgver.tar.bz2
+ ha-log.service
+ fixing-path.sed
+ replace-linux_os-to-gnulinux_os-term.sed
+ replace-opensource-to-free-term.sed
+)
+sha512sums=(
+ 35ac8ac555c39f24c11e3a768cc50eba051fe617edf4cdc0429dac73f45a472f144cfe6ec5faff575606f2b04ff76a2f732556d848b61410c2683d93ba928413
+ bb5bc5c5a9347302be583c43b100c0c3760ec4dcc3348a9f9708d5b2c58ec02dd5782c5ac9dcb86223258493ad3fba8ddd8dc5670390f0f602c34869b26bee6d
+ ce58a2af9f32265f12cc4984e9ae7f285fdb7737813ecccc0780015d048938d9dd79278635eb1cc6833f12f37a8c43211fec17411780220cf38fc44b91ecc076
+ e59386aee4db5857fa131798327aa449a5efcd7d50c3ab45dadfa0becc31698a62367ce83b85ca739bdebaad4a9daf96d02c42673a4e26294ec0fa67323fdb5b
+ c82bd919d1cd02afccd10aea3e015f289ac97e387a1485097d681f9161a00c64859a5dce0ed36b98ad6a340264c2d854dcc83e3248e12828795b73c6ff67ef5b
+)
prepare() {
export _CLUSTER_USER=hacluster
@@ -85,131 +96,58 @@ prepare() {
' $(grep -rlI INCLUDES | grep Makefile.am)
# fixing path
- sed -i 's|bin/sh|usr/bin/bash|;
- ' $(grep -rlI bin/sh)
- sed -i 's| /bin| /usr/bin|;
- ' $(grep -rlI ' /bin')
- sed -i 's| /sbin| /usr/bin|;
- ' $(grep -rlI ' /sbin')
- sed -i 's|usr/sbin|usr/bin|;
- ' $(grep -rlI usr/sbin)
- #sed -i 's|/lib64|/lib|;
- # ' $(grep -rlI /lib64)
- #sed -i 's|usr/libexec|usr/lib|;
- # ' $(grep -rlI usr/libexec)
- sed -i 's|var/lock|run/lock|;
- ' $(grep -rlI var/lock)
- sed -i 's|var/run|run|;
- ' $(grep -rlI var/run)
+ sed -i -f $srcdir/fixing-path.sed\
+ $(grep -rlI /bin)\
+ $(grep -rlI /sbin)\
+ $(grep -rlI /lib)\
+ $(grep -rlI /var)
- # remove Open Source term
- sed -i 's|Open Source / ||;
- s|open source / ||;
- s|Open Source|Free|;
- s|open source|free|;
- s|Free Software Development Lab|Open Source Development Lab|;
- ' $(grep -rilI 'open source')
- sed -i 's|OpenSource / ||;
- s|opensource / ||;
- s|OpenSource|Free|;
- s|opensource|free|;
- s|freesoftware.org|opensource.org|;
- s|http://www.opensource.org/|http://www.gnu.org/philosophy/free-sw.html|;
- s|http://www.gnu.org/philosophy/free-sw.htmllicenses/osl-|http://opensource.org/licenses/osl-|;
- s|http://www.gnu.org/philosophy/free-sw.htmlosd|http://opensource.org/osd|;
- ' $(grep -rilI opensource)
+ # fixing python2 path
+ sed -i 's|bin/env python|bin/env python2|g;
+ s|bin/python|bin/python2|g;
+ ' $(grep -rlI 'bin/env python')\
+ $(grep -rlI bin/python)
- # remove Linux term
- sed -i 's|Linux,|GNU/Linux,|;
- s|Linux and|GNU/Linux and|;
- s|Linux distro|GNU/Linux distro|;
- s|Linux distribution|GNU/Linux distribution|;
- s|Linux machine|GNU/Linux machine|;
- s|Linux Only|GNU/Linux Only|;
- s|Linux only|GNU/Linux only|;
- s|Linux operating|GNU/Linux operating|;
- s|Linux OS|GNU/Linux OS|;
- s|Linux platform|GNU/Linux platform|;
- s|Linux software|GNU/Linux software|;
- s|Linux specific|GNU/Linux specific|;
- s|Linux system|GNU/Linux system|;
- s|Linux will|GNU/Linux will|;
- s|# Linux$|# GNU/Linux|;
- s|# Linux.$|# GNU/Linux.|;
- s|* Linux$|* GNU/Linux|;
- s|* Linux.$|* GNU/Linux.|;
- s|// Linux$|// GNU/Linux|;
- s|// Linux.$|// GNU/Linux.|;
- s|, Linux|, GNU/Linux|;
- s|As Linux|As GNU/Linux|;
- s|as Linux|as GNU/Linux|;
- s|And Linux|And GNU/Linux|;
- s|and Linux|and GNU/Linux|;
- s|Be Linux|Be GNU/Linux|;
- s|be Linux|be GNU/Linux|;
- s|Because Linux|Because GNU/Linux|;
- s|because Linux|because GNU/Linux|;
- s|e.g. Linux|e.g. GNU/Linux|;
- s|For Linux|For GNU/Linux|;
- s|for Linux|for GNU/Linux|;
- s|In Linux|In GNU/Linux|;
- s|in Linux|in GNU/Linux|;
- s|Like Linux|Like GNU/Linux|;
- s|like Linux|like GNU/Linux|;
- s|non-Linux|non GNU/Linux|;
- s|Of Linux|Of GNU/Linux|;
- s|of Linux|of GNU/Linux|;
- s|On Linux|On GNU/Linux|;
- s|on Linux|on GNU/Linux|;
- s|OS type: Linux|OS type: GNU/Linux|;
- s|Other Linux|Other GNU/Linux|;
- s|other Linux|other GNU/Linux|;
- s|The Linux|The GNU/Linux|;
- s|the Linux|the GNU/Linux|;
- s|Typically Linux|Typically GNU/Linux|;
- s|typically Linux|typically GNU/Linux|;
- s|To Linux|To GNU/Linux|;
- s|to Linux|to GNU/Linux|;
- s|Under Linux|Under GNU/Linux|;
- s|under Linux|under GNU/Linux|;
- s|ArchGNU/Linux|ArchLinux|;
- s|e2fsprogs, typically GNU/Linux|e2fsprogs, typically Linux|;
- s|GNU/GNU|GNU|;
- s|GNU/Linux device|Linux device|;
- s|GNU/Linux Director Daemon|Linux Director Daemon|;
- s|GNU/Linux is a registered trademark of Linus Torvalds|Linux is a registered trademark of Linus Torvalds|;
- s|GNU/Linux kernel|Linux kernel|;
- s|GNU/Linux specific kernel|Linux specific kernel|;
- s|GNU/Linux Standard Base|Linux Standard Base|;
- s|GNU/Linux sysfs|Linux sysfs|;
- s|GNU/Linux Virtual Server|Linux Virtual Server|;
- s|GNU/Linux Watchdog|Linux Watchdog|;
- s|GNU/Linux watchdog|Linux watchdog|;
- s|GNU/LinuxHA|LinuxHA|;
- s|GNU/Linux-HA|Linux-HA|;
- s|GNU/LinuxSCSI|LinuxSCSI|;
- s|HA GNU/Linux|HA Linux|;
- s|High-Availability GNU/Linux|High-Availability Linux|;
- s|MkGNU/Linux|MkLinux|;
- s|SEGNU/Linux|SELinux|;
- s|VA GNU/Linux Cluster|VA Linux Cluster|;
- ' $(grep -rlI Linux)
-}
+ # remove Linux (OS) term to GNU/Linux (OS) term
+ sed -i -f $srcdir/replace-linux_os-to-gnulinux_os-term.sed\
+ $(grep -rlI Linux)
+
+ # replace Open Source term to Free term
+ sed -i -f $srcdir/replace-opensource-to-free-term.sed\
+ $(grep -rilI 'open.\{0,1\}source')
+#}
-build() {
+#build() { # disabled, due that is needed internet for generating man pages with libxslt.
cd $srcdir/Reusable-${_pkgname1^}-Components-$_pkgname2--$_pkgname2-$pkgver
setarch $CARCH ./autogen.sh
- setarch $CARCH ./configure --prefix=/usr\
+ setarch $CARCH ./configure\
+ --sysconfdir=/etc\
+ --prefix=/usr\
+ --exec-prefix=/usr\
+ --bindir=/usr/bin\
+ --sbindir=/usr/bin\
+ --includedir=/usr/include\
+ --oldincludedir=/usr/include\
+ --libdir=/usr/lib\
+ --libexecdir=/usr/lib\
+ --datarootdir=/usr/share\
+ --datadir=/usr/share\
+ --docdir=/usr/share/doc/$pkgname\
+ --dvidir=/usr/share/doc/$pkgname\
+ --htmldir=/usr/share/doc/$pkgname\
+ --pdfdir=/usr/share/doc/$pkgname\
+ --psdir=/usr/share/doc/$pkgname\
+ --infodir=/usr/share/info\
+ --localedir=/usr/share/locale\
+ --mandir=/usr/share/man\
+ --localstatedir=/var\
--disable-ansi\
--disable-fatal-warnings\
--disable-static\
--enable-doc\
--enable-libnet\
+ --enable-shared\
--enable-upstart\
- --libdir=/usr/lib\
- --localstatedir=/var\
- --sbindir=/usr/bin\
- --sysconfdir=/etc\
--with-daemon-group=haclient\
--with-daemon-user=hacluster\
--with-ocf-root=/usr/lib/ocf
@@ -220,19 +158,8 @@ package() {
cd $srcdir/Reusable-${_pkgname1^}-Components-$_pkgname2--$_pkgname2-$pkgver
setarch $CARCH make DESTDIR=$pkgdir install
- rm $pkgdir/etc/rc.d/logd && rmdir $pkgdir/etc{/rc.d,}
-
install -d $pkgdir/usr/lib/systemd/system
- echo '[Unit]' > $pkgdir/usr/lib/systemd/system/ha_log.service
- echo 'Description=Startup script logd service' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo 'Requires=network.target remote-fs.target' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo '' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo '[Service]' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo 'Type=forking' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo 'ExecStart=/usr/lib/heartbeat/ha_logd' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo '' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo '[Install]' >> $pkgdir/usr/lib/systemd/system/ha_log.service
- echo 'WantedBy=multi-user.target' >> $pkgdir/usr/lib/systemd/system/ha_log.service
+ install -m644 $srcdir/ha-log.service $pkgdir/usr/lib/systemd/system
msg 'AFTER COMPILE THIS SOFTWARE YOU MUST DELETE A CLUSTER USER AND A CLUSTER GROUP, EXECUTE AS ROOT:'
echo -e "# userdel $_CLUSTER_USER"