summaryrefslogtreecommitdiff
path: root/pcr/compiz/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/compiz/PKGBUILD')
-rw-r--r--pcr/compiz/PKGBUILD63
1 files changed, 36 insertions, 27 deletions
diff --git a/pcr/compiz/PKGBUILD b/pcr/compiz/PKGBUILD
index 57ef590d9..c2255ac54 100644
--- a/pcr/compiz/PKGBUILD
+++ b/pcr/compiz/PKGBUILD
@@ -1,56 +1,61 @@
-# Maintainer (Arch): Charles Bos <charlesbos1 AT gmail>
-# Contributor (Arch): Rob McCathie <archaur at rmcc dot com dot au
-# Contributor (Arch): /dev/rs0 <rs0@secretco.de.com>
-# Contributor (Arch): Iven Hsu <ivenvd AT gmail>
-# Contributor (Arch): Nathan Hulse <nat.hulse@gmail.com>
+# Maintainer (aur): Robert Brzozowski <robson75@linux.pl>
+# Maintainer (aur): Charles Bos <charlesbos1 AT gmail>
+# Contributor: Rob McCathie <archaur at rmcc dot com dot au
+# Contributor: /dev/rs0 <rs0@secretco.de.com>
+# Contributor: Iven Hsu <ivenvd AT gmail>
+# Contributor: Nathan Hulse <nat.hulse@gmail.com>
pkgname=compiz
-pkgver=0.9.13.0
-pkgrel=2
+pkgver=0.9.14.2
+pkgrel=1
pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
arch=('i686' 'x86_64')
+arch+=('armv7h')
url="https://launchpad.net/compiz"
license=('GPL' 'LGPL' 'MIT')
-depends=('boost' 'xorg-server' 'libxcomposite' 'startup-notification' 'librsvg' 'dbus' 'mesa' 'libxslt' 'fuse' 'glibmm' 'libxrender' 'libwnck3' 'pygtk' 'desktop-file-utils' 'pyrex' 'protobuf' 'metacity' 'glu' 'libsm' 'dconf')
-makedepends=('cmake' 'intltool')
+depends=('boost-libs' 'xorg-server' 'fuse2' 'glibmm' 'libwnck3' 'python-gobject' 'python-cairo' 'protobuf' 'metacity' 'glu')
+makedepends=('boost' 'cmake' 'intltool' 'cython')
optdepends=(
'xorg-xprop: grab various window properties for use in window matching rules'
)
-conflicts=('compiz-core')
-source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pkgname}-${pkgver}.tar.bz2"
+conflicts=('compiz-core' 'compiz-gtk' 'compiz-bcop' 'ccsm' 'compiz-fusion-plugins-main' 'compiz-fusion-plugins-extra' 'compiz-fusion-plugins-experimental' 'compizconfig-python' 'libcompizconfig' 'simple-ccsm')
+provides=("compiz-core=${pkgver}" "compiz-bcop=${pkgver}" "ccsm=${pkgver}" "compiz-plugins-main=${pkgver}" "compiz-plugins-extra=${pkgver}" "compizconfig-python=${pkgver}" "libcompizconfig=${pkgver}")
+source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pkgname}-${pkgver}.tar.xz"
"focus-prevention-disable.patch"
"gtk-extents.patch"
- "trailfocus-fix.patch")
-sha256sums=('f08eb54d578be559e3e723f3fe4291a56f5c96b2fdfb9c9e74ebb6596a1ca702'
+ "reverse-unity-config.patch"
+ "screenshot-launch-fix.patch"
+ "no-compile-gschemas.patch")
+sha256sums=('cfa061e93b032275ff9e7041f582a8f6d5ae271cf8a89e6bc74e3d3635999d3c'
'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
'16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
- '01e94ac52cd39eb5462a8505c7df61c7b14b05159de64f8700dfadb524bdb2ce')
+ '6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b'
+ '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
+ '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a')
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix decorator start command
- sed -i 's/exec \\"${COMPIZ_BIN_PATH}compiz-decorator\\"/exec \/usr\/bin\/compiz-decorator/g' plugins/decor/decor.xml.in
+ # Reverse Unity specific configuration patches
+ patch -p1 -i "${srcdir}/reverse-unity-config.patch"
# Set focus prevention level to off which means that new windows will always get focus
- patch -Np1 -i "${srcdir}/focus-prevention-disable.patch"
-
- # Use Python 2
- find -type f \( -name 'CMakeLists.txt' -or -name '*.cmake' \) -exec sed -e 's/COMMAND python/COMMAND python2/g' -i {} \;
- find compizconfig/ccsm -type f -exec sed -e 's|^#!.*python|#!/usr/bin/env python2|g' -i {} \;
+ patch -p1 -i "${srcdir}/focus-prevention-disable.patch"
# Fix incorrect extents for GTK+ tooltips, csd etc
- patch -Np1 -i "${srcdir}/gtk-extents.patch"
+ patch -p1 -i "${srcdir}/gtk-extents.patch"
+
+ # Fix application launching for the screenshot plugin
+ patch -p1 -i "${srcdir}/screenshot-launch-fix.patch"
+
+ # Don't try to compile gschemas during make install
+ patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
- # Fix ambiguous function call in trailfocus plugin
- patch -Np1 -i "${srcdir}/trailfocus-fix.patch"
}
build() {
cd "${pkgname}-${pkgver}"
- export PYTHON="/usr/bin/python2"
-
mkdir build; cd build
cmake .. \
@@ -65,7 +70,7 @@ build() {
-DBUILD_KDE4=Off \
-DCOMPIZ_BUILD_TESTING=Off \
-DCOMPIZ_WERROR=Off \
- -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp" \
+ -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp"
make
}
@@ -89,4 +94,8 @@ package() {
install -dm755 "${pkgdir}/usr/share/glib-2.0/schemas/"
install -m644 generated/glib-2.0/schemas/*.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/"
fi
+
+ # Install licenses
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}-${pkgver}"/{COPYING,COPYING.GPL,COPYING.LGPL,COPYING.MIT} "${pkgdir}/usr/share/licenses/${pkgname}"
}