summaryrefslogtreecommitdiff
path: root/pcr/cpptest/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/cpptest/PKGBUILD')
-rw-r--r--pcr/cpptest/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/pcr/cpptest/PKGBUILD b/pcr/cpptest/PKGBUILD
new file mode 100644
index 000000000..df08feb00
--- /dev/null
+++ b/pcr/cpptest/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jorge Araya Navarro <jorgean@lavabit.com>
+# Contributor (aur): Juan Pablo Gonzalez Tognarelli <lord_jotape@yahoo.com.ar>
+pkgname=cpptest
+pkgver=1.1.2
+pkgrel=2
+pkgdesc="CppTest is a portable and powerful unit testing framework for handling automated tests in C++. with focus on usability and extendability."
+url="http://cpptest.sourceforge.net/"
+depends=(gcc-libs)
+makedepends=(pkgconfig)
+source=(http://downloads.sourceforge.net/sourceforge/cpptest/$pkgname-$pkgver.tar.gz)
+md5sums=('79b9bff371d182f11a3235969f84ccb6')
+arch=('i686' 'x86_64')
+license="LGPL"
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+}