summaryrefslogtreecommitdiff
path: root/pcr/dbus-elogind/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/dbus-elogind/PKGBUILD')
-rw-r--r--pcr/dbus-elogind/PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/pcr/dbus-elogind/PKGBUILD b/pcr/dbus-elogind/PKGBUILD
index d6095e7b4..428324593 100644
--- a/pcr/dbus-elogind/PKGBUILD
+++ b/pcr/dbus-elogind/PKGBUILD
@@ -10,14 +10,14 @@ _commit=8b582cb10d7cf00af7a70496aec48af24edc542b # tags/dbus-1.10.16^0
pkgname=dbus-elogind
pkgver=1.10.16
-pkgrel=2
+pkgrel=3
pkgdesc="Freedesktop.org message bus system"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(i686 x86_64 armv7h)
license=(GPL custom)
-provides=('libdbus' "dbus=$pkgver")
+provides=('libdbus' "dbus=$pkgver" "dbus-x11=$pkgver")
conflicts=('libdbus' 'dbus' 'dbus-x11')
-depends=('expat' 'libx11' 'libelogind' 'libeudev')
+depends=('expat' 'libx11' 'libelogind')
makedepends=('xmlto' 'docbook-xsl' 'python' 'yelp-tools' 'doxygen' 'git')
optdepends=('dbus-openrc: dbus initscript')
source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit"
@@ -46,14 +46,15 @@ build() {
--with-system-socket=/run/dbus/system_bus_socket \
--with-console-auth-dir=/run/console/ \
--enable-inotify \
+ --enable-elogind \
--disable-static \
--disable-verbose-mode \
--disable-asserts \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --without-systemdsystemunitdir \
--disable-systemd \
--disable-user-session \
- --enable-x11-autolaunch \
- --enable-elogind
+ --enable-x11-autolaunch
+
make
}