summaryrefslogtreecommitdiff
path: root/pcr/freefilesync/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/freefilesync/PKGBUILD')
-rw-r--r--pcr/freefilesync/PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/pcr/freefilesync/PKGBUILD b/pcr/freefilesync/PKGBUILD
new file mode 100644
index 000000000..182fd13b7
--- /dev/null
+++ b/pcr/freefilesync/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer : freaj <freaj@riseup.net>
+# Contributor (Arch): chenxing <cxcxcxcx AT gmail DOT com>
+# Contributor (Arch): Michael Burkhard <Michael DOT Burkhard AT web DOT de>
+# Maintainer (Arch): alexmo82 <25396682 AT live DOT it>
+
+pkgname=freefilesync
+pkgver=6.14
+pkgrel=0
+pkgdesc="Visual folder comparison and synchronization"
+arch=('any')
+url="http://sourceforge.net/projects/freefilesync/"
+license=('GPLv3')
+depends=(wxgtk webkitgtk2 boost)
+conflicts=(freefilesync-ubuntu)
+source=("http://downloads.sourceforge.net/project/zenxml/zenXml_2.1.zip"
+ "http://downloads.sourceforge.net/project/freefilesync/FreeFileSync/$pkgver/FreeFileSync_${pkgver}_Source.zip"
+ FreeFileSync.desktop
+ ffsicon.png
+ RealtimeSync.desktop
+ rtsicon.png)
+md5sums=('d6eee89cdf8b08a2e057338013752c62'
+ 'e9ccd9ef085fdfc7401472d2e9a3c90f'
+ 'a7be7841f47f29d8e6210c8ab592a1e3'
+ '1f452dff6f970d95839411008d86250b'
+ '90152f1021f2d6fb6ab4fa511dc60fa9'
+ 'ee5587fa0a8d906ad416564e4daf5a06')
+
+build() {
+ cd ${srcdir}/FreeFileSync/Source
+ make launchpad
+
+ cd RealtimeSync
+ make launchpad
+}
+
+package() {
+ cd ${srcdir}/FreeFileSync/Source
+ make DESTDIR=${pkgdir} install
+
+ cd RealtimeSync
+ make DESTDIR=${pkgdir} install
+
+ cd ${srcdir}
+ install -Dm644 FreeFileSync.desktop $pkgdir/usr/share/applications/FreeFileSync.desktop
+ install -Dm644 ffsicon.png $pkgdir/usr/share/pixmaps/ffsicon.png
+ install -Dm644 RealtimeSync.desktop $pkgdir/usr/share/applications/RealtimeSync.desktop
+ install -Dm644 rtsicon.png $pkgdir/usr/share/pixmaps/rtsicon.png
+}